Question / Help Rendering Lag/Encoder Overload 23.0.0

MadVaper

New Member
I've always had a bit of an issue with rendering lag, but usually it dips by a handful of frames pretty infrequently. Ever since updating yesterday to 23.0, it's gotten worse, despite the fact that this build was intended to improve performance.

Log: https://obsproject.com/logs/SZKOhScROHYwZR9e

Using the new nVENC encoder, i7-7700k at 5GHz, 2080 Ti, 32Gb DDR4.

The weird thing is that I now dip from 60fps to around 30-40fps during times of low load, such as loading screens. I get this drop in stream FPS when my GPU is at about 30% load and my CPU is 50% load. In-game, I still get occasional dips between 55-59 fps, but still, my CPU and GPU should both have enough headroom, as they stay in the 80% - 90% range.

Another thing to note is that I use G-sync 144Hz on my main monitor with another two 60Hz screens. Game is only running on the main monitor. V-Sync is enabled, but only kicks in at 144fps, which this particular game (Anthem) never reaches. Unless a game has an in-game fps limiter, I can't really cap fps lower than 144. But again, this problem is at its worst during periods of low load.

I've tried looking around and tweaking some settings, but the issue persists no matter what I try to do. Any insights would be appreciated.
 

MadVaper

New Member
Just an update. Just tried Resident Evil 2. While in menus and in-game, OBS fps is averaging 41fps. Game fps capped to 144 via v-sync, GPU load at 60%, CPU load around 50%. This is worse than before the update where it would occasionally dip into the mid-50s.

Also, enabling monitor capture instead of game capture eliminates the problem completely and OBS is completely smooth. However, the game caps itself to 60fps, input lag presents itself, and the gameplay is more stuttery than the OBS preview screen.

EDIT: Another update - just went back and tried RE2 again with the old encoder...no drops. So it's not the build that's causing issues, definitely the new encoder. Oddly enough, monitor capture still produces PERFECTLY smooth footage, smoother than game capture, but makes games unplayable.
 
Last edited:

themigty

New Member
Having this problem too. I never ever had encoding lag with Nvenc, since it makes no sense - it's using a dedicated encoder. The "Video Encode" graph on my task manager never reaches 50%, but OBS still gives me an "Encoder overload" errors on the bottom left.

I do sometimes get high GPU usage in games like Apex, however it's usually below 0.1% rendering frames dropped since I limited my in-game FPS and therefore resolved the "classic" high GPU usage issue.

Software encoder X264 runs well, without any problems, I just think it's silly to use it because I got a dedicated encoder in my setup and I can't use it anymore since the update came out.

Specs: Ryzen 2700, RTX 2070

I can post logs, but I doubt you'll see anything special.
 

MadVaper

New Member
Possible "solution"... turn off anything that uses CUDA. Under "Video," turn Downscale Filter to Bilinear. Under "Output," use the Quality preset or lower, uncheck both Look-ahead and Psycho Visual Tuning, and set Max B-Frames to 0. This even allowed me to go up to 1080p60 from 720p60 with only a quick drop into the mid-50s in fps. Disabling the preview seems to have gotten rid of even that quick drop.

What I can't say is which looks better, new nVENC with all these settings disabled, or old nVENC with more quality settings enabled. For me, it seems to be a problem with any setting that uses CUDA, yet my GPU still only maxes out at around 60%. Tested with Resident Evil 2, constant 144fps.

Any ideas? Anyone? Bueller?
 

themigty

New Member
Update: Problem is appears to be gone after uninstalling OBS, clearing all folders and re-doing settings, where I mostly used default values.
 

Gianluca Leal

New Member
I am also having this issue.
Prior to v23, I would only get short, occasional hiccups in my NVENC encodings; now it's very frequent and long.
Even when switching back to the older FFMPEG implementation of NVENC instead of using the new SDK one, the hiccups persist.
The SDK hiccups are crazy, while the FFMPEG ones are slightly less but still painful compared to that of v22

Update: Problem is appears to be gone after uninstalling OBS, clearing all folders and re-doing settings, where I mostly used default values.
You're certain on this? You went completely factory reset on OBS and it removed your stutters?
What about your scenes? You deleted all your settings and profiles but did you at least import your scenes?
I have a LOT of scenes and I don't want to have to make them all again from scratch.
 

branrivera1991

New Member
So day one of the update i ran my stream perfecting without any dropped frames in OBS. 2nd day i was contantly droping between 40 fps to 60 fps. This is without changing any obs settings from day one. Not sure what is the cause of this as well.

My build is i7 8700k, RTX 2080, 16gb ram,

My obs settings are the recommended settings from nvidia directly
 

MadVaper

New Member
You're certain on this? You went completely factory reset on OBS and it removed your stutters?
What about your scenes? You deleted all your settings and profiles but did you at least import your scenes?
I have a LOT of scenes and I don't want to have to make them all again from scratch.
I'd also like to know if this is still working for you, and if you were able to do it without rebuilding your scenes.
 

Intrilo

New Member
Try turning off game mode in windows settings, it fixed my rendering issues

Open Settings app from Start Menu, click on the Gaming icon, then click on Game Mode tab in left-side pane. Now set "Use Game Mode" option to OFF to disable Game Mode system wide.
 

themigty

New Member
I am also having this issue.
Prior to v23, I would only get short, occasional hiccups in my NVENC encodings; now it's very frequent and long.
Even when switching back to the older FFMPEG implementation of NVENC instead of using the new SDK one, the hiccups persist.
The SDK hiccups are crazy, while the FFMPEG ones are slightly less but still painful compared to that of v22



You're certain on this? You went completely factory reset on OBS and it removed your stutters?
What about your scenes? You deleted all your settings and profiles but did you at least import your scenes?
I have a LOT of scenes and I don't want to have to make them all again from scratch.
So OBS was working flawlessly for a bout 2 days, playing Apex with no problem but on day 3 I had a longer session and after about 4 hours or so it started choking hard, constantly giving me the same error again (Encoding overloaded on NVENC) and I gave up and swapped to x264 where I dropped no frames at all.
Sorry for false hope, it just seemed to work for a few days. ;_;
 

RaffaSK

New Member
Estou tendo esse mesmo problema, do nada meus fps de 60 a 40 - 30, eu tenho um i7-9700K, RTX 2060 com 24gb Ram, testei tudo e nada funcionou, até nas configurações avançadas do obs eu mudei o sistema. NV12 a I420 cor, e diminuiu para quase nenhuma queda.
 
Top