Question / Help Recording Preview and Output Video lagged frames

joeygallegos

New Member
Hello. When I try to record in OBS (not stream) I am getting very laggy footage on preview and the output file when idle and when recording.
During normal menus or static screens, the frames stay at 60 FPS with ~2% CPU usage.
When I load into R6 Siege and start recording the actual gameplay the game does not lose frames, and seems to be play just fine on my main monitor, but has terrible lag and missing frames on OBS preview which is on the screen to my left. During actual gameplay and recording, the frames drop to about 15 FPS with ~10% - ~15% CPU usage.

EDIT: Here is a youtube video with the choppy footage: https://youtu.be/dGcBb6wHuBY

Code:
01:55:09.379: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Joey/Videos/2019-01-11 01-50-40.mp4' stopped
01:55:09.379: Output 'adv_file_output': stopping
01:55:09.379: Output 'adv_file_output': Total frames output: 16039
01:55:09.379: Output 'adv_file_output': Total drawn frames: 6012 (16098 attempted)
01:55:09.379: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 10086 (62.7%)

What I have already done:
  • Followed all the steps on https://obsproject.com/wiki/How-to-disable-Windows-10-Game-Mode which did not resolve the issue. Attached is the log file for the recording as well as the recording itself.
  • Made registry changes (see above).
  • Ran OBS and Siege as administrator.
  • Uninstalled AVerMedia HD Capture software.
  • Tried other games (BF4, BF3, BFV, Minecraft) same issue produced in output recording and preview.
  • Ended Skype, Discord and Chrome processes running in taskman.
 

Attachments

  • 2019-01-11 01-42-16.txt
    102.2 KB · Views: 16
Last edited:

Narcogen

Active Member
Do not use the OpenGL renderer. Switch back to the DirectX renderer.

01:42:17.089: Initializing OpenGL...
01:42:17.542: Loading up OpenGL on adapter NVIDIA Corporation GeForce GTX 1050 Ti/PCIe/SSE2
01:42:17.542: OpenGL loaded successfully, version 4.6.0 NVIDIA 417.35, shading language 4.60 NVIDIA
01:42:17.542: Warning: The OpenGL renderer is currently in use. On windows, the OpenGL renderer can decrease capture performance due to the lack of specific features used to maximize capture performance. The Direct3D 11 renderer is recommended instead.
01:42:17.598: ---------------------------------


The rendering process is lagging, but at this point I'm not confident that isn't directly caused by using OpenGL, so I would suggest making that change first, then doing another session and uploading another log.

01:55:09.379: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 10086 (62.7%)

The usual solution for this problem is capping the frame rate of the captured application.
 

DEDRICK

Member
If he has OpenGL as a renderer that means he had it on long ago then updated to the newest version and it still retained the old renderer. It's not even possible to select it anymore :D

1547342493532.png
 

joeygallegos

New Member
Here's the latest log from the latest recording. I locked Rainbow Six Siege at <= 60 FPS.
During the gameplay on my main monitor, I had no issues with FPS or lagging, but during the recording and on the preview I was losing a lot of frames with a lot of lag. I did update recently (did not have this issue before) and switched to DirectX. @DEDRICK is correct, and that option no longer shows for me.

Here's the footage produced from the recording:
https://youtu.be/3VAyDw3i9w4

At a glance:
Code:
22:48:27.057: ==== Recording Start ===============================================
22:48:27.057: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/Joey/Videos/2019-01-12 22-48-26.mp4'...
22:48:30.675: [game-capture: 'Game Capture'] d3d11 shared texture capture successful
22:48:30.677: [game-capture: 'Game Capture'] shared texture capture successful
22:53:57.859: [game-capture: 'Game Capture'] ----------------- d3d11 capture freed ----------------
22:53:59.910: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Joey/Videos/2019-01-12 22-48-26.mp4' stopped
22:53:59.910: Output 'adv_file_output': stopping
22:53:59.910: Output 'adv_file_output': Total frames output: 19927
22:53:59.910: Output 'adv_file_output': Total drawn frames: 8433 (19972 attempted)
22:53:59.910: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 11539 (57.8%)
22:53:59.911: ==== Recording Stop ================================================

Any ideas?
 

Attachments

  • new-log.txt
    8.1 KB · Views: 12

joeygallegos

New Member
I just played Battlefield 4 on medium graphic settings and this is the result of the lag/stalls. It's better, but still about 16%
EDIT: Here's the footage of that gameplay: https://youtu.be/1SHzhehLd6c

Code:
23:49:29.803: [game-capture: 'Game Capture'] ----------------- d3d11 capture freed ----------------
23:49:29.827: [game-capture: 'Game Capture'] d3d11 shared texture capture successful
23:49:29.840: [game-capture: 'Game Capture'] shared texture capture successful
23:49:30.170: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Joey/Videos/2019-01-12 23-36-58.mp4' stopped
23:49:30.170: Output 'adv_file_output': stopping
23:49:30.170: Output 'adv_file_output': Total frames output: 45070
23:49:30.170: Output 'adv_file_output': Total drawn frames: 37597 (45090 attempted)
23:49:30.170: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 7493 (16.6%)
23:49:30.170: ==== Recording Stop ================================================
 

Attachments

  • log-bf4.txt
    70.2 KB · Views: 11

Narcogen

Active Member
With everything else eliminated, that just looks like your 1050 is not capable of letting BF4 render at 1080p60 and also have OBS render those same frames at 1080p60.

The only other thing I see is that you're using game capture on both the game and Discord. Having two game captures in the same scene isn't suggested. Are you switching between them by hiding sources, or are you using Discord as an overlay?
 

joeygallegos

New Member
@Narcogen Discord overlay is disabled and I had it added as a scene to bring over the audio from my calls, but then removed it which did not fix the issue. I guess it is just the graphics card, so I will see about upgrading. There is nothing else to try that you know of?
 
Top