Bug Report QSV(QuickSync) encoder issue when using a different main monitor

#1
As a spoiler to keep this short

Operating System: Windows 10 Pro 64-bit (10.0, Build 17763)
Processor: Intel(R) Core(TM) i5-8600K CPU @ 3.60GHz (6 CPUs), ~3.6GHz
The OnBoard is the Intel(R) UHD Graphics 630
Memory: 16384MB RAM
DirectX Version: DirectX 12
Card name: NVIDIA GeForce GTX 1060 6GB
Main Monitor: 2590G4@1920 x 1080 (32 bit) (144Hz)
Secondary Monitor: MD 20165@1920 x 1080 (32 bit) (60Hz)



There is not really much of an log but I will still add one
Hey all,

so I reinstalled my Windows 10 and set everything up the way I would like it.
While setting up OBS (more for recording purposes than streaming) I ran into an issue that many people seem to have had in the past.

While googling for a solution I found that many people had the issue in different situations.
By trying out all of these and playing around with the settings I noticed that recording with QuickSync can work IF you record while your main monitor is connected to your iGPU. Now from the specs at the top you can tell that I wont connect my 144Hz monitor to my iGPU and constanly swapping games or applications from my second monitor to my main monitor is not a solution for me either. Connecting another HDMI to my main monitor did not fix this either, since then I would have to select the "third" monitor as my main monitor which would just be the HDMI output from my iGPU.

I don't want to make this too long so to get to the point:
Is there anyone that might has a workaround for this issue? Or is this a bug that is known and might get fixed soon?

Thanks for taking your time reading I hope to solve this issue once and for all
 

Attachments

koala

Active Member
#2
I can only say that I just recorded successfully with Quicksync on my machine, and even no monitor was connected to the iGPU. I have two monitors connected to my Nvidia card only, just as you. My Intel HD Graphis is showing up as secondary adapter in my log just like yours.
So there is something on your local machine that makes it not work.
It might be the Intel drivers. My Windows device manager says: Driver Date: 18.11.2018, Driver Version: 25.20.100.6323. Seems a somewhat recent version that came with Windows Update automatically, since I did not update manually for a long time.
 
#3
I can only say that I just recorded successfully with Quicksync on my machine, and even no monitor was connected to the iGPU. I have two monitors connected to my Nvidia card only, just as you. My Intel HD Graphis is showing up as secondary adapter in my log just like yours.
So there is something on your local machine that makes it not work.
It might be the Intel drivers. My Windows device manager says: Driver Date: 18.11.2018, Driver Version: 25.20.100.6323. Seems a somewhat recent version that came with Windows Update automatically, since I did not update manually for a long time.
I will try and report the results

Edit: Alright I deleted my install drivers using DDU and restarted my PC to do a Windows update.

Windows downloaded the following driver:
Intel Corporation - Display - 12/10/2018 12:00:00 AM - 25.20.100.6471
Which also did not fix the issue.
Capture.PNG

@1920x1080 30 FPS
 
Last edited:
#4
**FIXED**

Alright after uninstalling my driver and doing a Windows update for the "windows driver" it still did not work but I noticed there is a difference in version between me and @koala so I uninstalled my driver again using DDU and installed his driver version.

Now, I can record using my OnBoard GPU with the following settings:


and I could probably push even higher since OBS seems to "only" use 50% of the OnBoard GPU.

Few things that might be worth a notice:
You can also change your "main display" in your BIOS settings, I had that set to my PCI GPU (the Nvidia one). This could have been an issue too I changed it to auto just to be safe.
After a while you will probably download the newest driver for the OnBoard GPU and it might not work again. Try to downgrade, that might fix it.

Else I can just hope that anyone that comes across this issue gets it fixed, and once again thanks to @koala for helping me out

EDIT: Okay it seems like the bitrate doesnt work and the sound also doesnt come through but that another issue
 
Last edited:

koala

Active Member
#5
Bitrate 100000 is a waste of space for recording. Instead, use ICQ or CQP as rate control and choose a value between 15-20 (lower values mean better quality). With these rate controls, the quality is constant and the bitrate is adapted to whatever is required to achieve the given quality.
 
#6
Bitrate 100000 is a waste of space for recording. Instead, use ICQ or CQP as rate control and choose a value between 15-20 (lower values mean better quality). With these rate controls, the quality is constant and the bitrate is adapted to whatever is required to achieve the given quality.
This advice is great!
I thought I was limited to 40.000 bitrate but after trying out ICQ with 15 it shows 150.000
Not sure what it did but I will do some research, thanks!
 
Top