OBS won't start after sudo apt-get upgrade


New Member
Hi, I was running a live stream in OBS and did a system upgrade, but when I tried to open OBS again, I got the "failed to initialize video gpu not supported linux" message. I tried the solution that I found online, running the command LIBGL_ALWAYS_SOFTARE=1 obs on the terminal, but it didn't work. When I click on the obs icon it just doesn't open, and when I run the command obs and the LIBGL one, I get this message:

Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: CPU Name: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
info: CPU Speed: 847.273MHz
info: Physical Cores: 4, Logical Cores: 8
info: Physical Memory: 15994MB Total, 1709MB Free
info: Kernel Version: Linux 4.15.0-20-generic
info: Distribution: "Linux Mint" "19"
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.19.6
info: Portable mode: false
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /usr/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_clicked()
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_destroyed()
QMetaObject::connectSlotsByName: No matching signal for on_actionGridMode_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_program_customContextMenuRequested(QPoint)
QMetaObject::connectSlotsByName: No matching signal for on_transitionRemove_clicked()
info: OBS 26.0.2 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
    samples per sec: 48000
    speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
The X11 connection broke: No error (code 0)
XIO:  fatal IO error 22 (Invalid argument) on X server ":0"
      after 30 requests (30 known processed) with 0 events remaining.

Any tips? I tried removing it and installing it again but no luck.


New Member
Set the environmental variable QT_AUTO_SCREEN_SCALE_FACTOR=0 and or turn off high DPI scaling in your display options.