Bug Report OBS Virtual Cam output is blury and pixelish

MrSpock

Member
OK! By using an earlier version of NDI in Windows, at least the VLC Output is now clean (still need to set the ratio manually to 16:9)
Additional i saw that zoom does not offer 1080p Streaming for all users.

The Results i had with the Linux test, could be explained by the size (720p) and added a strong shitty compression. :)
 

demiguel.m

New Member
I'm starting to think is the same for everyone but nobody seems to use for desktop/text sharing?
Same bad quality resolution with NDI plugin and Virtual Input.
 

MrSpock

Member
OK! conclusion. I Tested now on a second machine with a all UpToDate setup. To make it short!
Here is a Tutorial to verify that OBS and NDI is not the Issue.

Make shure you have set the Output and scaling in OBS to 1080p

Plugin: Virtual Camera
start blugin no settings needed!

Plugin: NDI
make shure after you started to plugin to set in the Virtual Input client the video also to 1080 (right bottom corner of your desktop)

Test device: Show Output Picture in VLC the CORRECT way (I use the German version, so maybe the words differ)!
VLC> FILE> open capture device (ctrl+c)> Change video device to NDI/virtual camera> click advanced options> Set ratio from 4:3 to 16:9> OK > Play!

Now you see the Output your Plugin is giving to all other programs.

If anybody needs Service, Add me on LinkedIn ;)
www.linkedin.com/in/artur-s-levi
 
Last edited:

MrSpock

Member
OK, just Installed a fresh windows 10 1903 and the error is back! Funny Thing... Using older version of OBS (24.0.3) gives better results!
 

demiguel.m

New Member
I tried a bunch of different things (my monitor is 2K and I even try to reduce to 1080 with the same results), and nothings seems to work.
I'll try the YUY2 thing you mentioned!
 

MrSpock

Member
I will write later how to set the colorformat manually in vlc.
The issue is related how windows Interpret the colorformal. If i open the ndi stream on a second pc in the network, the output is flawless.

If i open it on the local vlc the output is unusable!
 

demiguel.m

New Member
Testing NDI+VLC with UYVY, everything works how it should. I don't even need to change the video output en OBS to 1080. Works a little bit cleaner with 1440 in video base and output. The question is the same you asked in the other threat: How can we put that colorformat as default?
 

MrSpock

Member
Testing NDI+VLC with UYVY, everything works how it should. I don't even need to change the video output en OBS to 1080. Works a little bit cleaner with 1440 in video base and output. The question is the same you asked in the other threat: How can we put that colorformat as default?
Thing is, all my other Systems play YUY2 without any issues. I saw that Win 10 has/had issues playing YUY2 .

This time, I setup a clean Win10 1909, just installed NVIDIA Drivers and OBS+NDI and VLC. This bug come right away!
It is a DirectShow decoding error i think.
 

MrSpock

Member
at least in zoom. the output looks ok... i installed meanwhile a shark 007 Codec pack.... maybe this helped a little
 

demiguel.m

New Member
Thing is, all my other Systems play YUY2 without any issues. I saw that Win 10 has/had issues playing YUY2 .

This time, I setup a clean Win10 1909, just installed NVIDIA Drivers and OBS+NDI and VLC. This bug come right away!
I have two pc. I9 9900K and laptop dell XPS 2019 i7 all updated, nvidia, w10 1909, zoom, obs, scripts, plugins... behaviour is exactly the same.
I’ll test an iMac in a while and post.
[/QUOTE]
 

demiguel.m

New Member
It seems to be a little more complicated in MacOs than windows and with Catalina is a pain in the ass.
I did not figure out how to do it yet without disabling SIP...
 
Top