Obs studio crashes when I try to record with h264

_deak

New Member
Hello, can anybody tell me why can't I make OBS work with h264 encodig?
OBS shows an alert telling that it couldn't start the outuput. That if I am using NVENC orAMD, I shuolud make sure that my drivers are up do date, and they are.

Im not interested in recording with X264, I need to use h264 due to my hardware. Before I was able of usinig H264 to stream and record, but when i try to stream with h264on Facebook it shows the same messsage.

I'll leave log file if anybody can help me and other users whom are facing the same struggle.

Thanks a lot!
 

Attachments

  • 2021-06-12 16-34-44.txt
    6.6 KB · Views: 28

qhobbes

Active Member
Try running OBS as Admin. Right click on shortcut, properties, advanced, check box, ok, apply, ok.
 

_deak

New Member
I attach another log file, it failed again attempting to record Valorant
 

Attachments

  • 2021-06-13 01-21-31.txt
    10.4 KB · Views: 27

_deak

New Member
This is being done with updated chipset drivers, gpu/monitor drivers reinstalled from site. Obs updated to latest version and given admin permsissions. Processor is overclocked but it worked just fine before with same specs AMD same BIOS ver. Obviously not drivers. on the logs i can see this AMF_NOT_FOUND and AMF_OPENCL_FAILED alerts.
 

_deak

New Member
After reading a lot of threads and installing many plugis I can deduce the problem is new updates, not systems.
OBS 27.0.1 crashes too even running as admin and win7 compatible and allowing OpenCL.
on logs it says: H264/AVC: Supported.
 

Attachments

  • 2021-06-17 13-20-10.txt
    8.6 KB · Views: 26
Top