OBS stops responding indefinitely when trying to access the properties of a new or existing video capture device


New Member
Hi there,

I'm at a loss with this, every time I try to add a new video capture device source or edit the properties of an existing one OBS freezes (not responding app) and I have to force close it with task manager.
I'm running windows 10 21H2 and the latest version of OBS, this has persisted through multiple updates of both.
There are no crash logs as the app doesnt technically crashes it just stops responding.
Sometimes I can get it working briefly by installing an older version of OBS and then updating the new one but then it breaks again by next reboot.

I've tried completely uninstalling OBS (even used REVO to make sure there were no lingering reg files etc) and reinstalling, deleting and recreating all profiles and scenes (this worked briefly on a completely clean install but stopped after next reboot), updated my drivers for everything and removed any old unused ones.

I've seen quite a few people with this same issue dating back to a couple of years ago and even more of them recently, but no one seems to have a concrete fix.

Please could someone help? Any idea would be greatly appreciated.