Resource icon

obs-ndi - NewTek NDI™ integration into OBS Studio 4.9.1

fracta

New Member
Hello,
I am not able to see the NDI source on OBS. I am on macOS Sierra, running OBS 24.0.6, I installed successfully the NDI.pkg & NDI runtime package....
Shall I open skype to be able to see the plugin in the tool menu or add source menu ?
thanks for your help
fracta
problem solved using this installer for Mac: Mac OS
 

nogard

New Member
Hey,
I have found some information about my doubt, but I am not clear.
What settings should I use for video output?

option 1
Gaming PC:
Base (canvas) resolution: 2560:1440
Output (scaled) resolution: 1920:1080
Streaming PC:
Base (canvas) resolution: 1920:1080
Output (scaled) resolution: 1920:1080

option 2
Gaming PC:
Base (canvas) resolution: 2560:1440
Output (scaled) resolution: 2560:1440
Streaming PC:
Base (canvas) resolution: 2560:1440
Output (scaled) resolution: 1920:1080

option 3
Gaming PC:
Base (canvas) resolution: 2560:1440
Output (scaled) resolution: 1920:1080
Streaming PC:
Base (canvas) resolution: 2560:1440
Output (scaled) resolution: 1920:1080

i´m using NDI Plugin and the streaming PC is encoding using x264
 

hquinn09

New Member
Fracta, I am having the same problem. Have installed latest updates for Mac (Catalina), OBS (24.0.6) and OBS Link (1.0.1) and no NDI Plugin is showing up. Any help would be nice. Thanks!
 

lionfeather

New Member
I've installed OBS, the NDI plugin, and the NDI camera app for the iPhone. I see NDI as a source in OBS, but I don't see my phone with the app running. It's not available under source name. What might I have missed?
 

lionfeather

New Member
I've installed OBS, the NDI plugin, and the NDI camera app for the iPhone. I see NDI as a source in OBS, but I don't see my phone with the app running. It's not available under source name. What might I have missed?
found the answer to my own question....
I had to open up a port in my routers firewall 5353 to be precise. I also had to shut off the widows defender private firewall. I did try to create an inbound rule to allow 5353 thru, but that's not enough. Maybe I'll solve that bit with time.
Anyway just want to share the answer with you.
 

NevetsA

New Member
Is there any information as to when and if the Android app will be available? Is there a way to sideload it....legally? From what I have read here NDI is a very useful tool.
 

Brotuulaan

New Member
Installed it today but can't use it because any time it's active, it disrupts the audio feed from my other sources—regardless of any audio setting I've found.

If I turn off the NDI feed from my phone, it leaves a static shot of the last frame on the screen and the audio works fine.

If I hide the NDI source, the audio works fine.

But if the feed is live and the source is visible, all other audio just becomes a bubbly, jittery mess. This is regardless of the BDI audio being enabled or what video format I'm using to stream/record.
 

jbreher

New Member
I'm one more person reporting that, after installing (using the linked explicitly Catalina-compatible file libNDI_for_Mac.pkgt), and relaunching OBS (or rebooting the entire computer for that matter), I do not have an NDI entry in OBS's Tools menu. Maybe I've been insuffificently persistent, but an hour of poking around has not unearthed a solution. Any help would be appreciated.
Log file: https://obsproject.com/logs/w3dJ9n2k9phGu4fW
 

Narcogen

Active Member
I'm one more person reporting that, after installing (using the linked explicitly Catalina-compatible file libNDI_for_Mac.pkgt), and relaunching OBS (or rebooting the entire computer for that matter), I do not have an NDI entry in OBS's Tools menu. Maybe I've been insuffificently persistent, but an hour of poking around has not unearthed a solution. Any help would be appreciated.
Log file: https://obsproject.com/logs/w3dJ9n2k9phGu4fW

You may have installed the NDI runtime (the NDI library) but you haven't installed the NDI plugin for OBS, at least not successfully.

Below is the portion of your log where OBS loads modules. If a module loads, it's listed here. If it doesn't, an error appears here. The obs-ndi.so file does not appear here, which means it isn't installed.


21:34:45.832: Loaded Modules:
21:34:45.832: vlc-video.so
21:34:45.832: text-freetype2.so
21:34:45.832: rtmp-services.so
21:34:45.832: obs-x264.so
21:34:45.832: obs-vst.so
21:34:45.832: obs-transitions.so
21:34:45.832: obs-outputs.so
21:34:45.832: obs-libfdk.so
21:34:45.832: obs-filters.so
21:34:45.832: obs-ffmpeg.so
21:34:45.832: obs-browser.so
21:34:45.832: mac-vth264.so
21:34:45.832: mac-syphon.so
21:34:45.832: mac-decklink.so
21:34:45.832: mac-capture.so
21:34:45.832: mac-avcapture.so
21:34:45.832: linux-jack.so
21:34:45.832: image-source.so
21:34:45.832: frontend-tools.so
21:34:45.832: decklink-ouput-ui.so
21:34:45.832: coreaudio-encoder.so
21:34:45.832: ---------------------------------
21:34:45.833: os_dlopen(../obs-plugins/obs-browser->../obs-plugins/obs-browser.so): dlopen(../obs-plugins/obs-browser.so, 257): image not found
 

jbreher

New Member
ThAnks. Though I must admit a heap of puzzlement. Is the installer something other than the libNDI_for_Mac.pkg file as listed on the page https://github.com/Palakis/obs-ndi/releases/tag/4.7.1?

Edit: or do maybe I need both? The instructions as I interpret them are Catalina needs a manual install of libNDI_for_Mac.pkg instead of obs-ndi-4.7.1-macOS.pkg which is for earlier MacOS. But maybe both are required on Catalina? If the latter, the instructions would seem to be improved by making this explicit.
 
Last edited:

jbreher

New Member
Must require both. I have tentative success -- at least I see an entry 'NDI Output Settings' on the tools menu. Consider my problem solved.
 

jbreher

New Member
Next snag - as soon as I add an NDI source, OBS crashes.
Below is a screenshot taken immediately before confirming the dialog for the settings for Add 'NDI Source', after pressing the [Defaults] button, and selecting my iPhone in the Source Name dropdown. As soon as I click [OK], OBS crashes.
The window above OBS is the NewTek NDI Video Monitor, which is displaying the intended NDI feed. It remains up and running.
The phone is running NewTek NDI HX Camera.
Results are the same if I terminate NDI Video Monitor and run again.

Any suggestions for troubleshooting?

Hm. Pic too large to upload. Posted it to iiimgur:
4rROAP5.png
 

Artem.ru

New Member
Can I do this using this plugin and the ZOOM program?
skype-content-creator-full-sized.png

P.S. I know that Skype has built-in NDI - so implementing it in it is very easy. But I need to do it for ZOOM!
 

Narcogen

Active Member
Next snag - as soon as I add an NDI source, OBS crashes.
Below is a screenshot taken immediately before confirming the dialog for the settings for Add 'NDI Source', after pressing the [Defaults] button, and selecting my iPhone in the Source Name dropdown. As soon as I click [OK], OBS crashes.
The window above OBS is the NewTek NDI Video Monitor, which is displaying the intended NDI feed. It remains up and running.
The phone is running NewTek NDI HX Camera.
Results are the same if I terminate NDI Video Monitor and run again.

Any suggestions for troubleshooting?

Hm. Pic too large to upload. Posted it to iiimgur:

You've now progressed past your first issue (didn't install the plugin) to the one everyone else on MacOS now has, which is that the 4.5 version of the NDI library causes OBS-NDI to crash. If you didn't already have 4.0 or 4.0 of the NDI runtime downloaded, you may be out of luck until one of these things happens: 1) NewTek updates 4.5 to resolve the crash issue; 2) OBS-NDI updates the plugin to resolve the crash issue; 3) NewTek restores a pre-4.5 MacOS NDI download for users wishing to downgrade; 4) You get an older NDI runtime from another source, uninstall 4.5, and install that older version.
 

jbreher

New Member
You've now progressed past your first issue (didn't install the plugin) to the one everyone else on MacOS now has, which is that the 4.5 version of the NDI library causes OBS-NDI to crash. ...you may be out of luck until ... 4) You get an older NDI runtime from another source, uninstall 4.5, and install that older version.

Thanks again for your reply.

I guess I'll put the call out: Does anyone here (that may be following along) know where I can find an older copy of the NDI runtime?
 

Narcogen

Active Member
I'm one more person reporting that, after installing (using the linked explicitly Catalina-compatible file libNDI_for_Mac.pkgt), and relaunching OBS (or rebooting the entire computer for that matter), I do not have an NDI entry in OBS's Tools menu. Maybe I've been insuffificently persistent, but an hour of poking around has not unearthed a solution. Any help would be appreciated.
Log file: https://obsproject.com/logs/w3dJ9n2k9phGu4fW

https://obsproject.com/forum/thread...ing-source-mac-high-sierra.117404/post-445745
 

Palakis

Developer

teacherguy

New Member
Next snag - as soon as I add an NDI source, OBS crashes.
Below is a screenshot taken immediately before confirming the dialog for the settings for Add 'NDI Source', after pressing the [Defaults] button, and selecting my iPhone in the Source Name dropdown. As soon as I click [OK], OBS crashes.
The window above OBS is the NewTek NDI Video Monitor, which is displaying the intended NDI feed. It remains up and running.
The phone is running NewTek NDI HX Camera.
Results are the same if I terminate NDI Video Monitor and run again.

Any suggestions for troubleshooting?

Hm. Pic too large to upload. Posted it to iiimgur:
4rROAP5.png
I have had some success by pressing neither "OK" or "Cancel." Instead, quit OBS. You will get a warning asking if you want to save changes. Say yes to that. When you re-open OBS, hopefully you will be good to go.
 

DiWoWo

New Member
I experience stuttering issues with the NDI runtime/plugin system when broadcasting from my Win10 Gaming PC to my second PC which is running on Fedora Linux 31. I'm trying this since many NDI Plugin and runtime versions now, always hoping it will fix something but sadly it does not.
If i broadcast from the Fedora machine to Win10 everything works fine. Also when i broadcast via NDI from my Win10 machine to my laptop which runs Win10 as well its working fine. As soon as the Fedora machine receives any video signal via NDI even the preview is stuttering terribly.

Does anyone have any advice i can follow to fix that in any way?

Specs:
Gaming PC: Windows 10 Pro Version 1903 Systembuild 18362.720, OBS Version 25.0.4
Linux PC: Fedora 31 (x86-64), OBS 25.0.4 (linux)

Issues accured with every NDI Plugin/Runtime version that came out in the past.
 
Top