OBS Crashing when i switch scene selections

lithodora

New Member
Crash Log:


Log File:


I have removed plugins not in use.
I have uninstalled SE.Live. Installed OBS-Studio. Reinstalled SE.Live.

I have created a new Scene Collection and when switching to it my OBS crashes instantly.

At this moment I am able to use the scenes within the Scene Collection that opens with OBS seemingly without issue.

I see another post with similar issue this morning. Hoping we may get this resolved quickly as I have a charity stream tomorrow with a dozen other streamers set to be on the show and it's been promoted for over a month.
 

.norman.

Member
ok, so i wasn't the one with the issue so i am not 100% sure about this. but if i remember correctly: the resolution, for at least 1 user, was to uninstall OBS and SE.Live then install an older version of OBS v27.x.x then use the update tool from inside obs to upgrade to the newest version. and this resolved the issue for him.
 

lithodora

New Member
ok, so i wasn't the one with the issue so i am not 100% sure about this. but if i remember correctly: the resolution, for at least 1 user, was to uninstall OBS and SE.Live then install an older version of OBS v27.x.x then use the update tool from inside obs to upgrade to the newest version. and this resolved the issue for him.
My stream setup was so complicated I was trying to do anything but that. It was my next step though... I'll report back.
 

.norman.

Member
My stream setup was so complicated I was trying to do anything but that. It was my next step though... I'll report back.
make a backup! export your scene collection and profile data or backup the %appdata%\obs-studio\basic folder.
 

lithodora

New Member
make a backup! export your scene collection and profile data or backup the %appdata%\obs-studio\basic folder.
I tried updating StreamFX and now OBS won't even load. I've backed up the profiles folders and will be uninstalling each item and trying again. Taking a good break from it all first.
 

lithodora

New Member
After a series of tests installing/uninstalling. Removed StreamFX which was heavily relied upon, but that seems to make the difference. Rebuilding all my scenes/filters now.
 

.norman.

Member
you are the 2nd person in 2 days to tell me that streamFX appeared to be their issue. I use streamFX but only for the blur filter (there is probably a more lightweight solution but i haven't looked) but i have no problems with it. I do suspect that it causes an intermittent crash on closing OBS but it does not affect function (that i can tell) so i have not worried about it too much.
 
Top