Question / Help OBS crashes on start-up

Neuro8630

New Member
Please help.

In a cruel twist of fate OBS stoped working on an ideal night for streaming.

Tried to install and reinstall, deleted the obs folder in the Library, tried switching audio output but NOTHING WORKS!

I don't know what I possibly did to make it act like this every time I start the program but for some reason OBS has decided it HATES running on my computer, even though it had been running fine previously.

I can post the log of the crash report if needed. I am also running on an iMac running El Capitan.
 
Last edited:

Narcogen

Active Member
I think the latest OBS requires Sierra or higher. I believe the requirements on the site haven't been adjusted to reflect this. If you can't update your OS, downgrade to OBS 23.x.
 

Ashraffy

New Member
Hi all. I have had the same issue for the past few weeks or so. I would start OBS studio and it would crash. First I read some old data that it could be related to graphics drivers so I uninstalled them and reinstalled and it seemed to work. The next time I tried to stream and started OBS it crashed. I then tried rebooting in case it didnt close cleanly from its last crash. That seemed to work. Till the next day when it crashed yet again!

So I started to do some extra testing. I had installed streamlabs.OBS live. So I uninstalled it. And lo and behold, OBS Studio started to work properly. So check if you have streamlabs OBS live installed and see what happens when you uninstall it.
 

Ashraffy

New Member
Hi all. I have had the same issue for the past few weeks or so. I would start OBS studio and it would crash. First I read some old data that it could be related to graphics drivers so I uninstalled them and reinstalled and it seemed to work. The next time I tried to stream and started OBS it crashed. I then tried rebooting in case it didnt close cleanly from its last crash. That seemed to work. Till the next day when it crashed yet again!

So I started to do some extra testing. I had installed streamlabs.OBS live. So I uninstalled it. And lo and behold, OBS Studio started to work properly. So check if you have streamlabs OBS live installed and see what happens when you uninstall it.

Oh.. I am using the current OBS Studio version - OBS 24.0.3 (64 bit version) if that makes any difference. I did like the media request option in OBS Live, but the code clearly needs extra work or something. Oh well.
 

Ashraffy

New Member
No. No updates on PC.

I had had no trouble with OBS Studio or obs.live for that matter since I installed it months ago. Suddenly around mid December it would crash on start up. On the PC it would freeze on start up. I got crash logs. Here is the one I got this morning. Thats when I decided to remove OBS studio and try reinstalling it. But before I removed OBS Studio, I removed Streamelements OBS.Live first and OBS studio hasnt crashed since.Also as a precautions, I downloaded streamlabs OBS and copied my scene overlays to it in case the reinstall didnt work . But MAC may be very different. Crash clearly says issue was in obs-plugins and thats what made me think OBS.Live may be the culprit or at least the culprit on the PC.
 

Attachments

  • Crash 2020-01-02 08-57-17.txt
    122.8 KB · Views: 36
Top