OBS branch with AMD VCE support.

GumBang

New Member
there are instructions on the front page of what is required. if you've never setup OBS before I would recommending trying that first as it is a requirement to have the main version installed first anyway. then install this fork from another folder
I have the main version installed and i know how it works bud the problem is i have no idea what to do with the file i download here. Can u help me?
 

jackun

Developer
@GumBang Ok, let's go further back then: get the archive manager to unpack the file from http://7-zip.org/ Winrar should also be capable. Also get MSVC++2013 from OP. Then just unpack the 7z file and run OBS.exe and hope it doesn't crash right out of the gate ;-)
 

dping

Active Member
I have the main version installed and i know how it works bud the problem is i have no idea what to do with the file i download here. Can u help me?
In addition to what jackun said, unzip the files to a folder on your desktop or somewhere where you can put multiple folder and keep track as these are beta builds, keey them organized until you find a version that works best. well this is what I do to compare and see if something works better on one build.

Run the obs.exe from that folder and when you do, you'll see the VCE tab and VCE enabled under the encoding tab. the newest one will best run in AMF to which you will check this option.
Under VCE options tab, set the quality level to one of the three different levels, speed, balanced or quality for anything under 720p@60fps or 1080@30fps. anything over those two and you'll need to use balance or speed.

set your IDR to 2x your FPS or 0 and your GOP to same or double your FPS.
 

jackun

Developer
Yeah, the override doesn't un-grey the quality balance.

With any VBR option checked in VCE tab, you have to go back and uncheck CBR from Encode to change quality balance. but when you press ok then go back in, CBR is rechecked and QB is grey'd again

Ah, while going over older post, I think by VBR you actually meant Const. QP/CRF? "Quality Balance" afaik sets fixed QPs/CFR (atleast I've been setting in OVE/AMF). VBR still uses bitrate unlike QP mode.
 
Last edited:

dping

Active Member
Ah, while going over older post, I think by VBR you actually meant Const. QP? "Quality Balance" afaik sets fixed QPs (atleast I've been setting in OVE/AMF). VBR still uses bitrate unlike QP mode.
I see. so no need for setting the quality balance under the encoder tab when using VBR?
 

RockStaR

New Member
Hey guys, i record with the amd vce codec and i have lags in Sony vegas if i play the clip( only in editing). and this isn't so nice because i always must render the clip if i would like to see if the clip is nice or not.
Maybe some guys have a idea why i have this lags? my pc is more then good:D
 

dping

Active Member
Hey guys, i record with the amd vce codec and i have lags in Sony vegas if i play the clip( only in editing). and this isn't so nice because i always must render the clip if i would like to see if the clip is nice or not.
Maybe some guys have a idea why i have this lags? my pc is more then good:D
post your obs log file
 

meredith

New Member
Here is my driver crashes log when i using 2015-02-08 version.
Streaming about a hour and 30mins, It's just happen.
The driver version is 14.12 Omega
 

Attachments

  • OBSCrashLog2015-02-07_1.txt
    2.9 KB · Views: 23
  • OBSCrashLog2015-02-09_1.txt
    1.6 KB · Views: 20
  • OBSCrashDump2015-02-07_1.dmp
    505.3 KB · Views: 19
Last edited:

Selloh

New Member
Well the 2015-02-08 build wont work for me with AMF at all. No matter what settings i use. (i use it for local recording)
If i press the record button, OBS will create the video file (0 bytes) but wont responding directly after i press the record button.

The 2014-11-23 build works for me. I get some strange bugs with it but it CAN work ^^
Every build after that wont record or freezes with AMF no matter what settings i use.
Max bitrate is mostly 25k depends on the game i play and Buffersize 0.

I would love to give you a crashlog but i dont get one. Only thing i get is this one
Its with the 2015-02-08 build
 

Attachments

  • 2015-02-12-0836-20.log
    8 KB · Views: 21

jackun

Developer
@Selloh What happens when you copy AMF dlls from 2014-11-23 build to newer?

@meredith ok, seems I have to add a function call timeout mechanism some how to detect these driver crashes, heh.
 
Last edited:

dping

Active Member
Well the 2015-02-08 build wont work for me with AMF at all. No matter what settings i use. (i use it for local recording)
If i press the record button, OBS will create the video file (0 bytes) but wont responding directly after i press the record button.

The 2014-11-23 build works for me. I get some strange bugs with it but it CAN work ^^
Every build after that wont record or freezes with AMF no matter what settings i use.
Max bitrate is mostly 25k depends on the game i play and Buffersize 0.

I would love to give you a crashlog but i dont get one. Only thing i get is this one
Its with the 2015-02-08 build
buffer size 0 used to be broken in VCE since that is used to get potentially unlimited bitrate.
 
Last edited:

RockStaR

New Member
Ok i solved my problem. If i record with obs and amd vce everything is okay.
But i record before with dxtorxy and amd vce and then sony vegas lags in editing:;D
 

halsoy

New Member
Atleast mplayer and vlc work with streaming, so a case of flash player not understanding things properly probably. AMF crops it to 1704x720 so if you haven't already, try to set video size to that. Usually a good thing to keep sizes in multiples of 16 or 8.

Sorry, haven't read here the last few days. I just wanted to update that I have a fix for it now. It's probably obvious, but I never tried it before. After reading this I did some experiments. It turns out that if I set my Base Resolution to 2670x1080 and get my downscaling to 1712x720 (257:108 Aspect Ratio) the green line on the right end of the screen goes away. Exactly why I don't know. But I noticed that if I tried to get 1704 instead of 1706 downscaled, the line got thicker. So simple method of elimination, I made the resolution larger. A couple of tries later, and I got the bar to go away All that remained then was to make sure all sources were scaled to fit screen again, so there's no black frames.

Here:



q8526hP.jpg


Now, exactly why it does this you most definitely know better than I. Just, if anyone else has the same issue, this could probably be a fix. If you want to to test some files/whatever to see if there's some way of fixing this nativly in your build, I'd be more than happy to test for you.
 
Top