Question / Help nvidia encoder missing in x64 version

buZZrar

New Member
hi there!
the 64bit version of obs studio is missing the "NVIDIA NVENC H.264" encoder. the 32bit version isn't and works just fine.
the screenshot is showing a selectable nvidia encoder with the 64bit version. but this just came with a "advanced transformation" plugin and is not using the gpu at all.

current running 64bit logs:
 

Attachments

  • 32bit.jpg
    32bit.jpg
    196.5 KB · Views: 810
  • 64bit.jpg
    64bit.jpg
    208.7 KB · Views: 831

vapeahoy

Member
10:22:09.973: Loading up D3D11 on adapter Microsoft Basic Render Driver (0)
10:22:09.974: D3D11 loaded successfully, feature level used: b000
 

koala

Active Member
If the 32-bit version of OBS is able to recognize your graphics adapter, but the 64-bit is not, you have some issue with the 64-bit part of the graphics driver. Whatever it is, it isn't an OBS issue. I recommend you download the most recent Nvidia driver for your GPU directly from the Nvidia webpage and do a full reinstall. Remove the current driver, reboot. Then install the new driver. The Nvidia installer has an option to do a complete re-initialization either during install or uninstall.
 

buZZrar

New Member
If the 32-bit version of OBS is able to recognize your graphics adapter, but the 64-bit is not, you have some issue with the 64-bit part of the graphics driver. Whatever it is, it isn't an OBS issue. I recommend you download the most recent Nvidia driver for your GPU directly from the Nvidia webpage and do a full reinstall. Remove the current driver, reboot. Then install the new driver. The Nvidia installer has an option to do a complete re-initialization either during install or uninstall.
already done that. i used ddu to wipe everything, rebooted and installed the latest drivers. nothing changed.
 

BionicClick

Member
you can be pretty sure its not obs as the long time people said so.

If you don't believe them then download a program trial of vMix... and use its x64 variant. I would assume you have the same issue there due to a driver issue.

Or maybe use slobs to test too... (stream elements OBS)

my x64 OBS works just like fine, used daily.
 

BionicClick

Member
I apologize, but weren't you looking for NVENC not x264? that is x264. not NVENC. that one uses your CPU NOT your GPU (the one you show in VMIX) sorry but the issue persists there as well.
 

buZZrar

New Member
StreamLabs OBS is working fine as well. I'm totaly confused right now.
Nothing to apologize! I dont know too much about encoding/ encoder. I thought the last option from the dropdown (HEVCMain) was NVENC, isnt it?
I got to thank you anyways! StreamLabsOBS is pretty much the same and will do the trick for me.<3
 

Attachments

  • Unbenannt-1.png
    Unbenannt-1.png
    224.2 KB · Views: 227

R1CH

Forum Admin
Developer
You have installed the 3rd party StreamFX plugin on your 64 bit OBS. This overwrites the encoders used by OBS which is why you no longer see NVENC.
 

buZZrar

New Member
You have installed the 3rd party StreamFX plugin on your 64 bit OBS. This overwrites the encoders used by OBS which is why you no longer see NVENC.
as i said earlier, the plugin came in later and just added it's bulls*it. its just cpu encoding. befor i added the plugin, there was nothing else to select besides x264.
 

R1CH

Forum Admin
Developer
You probably have some application specific GPU overrides somewhere. Try renaming the obs-studio folder so it ignores any presets.
 

buZZrar

New Member
You probably have some application specific GPU overrides somewhere. Try renaming the obs-studio folder so it ignores any presets.
That fixed it! Thank you so much! I had the same idea as SL OBS was working without any problems.
 

Xaymar

Active Member
You have installed the 3rd party StreamFX plugin on your 64 bit OBS. This overwrites the encoders used by OBS which is why you no longer see NVENC.

StreamFX does not override any encoders. All the encoders are registered under the "StreamFX-" prefix (for example, NVENC is "StreamFX-nvenc_h264"). Any collisions or overrides only happen if OBS developers went out of their way to use the StreamFX prefix in the actual releases. Please do not make claims that can't be backed up by actual data.
 
Top