NVEnc Feedback thread (2014)

Status
Not open for further replies.

Dwindleflip

New Member
Re: 0.60 test build 7

I find CPU encoding to be better performance wise so far in my testing. On a gtx670 and an I7-4960x, NVENC just hurts game performance too much at the gpu level compared to cpu encoding. Of course this depends on system configurations, where in my case my cpu is barely at 20% usage and my GPU is running starcraft at 2560x1600 at 60fps with extreme settings.

NVENC does lower cpu load of course but the negative effect is your gpu performance takes a hit. With a game like sc2 running at 20% (while streaming obs cpu encoding) cpu usage not even at full clock, it just seems cpu encoding is a better choice than GPU. for comparison, a game like BF4 uses about 35% cpu on my system without obs running. Running NVENC with BF4 which is very gpu intense would hurt performance rather than help it when the cpu has so much more room for usage still.
 

Dwindleflip

New Member
Re: 0.60 test build 7

Isnt there a dedicated hardware encoder on the gpu? Perhaps this shouldnt hurt gpu processing as you say but how about the performance of internal bandwidth on the card with all the extra data being processed? I'm still tinkering with it currently.
 

Boildown

Active Member
Re: 0.60 test build 7

It has to be some dedicated silicon on these GPUs, not using the GPU itself (any more than OBS ordinarily does). Because otherwise we would notice 780s being far faster at encoding than 650s. But we haven't noticed that. They put some silicon on these chips that has essentially never been used until now.
 

Rezal

New Member
Re: 0.60 test build 7

Is there a list of custom encoder settings for Quicksync supported in this build?
 

Floatingthru

Community Helper
Re: 0.60 test build 7

Rezal said:
Is there a list of custom encoder settings for Quicksync supported in this build?

I only know that you can change bframes and couple other of settings that I can't remember off the top of my head. Most of the encoder settings for QSV are hard coded.
 

XeiZ

Member
Re: 0.60 test build 7

Pretty much only bframes and keyint while keyint for twitch... well yea...
 

Floatingthru

Community Helper
Re: 0.60 test build 9

Rezal said:
So nothing on trellis, target usage, mbbrc and extbrc?

No, Palana already set it to the highest possible quality. If you want better QSV you are going to have to upgrade platforms, unless you are already on Haswell of course.
 

Jim

Forum Admin
Jim
Forum Moderator
Developer
Re: 0.60 test build 9

Elgato should be fine, not much of the directshow code was changed. Can you verify that it's working fine with 0.592? Also, you must post a log with that.
 

Lanscaper

New Member
Re: 0.60 test build 9

Live gamer portable feedback:

Seems to be fixed. I just did a 3hr + stream, to twitch.tv. After reviewing the video recording I see none of that audio desync that made me regret purchasing this live gamer portable.

I will be doing some more testing but was happy to see this build specifically made mention of addressing this issue.

Thank you for your hard work Jim (and anyone else that may be involved)

** EDIT ** Confirmed using 0.60 build 9 at this time, thanks Jim
 

Jim

Forum Admin
Jim
Forum Moderator
Developer
Re: 0.60 test build 9

With test 9? Excellent, thank you for letting me know, I'm actually very grateful specifically for that feedback.
 
0.60 test build says this is not a valid win32 application

I have downloaded the latest test build as to 24/1/14 from sourceforge and got a zip file with 2 so folders, 32bit and 64 bit.
I have a 32bit windows xp service pack 3 system.
When I run both OBS.exe files from each of the folder it says this is not a valid win32 application. The OBS.EXE from 32bit folder shows a black fan like icon and the other shows no icon. I can't figure out what is causing this.
Hoping that the problem will be fixed soon as possible,
Farseen
 

Xphome

Member
Re: 0.60 test build says this is not a valid win32 applicati

farseenabdulsalam said:
I have downloaded the latest test build as to 24/1/14 from sourceforge and got a zip file with 2 so folders, 32bit and 64 bit.
I have a 32bit windows xp service pack 3 system.
When I run both OBS.exe files from each of the folder it says this is not a valid win32 application. The OBS.EXE from 32bit folder shows a black fan like icon and the other shows no icon. I can't figure out what is causing this.
Hoping that the problem will be fixed soon as possible,
Farseen
OBS requires DX10 which is not available on XP.
 

T1wka

New Member
Re: 0.60 test build 9

Can you resolve the conflict with the anti-cheat frost? Because this program blocks the capture of full-screen image in games.
 

dodgepong

Administrator
Forum Admin
Re: 0.60 test build 9

That's an issue with the anti-cheat program, not OBS's fault. If an anti-cheat program disallows applications from hooking a game, then OBS can't capture the game.
 
Status
Not open for further replies.
Top