New audio issue in OBS (DJ controller with sound card)

darude24

New Member
hi friends, hoping you can help a DJ with some audio issues! Screenshots and descriptions below

Problem: My microphone (connected to DJ controller which is connected to an external sound card) is not registering audio in OBS / my stream. I can hear my voice in my headphones (connected to DJ controller) but it's not registering on the computer.

Background: It all used to work basically out of the box when I set it up a year ago. The only change that happened was I tried setting up Xbox Game Bar to record my screen for some video game... Since then it's not worked and I've tried reverting as many of the changes I can remember. I'm sure it messed something up because before that - when I DJ stream the music is playing, I can talk in the mic and it registers in OBS + stream can hear it. I can see the audio line increase when I talk over the track. It was on the same Audio Output Channel, it didn't have a separate Input channel (since the mic is connected to the controller which is all the same output?).

The controller is Pioneer XDJ-RR, the software I use is called Rekordbox. All drivers are up to date, have tried restarting, plugging and unplugging the sound card. I'm considering resetting OBS completely but I'm wondering - can you restore your scenes / profiles? I exported them and saved the .json so I'm hoping when I do that I can restore all my channels and stream setup? Do you see the problem in the settings or any other recommendations??

Been troubleshooting for 2 days and starting to hit a wall... please help. Controller hasn't been dropped or spilled on, same for the microphone. Mic is working (I can hear it in my headphones) but it's stopped outputting in OBS... "Speakers (2-USB Audio CODEC)" is the external sound card.


image.png


image (1).png
image (2).png


Rekordbox audio settings page:
image (3).png
 

Attachments

  • image (3).png
    image (3).png
    76.9 KB · Views: 24

darude24

New Member
bump? is that ok? i was told to set sample rate to 44k instead of 48k everywhere since 48 causes issues. still doesn't work
 
Top