My streams common fps is set to 60 fps but doesn't look 60 fps

FerretBomb

Active Member
That log file does not contain a live streaming or recording session. We need to see a log from one at least 30 seconds in length to be able to diagnose what's going on. Most commonly this is caused by GPU over-loading, forcing OBS to skip frames due to being unable to complete its compositing/rendering tasks (which use a tiny bit of GPU resources).

One immediate problem though, you've set the RGB color range to 'Full' instead of 'Partial' like it should be. Full RGB requires a specialized end-to-end workflow and is only used for recording (never for streaming), and having it set to Full can cause significant color drift problems. Swap it back to Partial in Settings->Advanced.
 

FerretBomb

Active Member
The logfile says you aren't dropping/skipping frames, so most likely it's this:
06:53:41.495: - scene 'Scene':
06:53:41.495: - source: 'Display Capture' (monitor_capture)
06:53:41.495: - source: 'Elgato' (dshow_input)
06:53:41.495: - source: 'Game Capture' (game_capture)
Never have a Display Capture in the same scene as a Game or Window Capture. Display captures can interfere dramatically and cause performance problems (even if they're set non-visible); they should be avoided except as an absolute last resort, not used out of convenience. If you absolutely NEED one for some reason, place it in a second Scene on its own.

Beyond that, your monitor refresh is set at 144hz while you're streaming at 60fps; this causes an uneven pulldown as frames are erratically discarded to pipe that down. Recommend setting your monitor's refresh rate to 120hz instead. As it's a full-integer divisor, that will just discard every other frame and result in smoother motion.
 

swaggy_kb

New Member
The logfile says you aren't dropping/skipping frames, so most likely it's this:

Never have a Display Capture in the same scene as a Game or Window Capture. Display captures can interfere dramatically and cause performance problems (even if they're set non-visible); they should be avoided except as an absolute last resort, not used out of convenience. If you absolutely NEED one for some reason, place it in a second Scene on its own.

Beyond that, your monitor refresh is set at 144hz while you're streaming at 60fps; this causes an uneven pulldown as frames are erratically discarded to pipe that down. Recommend setting your monitor's refresh rate to 120hz instead. As it's a full-integer divisor, that will just discard every other frame and result in smoother motion.


I did a second stream test and it still doesn't seem to be smooth. Do you think its because of my gpu? I also set my monitor to 120 hz.
CLIP: https://clips.twitch.tv/DeafMushyDragonfruitBCWarrior
LOG FILE: below
 

Attachments

FerretBomb

Active Member
Clip looks fairly smooth for the most part. It's possible that it may be just because you're used to seeing it in a higher refresh than 60fps. With that building-example you're also somewhat throwing a worst-case scenario at the encoder with a TON of movement and screen changes. You did drop just under 1% of frames due to your network connection, which could be contributing here and there.

Try dropping your monitor to 60hz and play for a couple of days like that (to give your eyes and brain a chance to adjust to the new 'normal'), see if it looks any more or less smooth than the clip.
 
Top