Missing frequencies in desktop audio recording

Blackyu

New Member
Hello, I'm encountering a problem with desktop audio recording while trying to record a game. The sound itself is mostly fine, but higher and lower frequencies are completely cut out from the recording.
I've tried countless things, changing the recording frequency and even the frequency of my headset, disabling any parameters like exclusive mode, Surround, sound relocate, etc
I'm very confused as I have another installation of OBS on another PC, and it works just fine on there. I even copied the entirety of the settings from that other installation to mine, and the frequencies are still missing.
I've also tried to see if there wasn't a problem with my drivers, but any modification I try to apply doesn't work. Disabling and reenabling the headset and/or its driver doesn't work either.
There has been one time where it managed to record everything without issue, I absolutely don't know what was different between that recording and the previous ones, I couldn't replicate it and it stopped working again after a restart.

It only seems to affect lower and higher frequencies, the rest is completely unchanged, it's like a filter is applied on my sound when there isn't, and shouldn't be any.

I've attached two files, the sound I have on the recording and the sound that I should have. They're both enclosed in zip archives because of attachment format restrictions.

Log file of latest recording is available here :
https://obsproject.com/logs/yMcAOSoqXp3ODz-i

I am at a complete loss, any help would be greatly appreciated
 

Attachments

  • SoundIHave.zip
    469.1 KB · Views: 8
  • SoundIShouldHave.zip
    677.7 KB · Views: 10

Blackyu

New Member
I have managed to find the issue by myself, so, for anyone with the same problem as me who finds this topic :
The issue was not with OBS at all, but rather with some software from my headset provider. I use a CORSAIR headset, and apparently it came with a Gaming Audio Configuration Service and that was what was messing up my audio.

Here's how I disabled it :
  • Use Windows key + R to Run a program (can also be found by typing 'Run' in Start Menu)
  • Type services.msc and press Enter
  • It should open the list of all services on your computer, scroll down to 'Corsair Gaming Audio Configuration Service', and right-click on it.
  • Select 'Properties'
  • Stop the service
  • Once it is stopped, set the service from 'Automatic' to 'Manual'.
  • Apply and save
  • Check your recording audio. If it still doesn't work, try setting the service to 'Disabled' instead and restart your computer.

It did happen because of my CORSAIR headphones, but I'm guessing that a lot of headphones have some gaming audio service, which should be found and disabled if you encounter any issue like this on OBS.

Hope this post helps somebody someday!
 
Top