Laggy recordings with GTX 3090

Denniskuhh

New Member
Hi Everyone,

Recently I bought a brand new PC. It went a bit overkill because I didn't want any annoying issues (how ironic)..

My PC specs are as follows:

AMD Ryzen 9 3950X
Gigabyte VGA Geforce RTX 3090 Vision OC 24G
Corsair iCUE H100i Elite Capellix Liquid
MSI MAG X570 TOMAHAWK WIFI
Corsair DDR4 Vengeance RGB 4x 8GB 3600
Samsung 970 EVO Plus 1TB M.2 SSD
Seagate Enterpise Capacity 3.5 HDD 7TB
Corsair RM850 PSU
Corsair LL120 Fan
Phanteks Eclipse P500A

So when I try and record using OBS I notice the recordings aren't fluid.
It doesn't seem like a stable 60FPS, eventhough it doesn't show any dropped frames. (it does in the logs)

these are my OBS settings:

Nvenc encoder.
1920x1080 60
CQP 18 ( I also tried CBR with only 6k bitrate, but even that seems off)
preset: Highest Quality
Profile: High

This is my log:

19:03:44.272: [jim-nvenc] scaling enabled, falling back to ffmpeg
19:03:44.272: ---------------------------------
19:03:44.272: [NVENC encoder: 'recording_h264'] settings:
19:03:44.272: rate_control: CQP
19:03:44.272: bitrate: 0
19:03:44.272: cqp: 18
19:03:44.272: keyint: 120
19:03:44.272: preset: hq
19:03:44.272: profile: high
19:03:44.272: width: 1920
19:03:44.272: height: 1080
19:03:44.272: 2-pass: true
19:03:44.272: b-frames: 2
19:03:44.272: psycho-aq: 1
19:03:44.272: GPU: 0
19:03:44.272:
19:03:44.428: warning: Using global_quality with nvenc is deprecated. Use qp instead.
19:03:44.499: ---------------------------------
19:03:44.499: [FFmpeg aac encoder: 'Systeem Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:03:44.499:
19:03:44.500: ---------------------------------
19:03:44.500: [FFmpeg aac encoder: 'Microfoon Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:03:44.500:
19:03:44.501: ---------------------------------
19:03:44.501: [FFmpeg aac encoder: 'Discord Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:03:44.501:
19:03:44.502: ---------------------------------
19:03:44.502: [FFmpeg aac encoder: 'Chrome Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:03:44.502:
19:03:44.508: ==== Recording Start ===============================================
19:03:44.508: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/d-vdb/Videos/2021-09-23 19-03-44.mp4'...
19:07:30.210: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/d-vdb/Videos/2021-09-23 19-03-44.mp4' stopped
19:07:30.210: Output 'adv_file_output': stopping
19:07:30.210: Output 'adv_file_output': Total frames output: 13525
19:07:30.210: Output 'adv_file_output': Total drawn frames: 13533 (13542 attempted)
19:07:30.210: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 9 (0.1%)
19:07:30.213: ==== Recording Stop ================================================
19:07:30.276: warning: 2 frames left in the queue on closing
19:07:30.276: warning: 2 frames left in the queue on closing
19:07:30.277: warning: 2 frames left in the queue on closing
19:07:30.277: warning: 2 frames left in the queue on closing

Anyone has any idea what could cause these issues?
I feel like I shouldn't have any issues with a PC like this. At least not with settings like these.

I also did a second recording. This time in 1440p, and what I noticed is it shows both render ánd encoding lag.
my encoder is the GPU, which should be powerfull enough I assume.

Hopefully you can help me out!
With kind regards,

Dennis

Second recording:

19:16:30.424: [jim-nvenc: 'recording_h264'] settings:
19:16:30.424: rate_control: CQP
19:16:30.424: bitrate: 0
19:16:30.424: cqp: 18
19:16:30.424: keyint: 120
19:16:30.424: preset: mq
19:16:30.424: profile: high
19:16:30.424: width: 1920
19:16:30.424: height: 1080
19:16:30.424: 2-pass: true
19:16:30.424: b-frames: 2
19:16:30.424: lookahead: false
19:16:30.424: psycho_aq: true
19:16:30.424:
19:16:30.435: ---------------------------------
19:16:30.435: [FFmpeg aac encoder: 'Systeem Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:16:30.435:
19:16:30.436: ---------------------------------
19:16:30.436: [FFmpeg aac encoder: 'Microfoon Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:16:30.436:
19:16:30.437: ---------------------------------
19:16:30.437: [FFmpeg aac encoder: 'Discord Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:16:30.437:
19:16:30.438: ---------------------------------
19:16:30.438: [FFmpeg aac encoder: 'Chrome Audio'] bitrate: 192, channels: 2, channel_layout: 3
19:16:30.438:
19:16:30.444: ==== Recording Start ===============================================
19:16:30.445: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/d-vdb/Videos/2021-09-23 19-16-30.mp4'...
19:20:50.533: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/d-vdb/Videos/2021-09-23 19-16-30.mp4' stopped
19:20:50.534: Output 'adv_file_output': stopping
19:20:50.534: Output 'adv_file_output': Total frames output: 15589
19:20:50.534: Output 'adv_file_output': Total drawn frames: 15597 (15605 attempted)
19:20:50.534: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 8 (0.1%)
19:20:50.534: Video stopped, number of skipped frames due to encoding lag: 8/15603 (0.1%)
19:20:50.540: ==== Recording Stop ================================================
19:20:50.576: warning: 2 frames left in the queue on closing
19:20:50.577: warning: 2 frames left in the queue on closing
19:20:50.577: warning: 2 frames left in the queue on closing
19:20:50.577: warning: 2 frames left in the queue on closing
 

qhobbes

Active Member
Change your Preset to: Quality and uncheck the box for Psycho Visual Tuning. 2-pass and Psycho Visual Tuning both use additional GPU.
Strongly recommended that you record to MKV instead of MP4.

If still having issues, post full log.
 

Denniskuhh

New Member
Hi qhobbes,

I changed those settings and still have some lag in both rendering and decoding.
Btw, the reason I prefer .mp4 is because .mkv doesn't work with adobe.

anyways, this is my new log:

22:04:20.350: [jim-nvenc: 'recording_h264'] settings:
22:04:20.350: rate_control: CQP
22:04:20.350: bitrate: 0
22:04:20.350: cqp: 18
22:04:20.350: keyint: 120
22:04:20.350: preset: hq
22:04:20.350: profile: high
22:04:20.350: width: 1920
22:04:20.350: height: 1080
22:04:20.350: 2-pass: false
22:04:20.350: b-frames: 2
22:04:20.350: lookahead: false
22:04:20.350: psycho_aq: false
22:04:20.350:
22:04:20.362: ---------------------------------
22:04:20.362: [FFmpeg aac encoder: 'Systeem Audio'] bitrate: 192, channels: 2, channel_layout: 3
22:04:20.362:
22:04:20.363: ---------------------------------
22:04:20.363: [FFmpeg aac encoder: 'Microfoon Audio'] bitrate: 192, channels: 2, channel_layout: 3
22:04:20.363:
22:04:20.364: ---------------------------------
22:04:20.364: [FFmpeg aac encoder: 'Discord Audio'] bitrate: 192, channels: 2, channel_layout: 3
22:04:20.364:
22:04:20.365: ---------------------------------
22:04:20.365: [FFmpeg aac encoder: 'Chrome Audio'] bitrate: 192, channels: 2, channel_layout: 3
22:04:20.365:
22:04:20.371: ==== Recording Start ===============================================
22:04:20.371: [ffmpeg muxer: 'adv_file_output'] Writing file 'D:/Recordings/OBS/2021-09-23 22-04-20.mkv'...
22:08:38.278: [ffmpeg muxer: 'adv_file_output'] Output of file 'D:/Recordings/OBS/2021-09-23 22-04-20.mkv' stopped
22:08:38.278: Output 'adv_file_output': stopping
22:08:38.278: Output 'adv_file_output': Total frames output: 15457
22:08:38.278: Output 'adv_file_output': Total drawn frames: 15464 (15474 attempted)
22:08:38.278: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 10 (0.1%)
22:08:38.278: Video stopped, number of skipped frames due to encoding lag: 11/15472 (0.1%)
22:08:38.284: ==== Recording Stop ================================================
22:08:38.313: warning: 2 frames left in the queue on closing
22:08:38.313: warning: 2 frames left in the queue on closing
22:08:38.313: warning: 2 frames left in the queue on closing
22:08:38.313: warning: 2 frames left in the queue on closing
 

FerretBomb

Active Member
Adobe Premiere has issues with the MP4s that OBS writes directly anyway. Record to MKV and use the Remux Recordings feature in the File menu, or set it in Advanced to automatically remux to MP4.

We need to see a full, actual, complete logfile to offer proper troubleshooting. Not an excerpt. Just attach the text file itself to your post.
 

Denniskuhh

New Member
Hi FerretBomb,

thx for the tip on the Remux feature!

One thing, does this change video resolution? because I recorded a video in 2560x1440p canvas without scaling down,
but the video came out as 1920x1080? A bit odd.

I attached the logs below. Hopefully you can make some sense out of this.

This one was with scaling enabled to 1920 to make sure it didnt record any overly high settings. But it still suffers some bad framedrops..
Then again. A 3090 shouldn't have issues with 1440p recordings I assume.
 

Attachments

  • 2021-09-24 16-37-30.txt
    10.4 KB · Views: 18

qhobbes

Active Member
Remuxing does not change resolution.
16:37:30.810: base resolution: 2560x1440
16:37:30.810: output resolution: 1920x1080
The video came out at 1920x1080 because the output resolution is 1920x1080

Display/Monitor Capture is the worst way to build your scene. It should only be used as a last resort or if you need to record Windows stuff such as the Start Menu or Desktop.
Build your scenes with Game/Window/Video Device Capture etc. If you need to use Display/Monitor Capture and Game Capture, don't put them in the same scene.
 

Denniskuhh

New Member
Hi Qhobbes,

I tried gamecapture but it doesn't seem to change anything. I still have dropped frames.
Regarding the output resolution, I noticed I applied the scaling wrong. my bad ;)

About my general settings, wouldn't you agree it should'nt have any issues?
I've got the feeling my GPU or CPU might be broken or something.
I just need to make sure what it is.
 

qhobbes

Active Member
If your experiencing Rendering Lag, then your GPU is maxed out and OBS can't render scenes fast enough. Do the following:
1. On the monitor(s) you use for gaming, change the refresh rate from 165 Hz to 120 Hz.
2. Cap your games at 120 FPS/Enable Vsync, etc. The game should not run faster than 120 FPS
3. Duplicate your Scene Collection. One for streaming and one for recording. Remove the duplicate scenes.

Post new log if still having issues.
 

Denniskuhh

New Member
Hey Qhobbes,

I applied all 3 solutions but still got dropped frames.
Also regarding the 120 fps. GTA barelly hits 100 so it's kinda useless,
so I figured I should try Resident Evil Village. That usually has 165 so 120 would actually limit that.
But even in Administrator I still get dropped frames.

I did get a bunch different lines in the logs so maybe there's something in there?
 

Attachments

  • 2021-09-26 18-05-30.txt
    15.3 KB · Views: 10

Denniskuhh

New Member
hi Qhobbes,

I understand that having settings too high causes issues so I tried the same settings (game capped to 120 and in Administrator)
but this time in 1080p60 and I still dropped frames.. There's no way this is normal for a 3090 right?

What do you think causes this issue? I think it's either CPU or GPU, but since I have GPU rendering, CPU doesn't really do that much right?
I feel like the GPU has to be 'broken' ..

Thx for your help btw.
 

Attachments

  • 2021-09-27 13-50-32.txt
    19 KB · Views: 17

qhobbes

Active Member
It's not. I streamed at 1080 59.94 FPS with my rig and 1 frame lost to render lag over 4+ minutes.
1. Create a new scene collection with just 1 game capture source. nothing else. if that doesn't resolve it then,
2. Set you monitor, obs base canvas and game to 1920x1080. if that doesn't resolve it then,
3. Lower your games graphics settings.
 

Denniskuhh

New Member
Hi

I did all of the above. still have dropped frames.
What was interesting is that I tried a recording with cpu encoding on, and that time it didn't show any encoding drops, just rendering drops.
Which is the GPU.
 

FerretBomb

Active Member
Just as a sanity-check, have you loaded/run GPU-Z (and used the 'simulate activity' button to avoid low-power speed stepdown) to check and make sure that your 3090 is running in PCIe 16x mode?

Normally this kind of rendering lag indeed should not happen, and is most commonly attributable to a source that does not provide its frame data in time. But a poor PCIe bus speed can also sometimes do that. You might also check if there is a motherboard BIOS update available, and/or updated motherboard drivers (lots of people don't actually install them and just use the 'mostly works' stuff that comes from Microsoft).
 

Denniskuhh

New Member
Hi Ferret,

I have the most recent BIOS version (except from a beta one).
I have downloaded GPU-Z but can't find a 'simulate activity button'. I do however see the PCIe 16x mode in CPU-Z. (photo below).
 

Attachments

  • Screenshot_12.png
    Screenshot_12.png
    19.8 KB · Views: 18

Denniskuhh

New Member
I had both, just didn't see that option on there.
I started the simulation but don't know what I should be looking for so I've got some screenshots below

Hopefully you see something that seems a bit off.
 

Attachments

  • Screenshot_14.png
    Screenshot_14.png
    318.6 KB · Views: 23
  • Screenshot_15.png
    Screenshot_15.png
    332.8 KB · Views: 23
  • Screenshot_16.png
    Screenshot_16.png
    316 KB · Views: 24

FerretBomb

Active Member
In this case, unfortunately no. It looks fine. As I said, just sanity-checking as it's easy to overlook and has caused problems in the past.
 

TryHD

Member
That looks not fine, the GPU is running with 16 lanes but PCIe 2.0 which is the bandwidth of ~ 4 PCI 4.0 lanes
 

Denniskuhh

New Member
Hi Tryhard,

I just took a second look and at first it's 4.0, but very rarily it drops down to 2.0.
I don't know what this actually means tho.
 
Top