Bug Report If you get red output from a device, read here

Status
Not open for further replies.

Jim

Jim
Developer
#1

Wrim

New Member
#2
diagnostic copy/paste in spoiler below:
Device: ManyCam Virtual Webcam
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97

Device: ManyCam Video Source
type: RGB24, usingFourCC: false, res: 1280x720 - 1280x720, fps: 0.015625-29.97

Device: XSplitBroadcaster
type: RGB32, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
type: YUY2, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
Why does it say Xsplit? All I have running is ManyCam and OBS...
But maybe uninstalling Xsplit will fix the problem.

Edit: While uninstalling Xsplit I got a message to close Skype.
Apparently Xsplit was running through Skype.
Gonna try hosting again nevertheless and see if anything changed.

Edit 2: After uninstalling Xsplit, closing Skype, restarting ManyCam and OBS and trying again I still got Red Screen.
Ran diagnostics again and got this:

Device: ManyCam Virtual Webcam
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97
type: RGB24, usingFourCC: false, res: 160x120 - 1920x1440, fps: 0.015625-29.97

Device: ManyCam Video Source
type: RGB24, usingFourCC: false, res: 1280x720 - 1280x720, fps: 0.015625-29.97

EDIT 3: FIXED IT! I went through my setups with trial and error and saw that although I set Video settings to 1280x720, and the resolution in ManyCam to 1280x720, my Source setup had a different resolution (1920x1080)

So my Red Screen problem was caused due to conflicting resolutions!
 
#4
I got red screen from dxtory after changing from 30 to 40 fps, with no apparent reason or easy fix. I had to remove my scenes config file and re-add dxtory to fix it. Weird.
 

Jim

Jim
Developer
#5
yea, dxtory is a bit weird in that regard -- you have to set the FPS to whatever dxtory uses internally I believe.
 

noto

New Member
#6
hd pvr is not working, getting the red screen.

Code:
Device: Integrated Webcam
   type: YUY2, usingFourCC: false, res: 640x480 - 640x480, fps: 30-30
   type: YUY2, usingFourCC: false, res: 160x120 - 160x120, fps: 30-30
   type: YUY2, usingFourCC: false, res: 176x144 - 176x144, fps: 30-30
   type: YUY2, usingFourCC: false, res: 320x240 - 320x240, fps: 30-30
   type: YUY2, usingFourCC: false, res: 352x288 - 352x288, fps: 30-30
   type: YUY2, usingFourCC: false, res: 1280x720 - 1280x720, fps: 7.5-7.5
   type: MJPG, usingFourCC: false, res: 640x480 - 640x480, fps: 30-30
   type: MJPG, usingFourCC: false, res: 160x120 - 160x120, fps: 30-30
   type: MJPG, usingFourCC: false, res: 176x144 - 176x144, fps: 30-30
   type: MJPG, usingFourCC: false, res: 320x240 - 320x240, fps: 30-30
   type: MJPG, usingFourCC: false, res: 352x288 - 352x288, fps: 30-30
   type: MJPG, usingFourCC: false, res: 1280x720 - 1280x720, fps: 30-30

Device: Hauppauge HD PVR Capture Device
   type: RGB32, usingFourCC: true, res: 720x480 - 720x576, fps: 25-29.97

Device: VDP Source

Device: XSplitBroadcaster
   type: RGB32, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
   type: YUY2, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
 

noto

New Member
#8
here it is.
Code:
Open Broadcaster Software v0.421a - 32bit (´・ω・`)
-------------------------------
CPU Name: Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz
CPU Speed: 2195MHz
Physical Memory:  4095MB Total, 3798MB Free
stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0
------------------------------------------
Adapter 1
  Video Adapter: Intel(R) HD Graphics Family
  Video Adapeter Dedicated Video Memory: 67108864
  Video Adapeter Shared System Memory: 1711276032
=====Stream Start=====================================================================
  Base resolution: 1280x720
  Output resolution: 1280x720
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Microphone / Line In (IDT High Definition Audio CODEC)
------------------------------------------
Audio Encoding: AAC
    bitrate: 128
Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1280, height: 720
    quality: 10
    preset: veryfast
    i444: no
    max bitrate: 3000
    buffer size: 5000
------------------------------------------
Total frames rendered: 169, number of frames that lagged: 2 (1.18%) (it's okay for some frames to lag)
=====Stream End=======================================================================
=====Stream Start=====================================================================
  Base resolution: 1280x720
  Output resolution: 1280x720
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Microphone / Line In (IDT High Definition Audio CODEC)
------------------------------------------
Audio Encoding: AAC
    bitrate: 128
Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1280, height: 720
    quality: 10
    preset: veryfast
    i444: no
    max bitrate: 3000
    buffer size: 5000
------------------------------------------
Total frames rendered: 116, number of frames that lagged: 2 (1.72%) (it's okay for some frames to lag)
=====Stream End=======================================================================

Profiler results:

==============================================================
frame - [100%] [avg time: 10.366 ms] [avg calls per frame: 1] [children: 91%] [unaccounted: 9.01%]
| scene->Preprocess - [0.0193%] [avg time: 0.002 ms] [avg calls per frame: 1]
| video encoding and uploading - [91%] [avg time: 9.43 ms] [avg calls per frame: 1] [children: 39.5%] [unaccounted: 51.4%]
| | CopyResource - [2.67%] [avg time: 0.277 ms] [avg calls per frame: 0]
| | conversion to 4:2:0 - [19%] [avg time: 1.965 ms] [avg calls per frame: 0]
| | call to encoder - [17.9%] [avg time: 1.857 ms] [avg calls per frame: 0]
==============================================================
 

Jim

Jim
Developer
#9
Do you think you could drop by the IRC channel some time, or message on skype or something? I would love to do some tests but using the forum is a bit difficult and slow.
 
#11
Hi! I have a Hauppauge HD PVR that pretty much works with nothing, so it was no surprise to me to see a big red box when I tried to input it into OBS, but I figured it'd be better to give information that may help. I mean, who knows? You've worked magic already.

Code:
Device: USB 2.0 1.3M UVC WebCam
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 5-30
   type: RGB24, usingFourCC: false, res: 352x288 - 352x288, fps: 5-30
   type: RGB24, usingFourCC: false, res: 320x240 - 320x240, fps: 5-30
   type: RGB24, usingFourCC: false, res: 176x144 - 176x144, fps: 5-30
   type: RGB24, usingFourCC: false, res: 160x120 - 160x120, fps: 5-30
   type: RGB24, usingFourCC: false, res: 1280x800 - 1280x800, fps: 5-7
   type: RGB24, usingFourCC: false, res: 1280x1024 - 1280x1024, fps: 5-7
   type: YUY2, usingFourCC: false, res: 640x480 - 640x480, fps: 5-30
   type: YUY2, usingFourCC: false, res: 352x288 - 352x288, fps: 5-30
   type: YUY2, usingFourCC: false, res: 320x240 - 320x240, fps: 5-30
   type: YUY2, usingFourCC: false, res: 176x144 - 176x144, fps: 5-30
   type: YUY2, usingFourCC: false, res: 160x120 - 160x120, fps: 5-30
   type: YUY2, usingFourCC: false, res: 1280x800 - 1280x800, fps: 5-7
   type: YUY2, usingFourCC: false, res: 1280x1024 - 1280x1024, fps: 5-7

Device: Hauppauge HD PVR Capture Device
   type: RGB32, usingFourCC: true, res: 720x480 - 720x576, fps: 25-29.97

Device: ASUS Virtual Camera
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 352x288 - 352x288, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 320x240 - 320x240, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 176x144 - 176x144, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 160x120 - 160x120, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 1280x800 - 1280x800, fps: 10000-1e+007
   type: RGB24, usingFourCC: false, res: 1280x1024 - 1280x1024, fps: 10000-1e+007

Device: SCFH DSF
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120
   type: RGB32, usingFourCC: false, res: 32x32 - 4096x4096, fps: 0.1-120

Device: XSplitBroadcaster
   type: RGB32, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
   type: YUY2, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004

Device: FFsplit Overlay 2.0b5
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
   type: RGB32, usingFourCC: true, res: 1x1 - 1680x1050, fps: 0.02-60.0002
Code:
Open Broadcaster Software v0.421a - 64bit ( ^ω^)
-------------------------------
CPU Name: Intel(R) Core(TM) i7 CPU       Q 720  @ 1.60GHz
CPU Speed: 1708MHz
Physical Memory:  6068MB Total, 4544MB Free
stepping id: 5, model 14, family 6, type 0, extmodel 0, extfamily 0
------------------------------------------
Adapter 1
  Video Adapter: ATI Mobility Radeon HD 5800 Series
  Video Adapeter Dedicated Video Memory: 1061826560
  Video Adapeter Shared System Memory: 2913232896
=====Stream Start=====================================================================
  Base resolution: 1600x900
  Output resolution: 800x450
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Microphone (Realtek High Definition Audio)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 60
    width: 800, height: 450
    quality: 10
    preset: veryfast
    i444: no
    max bitrate: 1500
    buffer size: 1500
------------------------------------------
Total frames rendered: 2321, number of frames that lagged: 1 (0.04%) (it's okay for some frames to lag)
=====Stream End=======================================================================

Profiler results:

==============================================================
frame - [100%] [avg time: 2.945 ms] [avg calls per frame: 1] [children: 81.2%] [unaccounted: 18.8%]
| scene->Preprocess - [0.204%] [avg time: 0.006 ms] [avg calls per frame: 1]
| video encoding and uploading - [81%] [avg time: 2.384 ms] [avg calls per frame: 1] [children: 39.5%] [unaccounted: 41.4%]
| | CopyResource - [0.102%] [avg time: 0.003 ms] [avg calls per frame: 0]
| | conversion to 4:2:0 - [20.4%] [avg time: 0.602 ms] [avg calls per frame: 0]
| | call to encoder - [19%] [avg time: 0.559 ms] [avg calls per frame: 0]
==============================================================
But yeah, if you can't get it to work I won't feel bad about it as this thing works with virtually nothing. 720x480 is the 'correct' resolution as I have it plugged into a PS2 currently; the one software (ArcSoft Showbiz) that does work with it shows the video output as 720x480.

Anyway, thanks again for OBS! After my last post I haven't had a single issue and everything has been perfect.
 
#13
noto said:
the hd pvr does work with xplit, ur wrong. make sure ur drivers are up to date.
I guess it depends on how you define "work". Does XSplit grab audio and video from the Hauppauge HD PVR? Yeah, it does. But last time I tried it, it started off 10 seconds delayed, slowly got to more of a 'live' status, then broke off and went 30+ seconds delayed, getting longer the longer I streamed and it wasn't just me experiencing it, everyone did. I mean... if that's what you consider working, then sure. :?

To be fair, I haven't tried the newest version of XSplit that came out last month(?). Because I don't have money to pay for XSplit and I don't like XSplit. But I remember reading on their forums that they blamed Hauppauge for it and there hasn't been any new drivers for Hauppauge HD PVR since I tested it.

But this isn't a forum for XSplit. So I'll just leave it at that.
 
#15
Getting the red screen trying to Using a Roxio Game Capture to stream 360 ps3 or psp can get it to work on xsplit but not obs for some reason.

Code:
Device: Roxio GAMECAP Capture
   type: YUY2, usingFourCC: false, res: 640x480 - 640x480, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 320x240 - 320x240, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 352x240 - 352x240, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 352x480 - 352x480, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 480x480 - 480x480, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 864x480 - 864x480, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 720x480 - 720x480, fps: 29.97-29.97
   type: YUY2, usingFourCC: false, res: 640x480 - 640x480, fps: 25-25
   type: YUY2, usingFourCC: false, res: 320x240 - 320x240, fps: 25-25
   type: YUY2, usingFourCC: false, res: 352x288 - 352x288, fps: 25-25
   type: YUY2, usingFourCC: false, res: 704x576 - 704x576, fps: 25-25
   type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25
   type: YUY2, usingFourCC: false, res: 720x576 - 720x576, fps: 25-25

Open Broadcaster Software v0.432a - 32bit (´・ω・`)
-------------------------------
CPU Name: Intel(R) Core(TM) i5 CPU         750  @ 2.67GHz
CPU Speed: 2666MHz
Physical Memory:  4095MB Total, 4095MB Free
stepping id: 5, model 14, family 6, type 0, extmodel 0, extfamily 0, HTT 1, logical cores 4, total cores 4
------------------------------------------
Adapter 1
  Video Adapter: AMD Radeon HD 7700 Series
  Video Adapeter Dedicated Video Memory: 1051820032
  Video Adapeter Shared System Memory: 4021493760
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 54, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End=======================================================================
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 1592, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End=======================================================================
Send Buffer Size: 8196
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 2434, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
Number of b-frames dropped: 0, Number of p-frames dropped: 0
=====Stream End=======================================================================
Send Buffer Size: 8196
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 2929, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
Number of b-frames dropped: 0, Number of p-frames dropped: 0
=====Stream End=======================================================================
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 72, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End=======================================================================
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 37, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End=======================================================================
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 1920x1080
  Output resolution: 1920x1080
------------------------------------------
Loading up D3D10...
------------------------------------------
Using auxilary audio input: Line (Roxio GAMECAP)
------------------------------------------
Audio Encoding: MP3
    bitrate: 128
   chosen type: YUY2, usingFourCC: false, res: 1024x576 - 1024x576, fps: 25-25, fourCC: 'YUY2'

Warning -- DShowPlugin: Failed to connect the device pin to the capture pin, result = 80040217
------------------------------------------
Video Encoding: x264
    fps: 30
    width: 1920, height: 1080
    quality: 5
    preset: veryfast
    i444: no
    max bitrate: 1200
    buffer size: 1200
------------------------------------------
Total frames rendered: 97, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End=======================================================================

Profiler results:

==============================================================
frame - [100%] [avg time: 5.663 ms] [avg calls per frame: 1] [children: 93.7%] [unaccounted: 6.3%]
| scene->Preprocess - [0.265%] [avg time: 0.015 ms] [avg calls per frame: 1]
| video encoding and uploading - [93.4%] [avg time: 5.291 ms] [avg calls per frame: 1] [children: 52.7%] [unaccounted: 40.7%]
| | CopyResource - [0.212%] [avg time: 0.012 ms] [avg calls per frame: 0]
| | conversion to 4:2:0 - [0.971%] [avg time: 0.055 ms] [avg calls per frame: 0]
| | call to encoder - [51.6%] [avg time: 2.92 ms] [avg calls per frame: 0]
==============================================================
 
#17
I get red screen using Hauppauge PVR

Here's the diagnostics output:
Code:
Device: Microsoft LifeCam Cinema
   type: YUY2, usingFourCC: false, res: 640x480 - 640x480, fps: 15-30
   type: YUY2, usingFourCC: false, res: 640x360 - 640x360, fps: 15-30
   type: YUY2, usingFourCC: false, res: 424x240 - 424x240, fps: 15-30
   type: YUY2, usingFourCC: false, res: 352x288 - 352x288, fps: 15-30
   type: YUY2, usingFourCC: false, res: 320x240 - 320x240, fps: 15-30
   type: YUY2, usingFourCC: false, res: 176x144 - 176x144, fps: 15-30
   type: YUY2, usingFourCC: false, res: 160x120 - 160x120, fps: 15-30
   type: YUY2, usingFourCC: false, res: 1280x720 - 1280x720, fps: 15-30
   type: YUY2, usingFourCC: false, res: 960x544 - 960x544, fps: 15-30
   type: YUY2, usingFourCC: false, res: 800x448 - 800x448, fps: 15-30
   type: YUY2, usingFourCC: false, res: 800x600 - 800x600, fps: 15-30
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 15-30
   type: RGB24, usingFourCC: false, res: 640x360 - 640x360, fps: 15-30
   type: RGB24, usingFourCC: false, res: 424x240 - 424x240, fps: 15-30
   type: RGB24, usingFourCC: false, res: 352x288 - 352x288, fps: 15-30
   type: RGB24, usingFourCC: false, res: 320x240 - 320x240, fps: 15-30
   type: RGB24, usingFourCC: false, res: 176x144 - 176x144, fps: 15-30
   type: RGB24, usingFourCC: false, res: 160x120 - 160x120, fps: 15-30
   type: RGB24, usingFourCC: false, res: 1280x720 - 1280x720, fps: 15-30
   type: RGB24, usingFourCC: false, res: 960x544 - 960x544, fps: 15-30
   type: RGB24, usingFourCC: false, res: 800x448 - 800x448, fps: 15-30
   type: RGB24, usingFourCC: false, res: 800x600 - 800x600, fps: 15-30

Device: Logitech QuickCam E3500
   type: RGB24, usingFourCC: false, res: 320x240 - 320x240, fps: 5-30
   type: RGB24, usingFourCC: false, res: 160x120 - 160x120, fps: 5-30
   type: RGB24, usingFourCC: false, res: 176x144 - 176x144, fps: 5-30
   type: RGB24, usingFourCC: false, res: 352x288 - 352x288, fps: 5-30
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 5-30
   type: I420, usingFourCC: false, res: 320x240 - 320x240, fps: 5-30
   type: I420, usingFourCC: false, res: 160x120 - 160x120, fps: 5-30
   type: I420, usingFourCC: false, res: 176x144 - 176x144, fps: 5-30
   type: I420, usingFourCC: false, res: 352x288 - 352x288, fps: 5-30
   type: I420, usingFourCC: false, res: 640x480 - 640x480, fps: 5-30

Device: Hauppauge HD PVR Capture Device
   type: RGB32, usingFourCC: true, res: 720x480 - 720x576, fps: 25-29.97

Device: UScreenCapture
   type: RGB24, usingFourCC: false, res: 1920x1200 - 1920x1200, fps: 1-30

Device: IP Camera [JPEG/MJPEG]
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 320x240 - 320x240, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 352x240 - 352x240, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 352x288 - 352x288, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 400x300 - 400x300, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 640x480 - 640x480, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 704x480 - 704x480, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 704x576 - 704x576, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 800x600 - 800x600, fps: 1.#INF-1.#INF
   type: RGB24, usingFourCC: false, res: 1024x768 - 1024x768, fps: 1.#INF-1.#INF

Device: IP Camera [RTSP]
   type: MPEG2_VIDEO, usingFourCC: true, res: 640x480 - 640x480, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 320x240 - 320x240, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 352x240 - 352x240, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 352x288 - 352x288, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 400x300 - 400x300, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 640x480 - 640x480, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 704x480 - 704x480, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 704x576 - 704x576, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 800x600 - 800x600, fps: 1.#INF-1.#INF
   type: MPEG2_VIDEO, usingFourCC: true, res: 1024x768 - 1024x768, fps: 1.#INF-1.#INF

Device: vMix Video
   type: RGB32, usingFourCC: false, res: 320x240 - 320x240, fps: 25-25

Device: XSplitBroadcaster
   type: RGB32, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
   type: 'AYUV', usingFourCC: true, res: 1x1 - 320x240, fps: 1-255.004
   type: YUY2, usingFourCC: false, res: 1x1 - 320x240, fps: 1-255.004
Here's the log file:
Code:
Open Broadcaster Software v0.432a - 32bit (´・ω・`)
-------------------------------
CPU Name: Intel(R) Core(TM) i5 CPU         760  @ 2.80GHz
CPU Speed: 2808MHz
Physical Memory:  4095MB Total, 4095MB Free
stepping id: 5, model 14, family 6, type 0, extmodel 0, extfamily 0, HTT 1, logical cores 4, total cores 4
------------------------------------------
Adapter 1
  Video Adapter: NVIDIA GeForce GTX 550 Ti
  Video Adapeter Dedicated Video Memory: 1025179648
  Video Adapeter Shared System Memory: 3221368832
=====Stream Start=====================================================================
  Multithreaded optimizations: On
  Base resolution: 720x480
  Output resolution: 720x480
------------------------------------------
Loading up D3D10...
Using 5.1 speaker setup
------------------------------------------
Using auxilary audio input: Desktop Microphone (20- Cinema - Microsoft LifeCam.)
------------------------------------------
Audio Encoding: AAC
    bitrate: 128
Warning -- DShowPlugin: Could not find appropriate resolution to create device image source
------------------------------------------
  Using audio/video sync fix
------------------------------------------
Video Encoding: x264
    fps: 60
    width: 720, height: 480
    quality: 10
    preset: veryfast
    i444: no
    max bitrate: 1000
    buffer size: 1000
------------------------------------------
Total frames rendered: 265, number of frames that lagged: 1 (0.38%) (it's okay for some frames to lag)
=====Stream End=======================================================================

Profiler results:

==============================================================
frame - [100%] [avg time: 1.686 ms] [avg calls per frame: 1] [children: 59.8%] [unaccounted: 40.2%]
| scene->Preprocess - [0.0593%] [avg time: 0.001 ms] [avg calls per frame: 1]
| video encoding and uploading - [59.8%] [avg time: 1.008 ms] [avg calls per frame: 1] [children: 33.8%] [unaccounted: 26%]
| | CopyResource - [1.78%] [avg time: 0.03 ms] [avg calls per frame: 0]
| | conversion to 4:2:0 - [0.297%] [avg time: 0.005 ms] [avg calls per frame: 0]
| | call to encoder - [31.7%] [avg time: 0.535 ms] [avg calls per frame: 0]
==============================================================
Wirecast also won't display the Hauppauge output.
 

Jim

Jim
Developer
#18
Hauppauge is currently not working directly -- it seems it only outputs h264. Though I can possibly get it working in the future.
 
#19
Jim said:
Hauppauge is currently not working directly -- it seems it only outputs h264. Though I can possibly get it working in the future.
Please let me know when/if you get it working. I am currently using Xsplit, which is as flakey as hell - different day, different problem!
 
#20
I'm using one of the cheap EasyCap devices.

As I understand. EasyCap were originally being manufactured by a bunch of companies out of the same factories in hong kong but some changed manufacturer and claimed that theirs were the original and the others were bootleg. As such there are lots of different cards that call themselves EasyCap but they have different chipsets inside and require different drivers and such. There's a lot of back and forth between them over which is better, but overall all of them are more or less the same really cheap entry level capture cards. They typically capture RCA composite video and s-video (in SD) and have audio capture as well.

The one I'm using has an 'SMI Grabber' chipset. Here's a google code page for a dev group that makes a video4linux kernel module as well as linux firmware and other stuff.
http://code.google.com/p/easycap-somagic-linux/
Pictures of the device in question (as there are several different easycaps), to avoid confusion with other users using them.
http://code.google.com/p/easycap-somagi ... vicePhotos
and a google groups page for that code page.
https://groups.google.com/forum/?fromgr ... agic-linux

I'm not sure if that's very useful for you.

Here's the debug info.

Code:
Device: SMI Grabber Device
   type: UYVY, usingFourCC: false, res: 160x120 - 720x576, fps: 25-25
   type: UYVY, usingFourCC: false, res: 160x120 - 720x486, fps: 29.97-29.97
   type: UYVY, usingFourCC: false, res: 160x120 - 720x480, fps: 29.97-29.97
It seems to work in xsplit, but crashes FMLE as soon as you try to go live (I'm not sure why, I think it's the audio). In linux I can kind of stream it with ffmpeg but it's all buggy and I'm not sure why. I can stream with gstreamer though (on linux).
 
Status
Not open for further replies.
Top