Glitches while capturing my Camera


New Member

When I capture my camera (HDMI to USB through a video capture adapter) I have glitches while recording. And thoses glitches are also viewable when I play the video file created.

My CPU usage is around ~6% ~10% when recording.

Here is my log file:

I tried to:
- connect to my USB 3 port 1 and 2.
- connect to ny USB C port
- change de framerates, bandwidth, output format ...
- encode with software encoding or hardware encoding

Results I got:
I have no glitches when I go to software encoding, with 10fps and 720p params.... wich is not good for my usage.
I need to record at least at 30fps / 1080p and with those last params I have a bit less glitches but still glitches every ~2 ~3 seconds... wich is not usable.

Do you have any idea of the source of the problem ? What could I try ?

My laptop configuration is not bad (MX 150 gpu + I7 cpu + 16gb ram + fast 1TB SSD).
My camera is a Panasonic Lumix GX80.

Thank you very much.
Last edited:


New Member
Hi thanks @cyclemat .

I'm plugged to energy and my energy settings are on max.

This is how it's like on video: (after few seconds)

When I view myself on screen there's no glitch, but when I'm recording it becomes glitchy.

Thanks for your help
Last edited:


New Member
I also tested on Linux (DeepIn based on Debian) and I have no glitches on it (even if it is slow fps because of I have no fast hardware video processing)... so I can imagine it is not my Hdmi => Usb capture hardware how's failling.


New Member
"mmmh did you use the ethernet port ? "
==> I'm not sure to understand: I just tried to record through my HDMI to USB capture device.

"has the mx150 no nvec support ? "
==> Through my research I found on a forum that MX150 has no NDEC or NVENC support... :/ (,

But my I7 CPU has HEVC support. (source wikipedia:

Should I disable my MX150 before recording to force my Intel 620 / I7 cpu encoding ?

"CPU usage is around ~6% ~10%" when recording with OBS Hardware mode yes.
I'm around ~25% ~50% (depends if 25fps or 60fps) in Software mode.

I just returned my capture device to shop to buy and try recording with another.
Do you have any capture device to recommend ? (HDMI input + Mic or Aux separated input ?)

Thank you for you help @cyclemat


New Member
Yes I do have two USB 3 ports and Two USB-C ports. I tried all thoses ports.

Thanks for recommendation. I acutally already have a Focusrite 2i2 ( with phantom 48v powered Mic.

But it's easier to use a capture device handling simple Mic and HDMI for video. There's less mess and cables on the desk... :)

Anyway, let's see if it works better with a Camlink or whatever.


New Member
ok yes, it's a bit expensive for only 1080P60 (200Euros) since 30fps could be enough for me ... well I'll see

Josh Ting

New Member
Hi, I have exactly same issue from the original post. I am using Blackmagic Webpresenter to Laptop. Tried most of the method can find from google but none of them fix it. Would like to know if you have solve the problem?