Gameplay is perfectly smooth, but recorded video is choppy/unsmooth.

RectaDSM

New Member

Greetings. I have the following problem.

My specs: i7 8700k, RTX 2080, I write to SSD, windows latest version, graphics card drivers latest version.

I record games at 60 fps, 1440p.

When recording games, the game itself works perfectly, smoothly and well. But the final video is not smooth, and it looks like it has less than 60 fps (although both mediainfo and windup say that the recording is 60 fps).

I don't know exactly when this problem occurred, I was taking a break from recording, but back in April 2022 everything was fine, recording was smooth. Now, on the same settings, on the same system, the video is choppy.

I have tried:
Turning g-sunc off and on.
Turning v-sync on and off.
Different resolution, different bitrate.
Install earlier version of Windows. Install earlier video card drivers.
Set the lowest graphics settings for games.
Turn off game bar and game mode in Windows.
Turn off the second monitor.
Limit fps in the game.

Tak also tried all recording settings in OBS itself. Nothing helps, the video is choppy.

None of this helps. Videos look choppy on all monitors, all refresh rates (60, 120, any).

The problem obviously started after April 2022. Until then everything was fine.

Any ideas, guys?
 

Sejbo8000

New Member
I think I have the same issue as you but mine started some time in June and every time I pan or move the in game camera around I get this weird frame skipping(While only recording) where it looks stuttery with and without G-sync and V-sync. I have tried 120fps with 120 refreshrate and 60. I also tried limiting fps but it had no effect on the issue. If I have no sync on the stutter seems to happen when I get screen tearing so maybe there is a connection there? Haven't found a solution and I have tried everything at this point in different games as well. When I play the game itself it is as smooth as can be and there are no issues what so ever. Just noticed you are the same guy from the other thread as well XD
 
Last edited:

RectaDSM

New Member
I think I have the same issue as you but mine started some time in June and every time I pan or move the in game camera around I get this weird frame skipping(While only recording) where it looks stuttery with and without G-sync and V-sync. I have tried 120fps with 120 refreshrate and 60. I also tried limiting fps but it had no effect on the issue. If I have no sync on the stutter seems to happen when I get screen tearing so maybe there is a connection there? Haven't found a solution and I have tried everything at this point in different games as well. When I play the game itself it is as smooth as can be and there are no issues what so ever. Just noticed you are the same guy from the other thread as well XD
yes, i am the guy from all similar threads, that problem just killing me
 

.norman.

Member
UPD: Tryed install different graphic card - 3070. Video still choppy.
i don't know if this will help or not, but other people are having issues with the latest nvidia driver. not sure if this is related, but there is a long thread about it. the solution in their case is to roll back the driver to a version dated Oct 12.
 

RectaDSM

New Member
i don't know if this will help or not, but other people are having issues with the latest nvidia driver. not sure if this is related, but there is a long thread about it. the solution in their case is to roll back the driver to a version dated Oct 12.
Thanks for the suggestion! But no, the situation has not changed.
 

sandrix

Member
Is the situation similar with x264?
What about the portable version of OBS? There may be something wrong with your settings.
 

RectaDSM

New Member
1. Ты используешь HEVC с битрейтом CQP. Попробуй сменить на NVENC H.264
2. Посмотри лог через https://obsproject.com/tools/analyzer Всё надо устранить
3. Вот статья про оптимизацию и всё такое
Tried everything, honestly. And the bitrate is the same, and the file MKV, and all options encoder (x264 brakes and recording, and the game itself), and all options settings.

I'll say more - the problem persists when using any software. At all. OBS, Mirilis ACTION, Shadowplay.

It's somewhere deeper, in the hardware or something else. Definitely not the video card, I've tried changing it too.)
 

RectaDSM

New Member
1. Ты используешь HEVC с битрейтом CQP. Попробуй сменить на NVENC H.264
2. Посмотри лог через https://obsproject.com/tools/analyzer Всё надо устранить
3. Вот статья про оптимизацию и всё такое
Tried everything, honestly. And the bitrate is the same, and the file MKV, and all options encoder (x264 brakes and recording, and the game itself), and all options settings.

I'll say more - the problem persists when using any software, not only OBS.

It's somewhere deeper, in the hardware or something else. Definitely not the video card, I've tried changing it too.)
 

Goblok

New Member
Did you find a solution? I have exactly the same problem. Gameplay is perfectly smooth but the recordings are stuttering on every recording software. I have tried every settings in Nvidia control panel now but I cant get rid of the stuttering.

This is driving me crazy and I'm totally out of ideas of this point. I have tried two different monitors, different resolutions and fps and monitor HZ. I have changed Graphics Card, CPU, GPU, Motherboard, Memories, Hard Drives and PSU and installed fresh install of Windows 11 instead of 10. No luck. Only mouse and keyboard remain the same. I have tried to fixing the problem over a month now, search every forum post and tried every advice I can.

Sometimes the stuttering starts immediatly, sometimes it can be smooth for few minutes and then appear.

My current setup is:
Intel Core i9-13900K
RTX 4090
32GB DDR 5 @ 5600 MHZ
1000W PSU NZXT

As I mentioned I have changed virtually all components of my PC but the stuttering persists so I doubt it is a hardware issue.

I would love to hear how it is going for you now and if there are more people experiencing the same issue.
 

ValleGaming

New Member
It's the same problem here as well. Has been for a long time.
The 60FPS recorded video does not match the smoothness that i see on my screen with 60HZ - especially when turning around it seems choppy like it jumps back and forth a little from time to time. It does NOT look as smooth - although recording is 60FPS and i have no drops or issues while recording. I guess many people wouldn't really notice when you don't pay attention to it.

It doesn't matter if i use two PCs with a capture card or record locally on one PC with OBS..
It does not matter if i record with different recording software (Shadowplay, OBS, Recforge).
Different recording settings, NVENC, H264... MP4 or MOV..

No matter what - i can't get the recording to look as smooth as what i see on my screen when playing.

So - no solution.. but another person with the same problem.
 

Tronk6969

New Member
I've got the same problem(s). My OBS says there's not a single dropped frame from either encoding or rendering, yet the video comes out with a bunch of ugly stutters and choppy frames. I've updated my GPU drivers, I've switched from MKV to MP4, I've tried using CBR instead of CQP, I've run OBS as Admin every single time, I've tried disabling and enabling Game Mode, in all my antivirus/firewall programs I have put OBS on the allow list... I am at a loss as to what I can change to fix this problem.

I have yet to see a guide anywhere on the internet that explains why this would happen, and of course, OBS itself isn't giving me a straight answer, not one that I can glean any information from. If anyone gets anything on this, I'd be forever grateful to you if you shared what your solution(s) was.
 

Attachments

  • 2023-02-16 09-18-01.txt
    19.1 KB · Views: 122

RectaDSM

New Member
Did you find a solution? I have exactly the same problem. Gameplay is perfectly smooth but the recordings are stuttering on every recording software. I have tried every settings in Nvidia control panel now but I cant get rid of the stuttering.

This is driving me crazy and I'm totally out of ideas of this point. I have tried two different monitors, different resolutions and fps and monitor HZ. I have changed Graphics Card, CPU, GPU, Motherboard, Memories, Hard Drives and PSU and installed fresh install of Windows 11 instead of 10. No luck. Only mouse and keyboard remain the same. I have tried to fixing the problem over a month now, search every forum post and tried every advice I can.

Sometimes the stuttering starts immediatly, sometimes it can be smooth for few minutes and then appear.

My current setup is:
Intel Core i9-13900K
RTX 4090
32GB DDR 5 @ 5600 MHZ
1000W PSU NZXT

As I mentioned I have changed virtually all components of my PC but the stuttering persists so I doubt it is a hardware issue.

I would love to hear how it is going for you now and if there are more people experiencing the same issue.
no, problem is still there. I can see your PC is much stronger than my, but you recieving this problem... My guess is that something with Windows itself, or with mobo, or IDK((
 

wesh92

New Member
I've got the same problem(s). My OBS says there's not a single dropped frame from either encoding or rendering, yet the video comes out with a bunch of ugly stutters and choppy frames. I've updated my GPU drivers, I've switched from MKV to MP4, I've tried using CBR instead of CQP, I've run OBS as Admin every single time, I've tried disabling and enabling Game Mode, in all my antivirus/firewall programs I have put OBS on the allow list... I am at a loss as to what I can change to fix this problem.

I have yet to see a guide anywhere on the internet that explains why this would happen, and of course, OBS itself isn't giving me a straight answer, not one that I can glean any information from. If anyone gets anything on this, I'd be forever grateful to you if you shared what your solution(s) was.
Hope this will help, try disabling Hardware-Accelerated GPU Scheduling in Windows.
I also struggled with choppy recordings and never found a fix until now.
 

Leslief15

New Member
Any solution? Ive been trying to record my games but my recordings are so choppy and laggy. I’ve tried multiple softwares and all give me the same issue. I don’t have a bad pc and my recordings were fine before. When i watch the recordings back the quality is just horrible but if i were to send it to someone on discord it is fine? Also choppy in editing softwares. My recordings are being saved in my 2tb m.2
 
Top