Elgato Facecam freezes

ZachyChanMF

New Member
So i got a Facecam about a month and a half ago, but haven't been able to use it because I didn't have enough watts in the power supply to power everything I have plugged in usb wise and my 3070 lol Well i got my new 1200 watt power supply and can finally have everything plugged in and my pc not just randomly shut off, or so I thought... Tried to have my first stream since getting the new psu and about a half hour in I noticed the camera was froze. So i changed scenes and waited for the light to turn off on the cam then switched back and it was fine again for about 10 min then froze again I repeated the scene change and it unfroze for the about the same amount of time and refroze. I then went into the cam settings in obs. Tried setting the resolution from auto to the set 1080p along with the fps I got down to the bottom and when I hit apply the whole pc froze and then shut off and restarted not sure what I did or what I need to change to stop this. Also I'm thinking this might be an NVidia broadcast issue. If I route the cam through broadcast first then obs the cam just freezes and doesn't do anything but show a frozen image(obs discord doesnt matter). I have the camera plugged into the only light blue usb port on the mobo (its next to the only usb c input) the others are the dark blue I think the light blue is the more advanced usb? but I could be wrong. idk if I'm just over loading my mobo with usb stuff or maybe I have a setting wrong like I said but thought maybe someone might have had a similar issue Thanks for reading this far is you have!!

pc specs
mobo: msi x-570a pro
cpu: ryzen 7 3700x
gpu: aorus 3070 master
ram: 32gb dominator 3600mhz
m.2 boot drive (obs is on the m.2)
as far as usb stuff i have a corsair mouse pad, corsair headset stand, my corsair xeneon monitor connects with usb-c(stream deck plugged into monitor), wave 3 mic, 7 port usb expansion hub, my k100 keyboard with the nexus, and finally virtuoso headset

this was the last crash report from last month ;that i could get the crash today was not recorded i guess?? Not sure what that means but best i can do.
 

Attachments

  • 2022-01-29 09-18-38.txt
    34.4 KB · Views: 22
I had the same problem and fixed it by plugging in the Elgato Facecam straight into the PC without the USB hub in between. Could NOT get it to work right with the hub.
 

stylee

New Member
Had a similar issue and as the poster above says direct connection to PC solved it for me too.

looked like the face cam could t draw enough power from the USB port when using either a hub or extension, OEM cable straight into the machine worked a treat!
 
Top