Question / Help Dropping frames in OBS studio please help


New Member
So I just got this new computer and I have looked up all the videos and did all the stream test and still can't get a stable 60 fps in obs mainly in apex, I get high fps in game its just the fps the viewers would see cant stay at 60. I have a i9-9900k and a rtx 2060 and 16gb of ram. I'v tested bitrate from 2500-6000 and all the same in apex. I have also chose the best possible server with the best bandwidth. Nothing works. I used the configuration wizard for its opinion on best possible settings and still the same outcome has occurred. Please someone help me figure this out here's the logs with the auto configuration wizard.


  • 2019-04-06 13-24-14.txt
    15.8 KB · Views: 26


New Member
You need to cap your in-game framerate through the origin launcher...

Open Origin launcher
Right click on apex legends
Click Game Properties
Then open the advanced tab and type in the following command in the command line arguments

+fps_max 75

Then press apply and then re launch the game and check your FPS stability on OBS

If you are playing on a high framerate/high resolution monitor you will have to fine tune the settings based on your hardware

This is why it sucks using a single pc for streaming as you have to compromise your in-game performance in order to provide a proper viewing experience for your audience.

I have a 9900k, GTX 1080, 32 gb of ram and was able to find that I can run my game at 1440p at about 75 fps without any FPS skips or at about 100-110 fps on 1080p without FPS skips (this is when testeed on both x264 medium prest or nvenc new/old at 6,000 kbps bitrate)

If you play on 1080p you can maybe crank it as high as 120-130 fps on the frame rate cap within the origin launcher itself

This is one of the only games I've found that I have to cap my frames at in order to stream it at a descent quality. This tells me that the game has a lot of optimization to do as far as the hardware resource consumption side of things are concerned.

Hope this helps you man.


Active Member
In addition to the fps cap, turn off Game Mode, as this diverts necessary GPU resources away from OBS.

Also, turn off Psycho Visual Tuning. This uses additional GPU resources, which leads to additional encoding lag if those resources aren't available.