Resource icon

DirectShow Audio Source Plugin

Mike

New Member
I'm wondering if it's not working because another device is taking control of it.

Something you can try is to restart your computer, and then when it comes back up delete the source you have now and create it again this time as a global source.

One more thing you can try is to create another virtual audio cable. This should theoretically work if iTunes is the one interfering with obs. You can open the control panel for vac and then add another line. From here, open the mme audio repeater for vac and set input to line 1 and output to line 2. Then, add the direct show audio source back in and set it to line 2.

If all else fails, you can go with the virtual audio cable approach and send both your mic input and your iTunes to virtual audio cable 1 and then in your audio settings set your mic to virtual audio cable 1.

Let me know if any of these work out for you (:
 

M1NO

New Member
The Global source route didn't work.

I don't understand your 2nd method and how to add another line.

Your 3rd method, I know how to send itunes to output audio to Line 1, but i dont get what you mean by sending my mic input to line 1, do you mean setting Line 1 as my Default Recording? or putting my Mic's "Playback through this device" to Line 1?


NOONE ELSE IS HAVING ISSUES WITH THIS PLUGIN?! am I the only one experiencing this issue when it comes to trying to play music ONLY on the viewers side?
 

Mike

New Member
The Global source route didn't work.

I don't understand your 2nd method and how to add another line.

Your 3rd method, I know how to send itunes to output audio to Line 1, but i dont get what you mean by sending my mic input to line 1, do you mean setting Line 1 as my Default Recording? or putting my Mic's "Playback through this device" to Line 1?


NOONE ELSE IS HAVING ISSUES WITH THIS PLUGIN?! am I the only one experiencing this issue when it comes to trying to play music ONLY on the viewers side?

Right. Let's go through the two methods I've described in depth.

-Creating another VAC and using it as a "bypass"-
1. Go to Start > All Programs > Virtual Audio Cable
2. Right click on the program "Control panel" and run it as an administrator.
3. In the top right corner you will see "cables" with a changeable number next to it. Change this number to 2, or 3 if you desire, and then press set. You can now close out of the control panel.
4. Now, go to Start > All Programs > Virtual Audio Cable > Audio Repeater (MME)
5. In this program, set the wave in to line 1 (Virtual Audio Cable), and the wave out to line 2 (Virtual Audio Cable) and then press start.
6. Now go into obs, and in the direct show audio source, set your audio input device to line 2 (Virtual Audio Cable).

Keep in mind, if this technique works for you, you will need to make sure Audio Repeater (MME) is running and sending line 1 to line 2 each time before you start your stream.


-Combining mic and music to ONE line-
1. Go to Start > All Programs > Virtual Audio Cable
2. Right click on the program "Control panel" and run it as an administrator.
3. In the top right corner you will see "cables" with a changeable number next to it. Change this number to 2, or 3 if you desire, and then press set. You can now close out of the control panel.
4. Now, go to Start > All Programs > Virtual Audio Cable > Audio Repeater (MME)
5. In this program, set the wave in to Microphone (3- Microsoft LifeCam VX-500) or whatever microphone you want to use, and the wave out to line 1 (Virtual Audio Cable) and then press start.
6. Now go into obs, and go into your settings. Open the audio settings, and change your Microphone/Auxiliary audio device to Line 1 (Virtual Audio Cable).

Keep in mind, the same as above, if this technique works for you, you will need to make sure Audio Repeater (MME) is running and sending your mic to line 1 each time before you start your stream.


Let me know how this works for you (:
 

M1NO

New Member
Right. Let's go through the two methods I've described in depth.

-Creating another VAC and using it as a "bypass"-
1. Go to Start > All Programs > Virtual Audio Cable
2. Right click on the program "Control panel" and run it as an administrator.
3. In the top right corner you will see "cables" with a changeable number next to it. Change this number to 2, or 3 if you desire, and then press set. You can now close out of the control panel.
4. Now, go to Start > All Programs > Virtual Audio Cable > Audio Repeater (MME)
5. In this program, set the wave in to line 1 (Virtual Audio Cable), and the wave out to line 2 (Virtual Audio Cable) and then press start.
6. Now go into obs, and in the direct show audio source, set your audio input device to line 2 (Virtual Audio Cable).

Keep in mind, if this technique works for you, you will need to make sure Audio Repeater (MME) is running and sending line 1 to line 2 each time before you start your stream.


-Combining mic and music to ONE line-
1. Go to Start > All Programs > Virtual Audio Cable
2. Right click on the program "Control panel" and run it as an administrator.
3. In the top right corner you will see "cables" with a changeable number next to it. Change this number to 2, or 3 if you desire, and then press set. You can now close out of the control panel.
4. Now, go to Start > All Programs > Virtual Audio Cable > Audio Repeater (MME)
5. In this program, set the wave in to Microphone (3- Microsoft LifeCam VX-500) or whatever microphone you want to use, and the wave out to line 1 (Virtual Audio Cable) and then press start.
6. Now go into obs, and go into your settings. Open the audio settings, and change your Microphone/Auxiliary audio device to Line 1 (Virtual Audio Cable).

Keep in mind, the same as above, if this technique works for you, you will need to make sure Audio Repeater (MME) is running and sending your mic to line 1 each time before you start your stream.


Let me know how this works for you (:

ok combining the mic and music into ONE line worked. but theres an annoying girl voice saying "TRIAL" over and over and over again on my stream. how do i make it stop?
 

Jack0r

The Helping Squad
Forum Moderator
Well, by buying Virtual Audio Cable. You could also check VB-Cable which is a free alternative.
 

M1NO

New Member
Well, by buying Virtual Audio Cable. You could also check VB-Cable which is a free alternative.
Yeah I got the full version thanks. everything seems to be working now that I got the mic and output on the same Line 1.. sad that this Plugin didn't work out.. =/
 

Mike

New Member
It's really odd that the plugin didn't work for you. But at least you got everything working now (:
 
Did anything change since the last update because it seems that the plugin is not working any more ...

I have an astro mixamp connected to my pc ... digital audio for gamesound and usb for Teamspeak (standard communication).

The plugin was used for getting TS sound (not my own voice) into my stream and the Audio Input Device is set to "DirectSound: Speakers (ASTRO Gaming USB MixAmp)".

Everything worked fine but now this is not working anymore. I made no changes by myself at all ...

Can anybody help me?

Yours, Lucky
 

caLviN1260

New Member
Did anything change since the last update because it seems that the plugin is not working any more ...

I have an astro mixamp connected to my pc ... digital audio for gamesound and usb for Teamspeak (standard communication).

The plugin was used for getting TS sound (not my own voice) into my stream and the Audio Input Device is set to "DirectSound: Speakers (ASTRO Gaming USB MixAmp)".

Everything worked fine but now this is not working anymore. I made no changes by myself at all ...

Can anybody help me?

Yours, Lucky
I have the exact same problem. I'm trying to get Skype (on one of my Astro's outputs) to play over my stream but I can't get it to work :/
 

Mike

New Member
Sometimes when a device is in use by another program/application it doesn't work as intended.

@L13GProject try a previous version of OBS (one that you last remember it working) and let me know if that resolves your issue.
 
Sometimes when a device is in use by another program/application it doesn't work as intended.

@L13GProject try a previous version of OBS (one that you last remember it working) and let me know if that resolves your issue.
... tryed that allready ... but nothing changed ... even a previous version of OBS ... installed the plugin new ... no changes ... the funny thing is that all devicesPrograms you can choose in the plugin are not working any more
 

Krxz

Member
I have the exact same problem. I'm trying to get Skype (on one of my Astro's outputs) to play over my stream but I can't get it to work :/
I have the same problem. Using my Speakers for game sounds + music to stream and my logitech g35 headset for communication (TS/Skype).

I used to be able to add the TS/Skype to the scenes I wanted of my stream. Now, nothing works.
What happened?
 
... obviously something must have happened ... I even installed everything on different PCs but I am not able to get thing working again !!!

Even VAC or VB have no effect to it ... but it is an essential feature to me because of different scenes with each different sound settings (short-break scene with music but TS excluded ... gaming scene with all sounds and Ts implemented) ... :( ... so what could the problem be?

Yours Lucky ...
 

Jack0r

The Helping Squad
Forum Moderator
Tested both output to stream and to desktop, all working good for recording devices, as usual.
  1. Make sure all sound drivers are up to date and not Windows default drivers
  2. Make sure exclusive mode is deactivated for all your devices
  3. Deactivate sound devices you never use
  4. Remember, the plugin works for recording devices and video capture devices
  5. although playback devices are listed, they should not work
 
Thank you, Jack0r, but ...

1. Checked ... YES
2. Checked ... YES
3. Checked ... YES
4. YES ... I know that !!!
5. YES ... I know that too !!!
 

caLviN1260

New Member
Tested both output to stream and to desktop, all working good for recording devices, as usual.
  1. Make sure all sound drivers are up to date and not Windows default drivers
  2. Make sure exclusive mode is deactivated for all your devices
  3. Deactivate sound devices you never use
  4. Remember, the plugin works for recording devices and video capture devices
  5. although playback devices are listed, they should not work
Perhaps that's why it isn't working then, I'm using a playback device? I'm not trying to use any recording type of thing for this, I want the voices of my friends to sound over Skype. My mic and my desktop audio work fine, but I need to be able to stream my Skype audio as well as it plays through a different playback output.
 

Dom Mayo

New Member
i would love to use this but the download links dont seem to be working for me?

Edit: worked this morning. guess it was just down for a few hours.
 
Last edited:

padfoot240

New Member
Did anyone find a fix for the stuttering issue? I'm trying with VAC.

Dom Mayo, are you getting it to work fine?

Anyone trying to overcome the stuttering issues, I was able to resolve by completely uninstalling OBS and then re-installing. This was a little extra work to rebuild all my scenes and sources, but it solved the stuttering issues I have experienced with this plugin and VAC
 
Last edited:
Top