Resource icon

DirectShow Audio Source Plugin

Jigsaw Complex

New Member
Hi! I'm having an issue with OBS and I believe this plugin, and I've tried going to many places for help, so why not here. I'm trying to stream to Twitch while using two different audio sources.

I have my game audio coming out of my desktop speakers (which is the system default) and I have my voicechat audio (Mumble, Ventrillo, etc) coming from my headset (Because the voices coming from my head just feels better. lol). The problem is that when I stream, only the desktop audio and my mic is getting picked up; so it just sounds like I'm a crazy man.

A nice person at the Twitch subreddit linked me here to get the DirectShow Audio Source plugin, and while I get that installed alright, I don't think I've got the Scenes/Sources set up right. As is, I only have one Scene set up with the Sources within being the various games I play set up as Game Capture. I was told on the subreddit to add the audio source as a Global Source and add it to the Scenes that need it.

I guess I just need help within OBS and the plug in to find out what I need to set it to in order to stream both audio feeds. If it helps, here are some screens of my settings in OBS and the plugin. http://jigsawcomplex.imgur.com/all/
 

Jigsaw Complex

New Member
I will gladly take any other ideas, but I basically had to acquire VAC and set up 3 lines to get it all working, but it's good now.
 

paibox

heros in an halfshel
The server hosting the download is currently down because someone dug off a fiber cable down south. It's possible that it won't be up until Monday, since it's holiday times in many parts of Europe.
 

Vad1us

New Member
hi! i cant install this plugin, OBS v.622b just dont see the plugin (sorry, was too lazy to change language for you)
Безымянный.png
and now it working, what can i say, MAGIC
 

Lunaus

Member
Love this Plug-in, wouldn't have known about it without RJ! But I do have to point out that I use a webcam and I already have a global source for it, now with this it auto-selects my webcam and there's no "none" option or any option to choose from where I only get to choose the type of device I want to use at the time, making it so I can't use this again as a global source because all options are selected at once.

Sorry if this has been stated before.
 

M1NO

New Member
Can you pleas tell us how you fixed it, cause i have the same problem!





Thats what i get :/

Can some one pleas help me!


I got here also. Is the plugin broken at the moment? When I try to add a source I already sense a feeling that the plugin is broken because it says (string not found), instead of showing the correct name for the plugin.

l set my output to Line 1 on my audio player then created a new scene with this plugin to output my music being played on Line 1 but no sound was being output when I listened to my own stream.. =/

Any idea what's wrong?
 

paibox

heros in an halfshel
The plugin isn't broken, it's simply missing the locale for the language you have OBS set to. You can make a copy of en.txt and rename it to de.txt or ru.txt or whatever language you're currently using.
 

Mike

New Member
The plugin isn't broken, it's simply missing the locale for the language you have OBS set to. You can make a copy of en.txt and rename it to de.txt or ru.txt or whatever language you're currently using.

For those having the "string not found" error, it is a problem with the locale in the newer versions of obs.
To get it show as intended by the creator, do the following:

1. Go into your plugins folder, mine is located at "C:\Program Files (x86)\OBS\plugins\"
2. From here, locate and open the folder DShowAudioPlugin
3. Now open the folder locale in this folder. You should now be at "C:\Program Files (x86)\OBS\plugins\DShowAudioPlugin\locale"
4. In this folder, open en.txt and replace all of its content with the following:
Cancel="Cancel"
ClassName="DirectShow Audio Source"
DeviceSelection="Audio Device Selection"
OK="OK"

CrossbarSelection.Open="Open Crossbar"

DeviceSelection.AudioDevice="Audio Input Device:"
DeviceSelection.Blend="Blend (1-1000):"
DeviceSelection.ChromaKey="Chroma Key"
DeviceSelection.Color="Color:"
DeviceSelection.Config="Configure"
DeviceSelection.Crossbarselect="Select Device Crossbar:"
DeviceSelection.CustomResolution="Custom Resolution:"
DeviceSelection.Device="Device:"
DeviceSelection.ExistsInScene="A source using this device already exists."
DeviceSelection.ExistsSomewhere="This device is currently being used as a source in one or more scenes."
DeviceSelection.FlipImage="Flip Image Vertically"
DeviceSelection.FlipImageHorizontal="Flip Image Horizontally"
DeviceSelection.ForceCustomAudio="Force Custom Audio Device"
DeviceSelection.FPS="FPS:"
DeviceSelection.GlobalExists="A global source using this device already exists."
DeviceSelection.InvalidResolution="Invalid Resolution"
DeviceSelection.NoSound="No Audio"
DeviceSelection.Opacity="Opacity"
DeviceSelection.OutputSound="Output audio to stream only"
DeviceSelection.PlayToDesktop="Output audio to desktop"
DeviceSelection.PreferredType="Use Output Format"
DeviceSelection.Refresh="Refresh"
DeviceSelection.Resolution="Resolution"
DeviceSelection.Select="Select"
DeviceSelection.Similarity="Similarity (1-1000):"
DeviceSelection.Sound="Audio"
DeviceSelection.SoundOffset="Audio Time Offset (milliseconds):
DeviceSelection.SpillReduction="Spill Reduction (1-1000):"
DeviceSelection.UnsupportedResolution="This device does not support that resolution"
DeviceSelection.UseChromaKey="Use Chroma Key"

Plugin.Description="This plugin allows you to add a separate sound source, as long as the device has a compatible DirectShow interface."
Plugin.Name="DirectShow Audio Source Plugin"
5. Save and close.

Please note, if you are using a different language other than english, you will need to change the name of the txt file as mentioned by paibox above.


(:
 

M1NO

New Member
Okay cool thanks I got all the text showing up properly now but the plugin still does not seem to work for some reason. Here is what I am doing:

1) Download 32 bit AND 64 bit plugin
2) Put 32 bit into "D:\Program Files (x86)\OBS\plugins" and 64 bit into "D:\Program Files (x86)\OBS\64bit\plugins"
3) Set iTunes to play music output into "Line 1 Virtual Audio Cable" ( I can see that the music is actually going through to this output when I go to my Sound settings because I see the bar moving up and down indicating that sound is being output)

4) Open up OBS v0.624b - 32 bit
5) Create Source in one of my current Scenes for DirectShow Audio Source plugin (I tried both DirectSound: Line 1 and Line 1 in the screenshot and both set to Output audio to stream only)


No sound is output when I go to my stream page to look at my own stream...

What am I doing wrong here? lol :(

(Also noticed that the Configure button does nothing for any of these choices except for my webcam)
 

M1NO

New Member
M1NO, select "Line 1 (Virtual Audio Cable)" as the audio input device. (:
5) Create Source in one of my current Scenes for DirectShow Audio Source plugin (I tried both DirectSound: Line 1 and Line 1 in the screenshot and both set to Output audio to stream only)

I've already stated that I've tried both for the audio input device.. still no luck.. I selected the Direct Sound: Line 1 (Virtual Audio Cable) and the Line 1 (Virtual Audio Cable) .. nada :(

Anyone know why?
 
Last edited:

M1NO

New Member
Did you restart the stream/recording after selecting "line 1 (virtual audio cable"?
Yes. I put my Desktop Audio Device to my actual "Speakers (Realtek High Definition Audio)" on OBS Audio Settings so that viewers can hear my ingame sounds and everything I hear on my end like so:


Then on my scene I tried to add another Audio source which is my Line 1 VAC that I am outputting my iTunes music onto so that I can play music for the viewers but not hear it on my end.



Still don't know what I'm doing wrong.. As I've stated, my goal here is to stream all my desktop sounds normally, but I want to play music JUST for the viewers. I want only them to hear what my iTunes is playing so that I don't get distracted while playing games but I keep them entertained.
 
Last edited:

Jack0r

The Helping Squad
Forum Moderator
Hmm, very strange, I normally have 3 devices
Line 1 (Virtual Audio Cable)
Line 1 (Virtual Audio Cable)(2)
DirectSound: Line 1 (Virtual Audio Cable)
but only Line 1 (Virtual Audio Cable) works, the other two do not. You could in your case try the other ones. One thing though, does iTunes offer you an option to use Line 1 for your Music? In this case, get into your Windows Recording settings and set Line 1 to "listen to" and select your Headset in the dropdown. Then play some music and you should temporarily hear it as well. Just to check that everything between iTunes and VAC works :)
 

M1NO

New Member
Hmm, very strange, I normally have 3 devices
Line 1 (Virtual Audio Cable)
Line 1 (Virtual Audio Cable)(2)
DirectSound: Line 1 (Virtual Audio Cable)
but only Line 1 (Virtual Audio Cable) works, the other two do not. You could in your case try the other ones. One thing though, does iTunes offer you an option to use Line 1 for your Music? In this case, get into your Windows Recording settings and set Line 1 to "listen to" and select your Headset in the dropdown. Then play some music and you should temporarily hear it as well. Just to check that everything between iTunes and VAC works :)

Yes I tried the Listen To, iTunes is definitely playing music through Line 1 VAC. I can see my volume meters bumping music on the Line 1 VAC in volume control without even having to do the "listen to" thing. But the problem still occurs, no music on the stream when I use this plugin to play only music for the viewers on that Line 1 VAC.


.... Why is life so hard.....
 
Last edited:
Top