Resource icon

CLR Browser Source Plugin [OBS Classic ONLY]

Elyanth

New Member
I can't open configuration pane from CLR. I can hit it , but nothing pops up. Already tried reinstalling (both obs and clr), and downgrading obs. Not working yet. Any ideas? Here's the log and some images, just in case



 

Attachments

Sapiens

Forum Moderator
@Elyanth Open the source properties for your browser source by double-clicking on it in the sources box. You can't configure the CLR Host plugin.
 

Elyanth

New Member
@Sapiens Problem seems to be on CLR browser, not on CLR host, it's CLR browser the one i can't open the configuration pane on, neither by double clicking nor from contextual menu.
 

Sapiens

Forum Moderator
@Elyanth Your screenshot shows that you're trying to access it via the plugins window, which is incorrect. Right-click on your browser source in the sources window (not the plugins window) and select Properties if double-clicking doesn't work.
 

Elyanth

New Member
@Sapiens The screenshot was only intended to show I have the plugin installed. Double clicking on the sources window or right-clicking and then hitting properties both do nothing. Also when trying to add a new CLR browser to a scene, also nothing happens.
 

Sapiens

Forum Moderator
@Elyanth Gotcha. Based on the behavior you're seeing in OBS I would suspect it is actually no longer installed, or that some files are missing/damaged. This usually happens with overly-aggressive antivirus software quarantining some of the related files. Disable any third-party antivirus software first (stuff like Windows Defender is fine) and try reinstalling the plugin files.
 

Elyanth

New Member
@Sapiens I've stopped my antivirus, reinstalled everything (again), got a friend to install it from scratch (as i did) with the same installers and it Works for him, but when i tried to add a CLR browser i keep getting no response (both trying to add and, after importing my scenes, to edit an existing one). I've attached the log in case it helps
 

Attachments

Colddawg

New Member
Hi, I am running into the same issue. I have tried older versions of OBS, 32 bit, 64 bit, fresh install of everything, turning off windows defender, etc. I open both the 32 or the 64 version and the CLR Browser plugin shows up in the source list, but when I got to create the source nothing appears. My plugin version says !Internal Version! and I am not sure how to fix that. Everything is current.
Windows 7 home premium
64 bit
 
Last edited:

esschallert

New Member
so first thanks for this plugin, but i got some problems with it.

Iam using the Twitchalert, alertbox nightdevs chat and a donation scroller, an there it starts to stutter/lagging, the text, or for example if someone follows me it the gif and the text animation is running with like 5 fps, the sound is normal but only the displayed graphics are stuttering. Is there some workaround for it?
 
Re: CLR Browser Source Plugin
I have no idea how to install this on my computer. I have watch tutorials, I did it exactly how I am supposed to, I have done it before on another computer and it worked, and I even installed the nightdev pack. But with the CLRHostPlugin.dll file in my plugins folder OBS keeps crashing. I am out of ideas, I have tried everything, can anyone help me? Here is my crash report...

Crashing thread stack trace:
Stack EIP Arg0 Arg1 Arg2 Arg3 Address
0018F014 00CD6B78 0018F03C 791BE41C 00CD14E0 791BE42B <unknown>!0xcd6b78
0018F018 791B50D5 00CD14E0 791BE42B 00008000 043E2000 mscorwks.dll!Ordinal77+0x50d5
0018F020 791BE41C 043E2000 043EA000 793E7080 00000000 mscorwks.dll!Ordinal77+0xe41c
0018F044 791BE4AD 00001000 043E2000 043E2000 00010000 mscorwks.dll!Ordinal77+0xe4ad
0018F068 791CD4C7 00008000 00001000 043E2000 00008000 mscorwks.dll!0x791cd4c7
0018F0B4 791CD4FA 00008000 00001000 043E2000 00008000 mscorwks.dll!0x791cd4fa
0018F0EC 791CD679 791CEAC8 0F738160 793DD0B8 00C78680 mscorwks.dll!0x791cd679
0018F134 791D09AE 00000000 0F738160 793DD0B8 00C78680 mscorwks.dll!0x791d09ae
0018F160 791CED2D 00000000 01085058 0018F1A4 792C61E8 mscorwks.dll!0x791ced2d
0018F190 791B16D2 00000000 0018F1F4 0F084363 00CD2698 mscorwks.dll!Ordinal77+0x16d2
0018F1A0 792C61E8 00CD2698 010852A0 010850A0 0F080000 mscorwks.dll!0x792c61e8
0018F1AC 0F084363 761678B0 00E9141C 0F08611D 00E9141C clrhostplugin.dll!0xf084363
0018F1FC 0F086015 00E91438 0F734D90 00C8D010 00000080 clrhostplugin.dll!0xf086015
0018F218 01162E40 011ADA33 00000001 00000000 02100210 obs.exe!OBS::OBS+0x1ac0
0018F718 0115B47B 01110000 00000000 00C82D65 00000001 obs.exe!WinMain+0xa5b
0018FBF4 011ADB3A 00223000 761638D0 978CCFCC 0018FC94 obs.exe!__tmainCRTStartup+0xfd
0018FC40 761638F4 00223000 963541B9 00000000 00000000 kernel32.dll!0x761638f4
0018FC54 778F56C3 FFFFFFFF 7791B6F3 00000000 00000000 ntdll.dll!0x778f56c3
0018FC9C 778F568E 011ADA33 00223000 00000000 00000000 ntdll.dll!0x778f568e

A minidump was saved to C:\Users\user\AppData\Roaming\OBS\crashDumps\OBSCrashDump2015-12-13_2.dmp.
Please include this file when posting a crash report.

List of loaded modules:
Base Address Module
01110000-0128A000 C:\Program Files (x86)\OBS\OBS.exe
77890000-77A0B000 C:\WINDOWS\SYSTEM32\ntdll.dll
76150000-76230000 C:\WINDOWS\SYSTEM32\KERNEL32.DLL
75C00000-75D7E000 C:\WINDOWS\SYSTEM32\KERNELBASE.dll
754C0000-75638000 C:\WINDOWS\SYSTEM32\CRYPT32.dll
74750000-7480E000 C:\WINDOWS\SYSTEM32\msvcrt.dll
77690000-7769E000 C:\WINDOWS\SYSTEM32\MSASN1.dll
746F0000-7474F000 C:\WINDOWS\SYSTEM32\WS2_32.dll
75080000-750C4000 C:\WINDOWS\SYSTEM32\sechost.dll
74AD0000-74B7D000 C:\WINDOWS\SYSTEM32\RPCRT4.dll
6F7B0000-6F7B9000 C:\WINDOWS\SYSTEM32\AVRT.dll
6F920000-6F9A3000 C:\WINDOWS\SYSTEM32\dxgi.dll
745C0000-745DE000 C:\WINDOWS\SYSTEM32\SspiCli.dll
72960000-7297D000 C:\WINDOWS\SYSTEM32\dwmapi.dll
745B0000-745BA000 C:\WINDOWS\SYSTEM32\CRYPTBASE.dll
75BA0000-75BF8000 C:\WINDOWS\SYSTEM32\bcryptPrimitives.dll
77710000-77857000 C:\WINDOWS\SYSTEM32\USER32.dll
75FB0000-760FF000 C:\WINDOWS\SYSTEM32\GDI32.dll
76290000-7768F000 C:\WINDOWS\SYSTEM32\SHELL32.dll
750D0000-7528D000 C:\WINDOWS\SYSTEM32\combase.dll
68240000-6826C000 C:\WINDOWS\SYSTEM32\d3d10_1.dll
75480000-754B7000 C:\WINDOWS\SYSTEM32\cfgmgr32.dll
0FCE0000-0FD54000 C:\WINDOWS\SYSTEM32\d3dx10_43.dll
74B80000-75079000 C:\WINDOWS\SYSTEM32\windows.storage.dll
75D80000-75DFB000 C:\WINDOWS\SYSTEM32\ADVAPI32.dll
75430000-75475000 C:\WINDOWS\SYSTEM32\shlwapi.dll
73E80000-73EAF000 C:\WINDOWS\SYSTEM32\IPHLPAPI.DLL
74870000-7495B000 C:\WINDOWS\SYSTEM32\ole32.dll
72CD0000-72CF4000 C:\WINDOWS\SYSTEM32\WINMM.dll
776A0000-776AC000 C:\WINDOWS\SYSTEM32\kernel.appcore.dll
75AE0000-75B6D000 C:\WINDOWS\SYSTEM32\shcore.dll
0F710000-0F914000 C:\Program Files (x86)\OBS\OBSApi.dll
76230000-76274000 C:\WINDOWS\SYSTEM32\powrprof.dll
526D0000-5272C000 C:\WINDOWS\SYSTEM32\d3d10_1core.dll
6F9B0000-6FBCA000 C:\WINDOWS\SYSTEM32\d3d11.dll
75B70000-75B7F000 C:\WINDOWS\SYSTEM32\profapi.dll
72CA0000-72CC3000 C:\WINDOWS\SYSTEM32\WINMMBASE.dll
745E0000-745E6000 C:\WINDOWS\SYSTEM32\PSAPI.DLL
74150000-741EB000 C:\WINDOWS\SYSTEM32\WINHTTP.dll
6B670000-6B824000 C:\Program Files (x86)\OBS\libx264-146.dll
71220000-7138B000 C:\WINDOWS\WinSxS\x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.10586.20_none_22adb5eaa762c7fa\gdiplus.dll
73E00000-73E75000 C:\WINDOWS\SYSTEM32\UxTheme.dll
69590000-69597000 C:\WINDOWS\SYSTEM32\XINPUT9_1_0.dll
77860000-7788B000 C:\WINDOWS\SYSTEM32\IMM32.DLL
75E00000-75F1F000 C:\WINDOWS\SYSTEM32\MSCTF.dll
57A10000-57A31000 C:\PROGRA~2\Raptr\ltc_help32-106010.dll
76100000-76142000 C:\WINDOWS\SYSTEM32\WINTRUST.dll
73BC0000-73DCF000 C:\WINDOWS\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.10586.0_none_d3c2e4e965da4528\Comctl32.dll
75F20000-75FA4000 C:\WINDOWS\SYSTEM32\clbcatq.dll
6F860000-6F8B5000 C:\WINDOWS\System32\MMDevApi.dll
72980000-72ACB000 C:\WINDOWS\System32\PROPSYS.dll
708D0000-708F2000 C:\WINDOWS\System32\DEVOBJ.dll
75290000-75322000 C:\WINDOWS\SYSTEM32\OLEAUT32.dll
0F080000-0F0A9000 C:\Program Files (x86)\OBS\plugins\CLRHostPlugin.dll
69B40000-69B99000 C:\WINDOWS\SYSTEM32\mscoree.dll
69AC0000-69B39000 C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscoreei.dll
79040000-79085000 C:\Windows\Microsoft.NET\Framework\v1.1.4322\fusion.dll
7C340000-7C396000 C:\Windows\Microsoft.NET\Framework\v1.1.4322\MSVCR71.dll
791B0000-79412000 C:\Windows\Microsoft.NET\Framework\v1.1.4322\mscorwks.dll
04500000-0462C000 C:\Program Files (x86)\OBS\DBGHELP.DLL
 

SiLeNtCovenant

New Member
Looks like Twitch updated something on their end that doesn't allow their popup chat to be rendered on older versions of Chrome. Can this be updated, please? The Twitch chat just shows up as a gray box with the logo in the middle
 

.c0dy

New Member
@Sapiens I've stopped my antivirus, reinstalled everything (again), got a friend to install it from scratch (as i did) with the same installers and it Works for him, but when i tried to add a CLR browser i keep getting no response (both trying to add and, after importing my scenes, to edit an existing one). I've attached the log in case it helps
I think I just resolved the "issue". Make sure that "Always on top" is not checked. This way I can finally make changes again / see the windows again.

 

Reyjkl

New Member
I am having a problem with clr browser in OBS. It installed fine on 64 bit and it worked at first but recently I started having a problem and my clr browser sources started to not work and crash OBS if i tried to change the properties. I attempted to create a new clr browser source and everytime I clicked ok to confirm the source title obs would crash (stop responding) and I would have to close it out. There was a forum post on NightDev with someone who was having the same problem but it was never answered (at least according to this: https://community.nightdev.com/t/clr-browser-crashing-obs/1357).
I tried reinstalling CLR browser multiple times but nothing changed.

Here is my latest log: https://gist.github.com/a7d93616f8deb22745a7

If you have any solutions to this bizarre problem please don't hesitate to tell me.

Thank you
 

Reyjkl

New Member
Hello,

i installed OBS 64bit, .NET, C++ Runtimes. I can find the function in OBS. But it displays no Websites or TwitchAlerts in my stream. I dont know why.
Can somone help me?

Logfile: http://pastebin.info/?paste=2709
You do have clr browser right? because that is the plugin you need to show webpages on stream (like twitch alerts)

[edit] ok so I took a look at your log file and saw that you do have clr browser installed. However, I am still uncertain of exactly what your doing to try and get obs to display websites on stream. Your post is extremely vague and I suggest you revise it so that we know
1. what the problem is
2. steps that made the problem occur
3. what you did to try to fix it (any troubleshooting)
 

EhsanKia

New Member
Is there any way to tell you're inside a CLR browser through Javascript? Any special parameters or objects that CLR Browser injects in the window environment that can be used to detect that?
 

Pimpmuckl

New Member
I have some interesting issues with the latest version: If I add a 1600x900 CLR Browser capture, I get a ton of GPU load (AMD Fury) and the frame rate tanks a ton. Seems like it's incredibly inefficient.

It directly is influenced by the size of the window in width and height, the larger the window, the worse the performance.

Going back to the v2 version in the OP makes it a bit better but it doesn't support transparency in the video which I need.

I can't seem to figure out a way to force the CPU to render or capture the scene. The WebGL option in advanced features doesn't do anything it seems like.

Log: https://gist.github.com/e36513d5c01b240c399b
 
Last edited:

Vod

New Member
I am having issues getting a locally stored HTML file to display in OBS using the CLR Browser. I add the file location like i would with a Twitch Alerts address but get nothing.
Any Help would be fantastic!
 

schoolruler

New Member
I have looked around on how to install the CLR browser plugin, but I having trouble making it work. I have installed the prerequisites and tried 32 and 64-bit. Where should I look for a solution?

PC specs:
AMD 8350 @4.0GHz
16GB ram @1600MHz
AMD 7950 3GB vram
Running on Windows 10 64-bit
 

skullmonkey

New Member
I'm trying to apply a glitch animation to my text. I get it to work in Firefox, but not in OBS.

The css that supposed to be in the .html file is this:

Code:
    <style>
        @keyframes noise-anim {
            0% { clip: rect(17px, 9999px, 58px, 0); }
            5% { clip: rect(99px, 9999px, 75px, 0); }
            10% { clip: rect(33px, 9999px, 10px, 0); }
            15% { clip: rect(70px, 9999px, 71px, 0); }
            20% { clip: rect(99px, 9999px, 16px, 0); }
            25% { clip: rect(74px, 9999px, 71px, 0); }
            30% { clip: rect(75px, 9999px, 42px, 0); }
            35% { clip: rect(4px, 9999px, 66px, 0); }
            40% { clip: rect(21px, 9999px, 45px, 0); }
            45% { clip: rect(29px, 9999px, 20px, 0); }
            50% { clip: rect(55px, 9999px, 83px, 0); }
            55% { clip: rect(20px, 9999px, 48px, 0); }
            60% { clip: rect(58px, 9999px, 63px, 0); }
            65% { clip: rect(20px, 9999px, 23px, 0); }
            70% { clip: rect(94px, 9999px, 11px, 0); }
            75% { clip: rect(71px, 9999px, 17px, 0); }
            80% { clip: rect(18px, 9999px, 21px, 0); }
            85% { clip: rect(84px, 9999px, 58px, 0); }
            90% { clip: rect(62px, 9999px, 49px, 0); }
            95% { clip: rect(24px, 9999px, 34px, 0); }
            100% { clip: rect(54px, 9999px, 81px, 0); }
        }

        @keyframes noise-anim-2 {
            0% { clip: rect(1px, 9999px, 36px, 0); }
            5% { clip: rect(59px, 9999px, 57px, 0);}
            10% { clip: rect(86px, 9999px, 30px, 0);}
            15% { clip: rect(95px, 9999px, 83px, 0);}
            20% { clip: rect(79px, 9999px, 6px, 0);}
            25% { clip: rect(56px, 9999px, 79px, 0);}
            30% { clip: rect(44px, 9999px, 91px, 0);}
            35% { clip: rect(66px, 9999px, 39px, 0);}
            40% { clip: rect(46px, 9999px, 11px, 0);}
            45% { clip: rect(59px, 9999px, 63px, 0);}
            50% { clip: rect(11px, 9999px, 20px, 0);}
            55% { clip: rect(42px, 9999px, 69px, 0);}
            60% { clip: rect(77px, 9999px, 69px, 0);}
            65% { clip: rect(31px, 9999px, 76px, 0);}
            70% { clip: rect(75px, 9999px, 71px, 0);}
            75% { clip: rect(31px, 9999px, 2px, 0);}
            80% { clip: rect(13px, 9999px, 6px, 0);}
            85% { clip: rect(36px, 9999px, 100px, 0);}
            90% { clip: rect(85px, 9999px, 65px, 0);}
            95% { clip: rect(80px, 9999px, 64px, 0);}
            100% { clip: rect(45px, 9999px, 10px, 0);}
        }
    </style>
It looks like this code is not supported?
Any help is appreciated.

Thanks,
Gorast
 
Top