Question / Help ChromaKey Opacity - Showing Opaque Black Instead of Transparent

SophieVision

New Member
Hiya!

I'm a bit new to OBS and I tried searching for a solution, but might not know all the terms or steps I need to achieve what I want.

I have a greenscreen and a scene. I have applied the chromakey filter to the scene, and adjusted the settings. In the Filter window, everything appears correctly (that is, the area of the greenscreen is a neutral dark gray color).

What happens is that when I close the Filter window, my Green Screen area becomes black, rather than showing through to the layer I have placed behind it (right now it's temporarily set to display a browser window). It's completely opaque.

Have I missed a step here? All the videos I've seen on youtube have done exactly what I have done and POOF, transparent background like magic.

Thanks for any help or direction you can provide!
 

koala

Active Member
A screenshot of your monitor with the chromakey configuration open (to see the settings) and a screenshot of the OBS main window (where you see black background instead of the background image in the preview, including scene and source setup) might help to understand what's wrong. Usually, it should work as you described.
 

SophieVision

New Member
Here's a shot of what's going on. The black area should be transparent.

Edit: I'm using the defaults on the ChromaKey config just to ensure that it's not me that's messing something up.
 

Attachments

Top