can't use game capture or display capture

salam turk

New Member
like a couple of months ago i wanted to record some stuff but when i used display capture of game capture non worked
so i my friend told me to watch a video and blah blah blah...
so i have tried to fix it but nothing works
changed what the app runs on either it is integrated or gpu and nothing changed
i have fully uninstalled and deleted some of the temp files
but this issue still doesnt let me record
i see a black screen thats it
but recently i found out about window capture and window capture works perfectly no problems with it. havent used it that much
so i really need a fix for recording gameplay and other stuff
but i mostly need it for recording my classes
i have been relying on nvidea shadow play but it doesnt record apps that arent games
pls i need help
paste bin of log https://pastebin.com/zmLjuLfU
 

salam turk

New Member
i have already tried this and it doesnt help
tried it multiple times
 

FerretBomb

Active Member
17:59:04.441: Available Video Adapters:
17:59:04.450: Adapter 0: NVIDIA GeForce GTX 1650
17:59:04.450: Dedicated VRAM: 4154458112
17:59:04.450: Shared VRAM: 4231653376
17:59:04.450: PCI ID: 10de:1f91
17:59:04.450: Driver Version: 27.21.14.6140
17:59:04.451: output 0: pos={0, 0}, size={1920, 1080}, attached=true, refresh=60, name=
17:59:04.451: Adapter 1: Intel(R) UHD Graphics 630
17:59:04.451: Dedicated VRAM: 134217728
17:59:04.451: Shared VRAM: 4231653376
17:59:04.451: PCI ID: 8086:3e9b
17:59:04.451: Driver Version: 27.20.100.8729
17:59:04.459: Loading up D3D11 on adapter NVIDIA GeForce GTX 1650 (0)
OBS is running on your 1650. To use a Monitor Capture, you need to set it to run on the integrated GPU. Here are updated instructions, for Win10 1903 or later (you are on the 20H2 version, so this applies):
 

salam turk

New Member
OBS is running on your 1650. To use a Monitor Capture, you need to set it to run on the integrated GPU. Here are updated instructions, for Win10 1903 or later (you are on the 20H2 version, so this applies):
hello ferret bomb.
i have already tried this and it doesnt work. i also tried the nvdia control panel program settings
nothing works but ill try again and see if it works
 

salam turk

New Member
OBS is running on your 1650. To use a Monitor Capture, you need to set it to run on the integrated GPU. Here are updated instructions, for Win10 1903 or later (you are on the 20H2 version, so this applies):
i have tried this again and it still doesnt change anything
idk if this is a problem.. it probably isnt
but in the graphic settings it doesnt say classic app it says desktop app but i think thats just a new update
 

FerretBomb

Active Member
hello ferret bomb.
i have already tried this and it doesnt work. i also tried the nvdia control panel program settings
nothing works but ill try again and see if it works
After you try it (in the OS, not in the nVidia control panel) do a test-recording and post another logfile, we can look and see what's going on.
 

salam turk

New Member
After you try it (in the OS, not in the nVidia control panel) do a test-recording and post another logfile, we can look and see what's going on.

here is the latest log
and here is the video but its too big so i added to google drive file
it looks kinda laggy but that is the recorder not my pc


and i also found out that bitbit doesnt work in window capture
 

FerretBomb

Active Member
You are still running OBS on the GTX 1650 according to that log, not the Intel UHD.
Can you grab a screenshot of where you set OBS to run on the low-power GPU? If it is in the nVidia control panel, that is not the right place.
 

salam turk

New Member
You are still running OBS on the GTX 1650 according to that log, not the Intel UHD.
Can you grab a screenshot of where you set OBS to run on the low-power GPU? If it is in the nVidia control panel, that is not the right place.
is it a problem that it is in my nvidea control panel also?
but in there its also set to integrated gpu which is the cpu
 

FerretBomb

Active Member
It isn't a problem that it's also set in the nVidia control panel, it's just ignored by Windows.
That's strange then; did you upload an old log file maybe? The screenshot is the correct place to set it, but your log file is saying it isn't set there.
 

salam turk

New Member
It isn't a problem that it's also set in the nVidia control panel, it's just ignored by Windows.
That's strange then; did you upload an old log file maybe? The screenshot is the correct place to set it, but your log file is saying it isn't set there.
hello? its been 2 days and you havnt responded
 

FerretBomb

Active Member
hello? its been 2 days and you havnt responded
Everyone here is a volunteer helper; OBS doesn't employ any staff other than Jim. I drop in to help out now and then, but life comes first. :)
Your most recent-posted log STILL shows OBS as running on the 1650. Until you have it running on the Intel GPU, Display Capture absolutely will not work.

Do be aware that if you switch to the Intel GPU, your Window and Game Capture sources will no longer work... only Display Capture. It's one of the reasons that laptops aren't recommended for streaming.
 

salam turk

New Member
Everyone here is a volunteer helper; OBS doesn't employ any staff other than Jim. I drop in to help out now and then, but life comes first. :)
Your most recent-posted log STILL shows OBS as running on the 1650. Until you have it running on the Intel GPU, Display Capture absolutely will not work.

Do be aware that if you switch to the Intel GPU, your Window and Game Capture sources will no longer work... only Display Capture. It's one of the reasons that laptops aren't recommended for streaming.
ok thank you i will look into it more
 

salam turk

New Member
It isn't a problem that it's also set in the nVidia control panel, it's just ignored by Windows.
That's strange then; did you upload an old log file maybe? The screenshot is the correct place to set it, but your log file is saying it isn't set there.
i fucking fixed it omg
i hate my life
i downloaded the app twice and i placed it on my d drive
and like a dumbass i forgot that it was there
so now it is fixed
for YEARS
thank you
 
Top