Can't play SRT stream through media source on OBS Linux. Works on Windows and through ffplay in Linux.

Caene

New Member
OS: Ubuntu Server 20.04
SLS version: 1.4.6
SRT version: 1.4.1
OBS Linux version: 25.0.8

Not sure what I am doing wrong here! The SRT server is running smoothly (https://github.com/Edward-Wu/srt-live-server). I can even add the server as media source in OBS on Windows, and it plays really nicely with low latency and all.

But the second I add the same information into media source on Linux, it will not run. I have compiled ffmpeg with libsrt and everything needed. I can play the stream through ffplay on the same Linux system I have the server running on. So the server is up and running, and I can play it with ffplay on Linux and it works on Windows OBS - but it just refuses to start the media in OBS on Linux.

Windows OBS (working, using internal IP):


Linux OBS (not working, tried using internal IP and external IP): No need to link image. It's the same settings, but with a black screen. It's not picking up the stream.

Linux FFPLAY (ffplay via terminal):


I have tried changing/forcing input formats like hevc and mpegts in OBS on Linux, but there is no stream coming through. I have tried unchecking and checking all the settings in media source, nothing really changes.

I mean, it's quite clear that libsrt is enabled and working, since I'm using the protocol through ffplay. And the stream is working perfectly in OBS on Windows. I guess one weird thing, is that I cant watch the stream on VLC by adding the srt url, I have to use ffplay to get the srt stream to work through VLC.

Anyway! What am I missing here? I have tried re-installing OBS on Linux, with no luck. I have yet to compile one from source though. I will try that as a next step.
 

OscarParzon

New Member
Hi. Any ideas ?.
I have the same problem. In windows it works using the recording option.
I couldn't find a way to stream SRT from Ubuntu using OBS.
FFmpeg works OK.
Maybe it is that OBS for Linux does not have the Tx SRT available?
 

danma06

New Member
That's beginning to be my belief. Although I don't have any Windows boxes I can test this with. Maybe SRT works in Windows but it was forgotten to be included in the Linux builds?
 

Th3irdEye

New Member
I know this is months old at this point but I just want to confirm that trying to play an SRT stream from a media source on Linux does not work for me. I spun up a VM and installed Windows after seeing this thread and tested the same SRT stream I was trying to get to load on Linux and it worked immediately in Windows. Something is broken in the Linux version of OBS related to SRT.
 

Filip S

Member
I am forced to use srt-live-transmit on linux to make it listen for SRT and then output UDP it to loopback 127.0.0.1 because its impossible to make my OBS 26.1.1 listen for SRT input RX - I have tried alot both compiled versions and snap versions so something is not working with OBS Linux and SRT API - I am not sure if the problem also exist on the MacOSX anyway I can't solve this.
I have a ffmpeg compiled with libsrt etc - on my raspberry I can transmit SRT using full hd/25 frames and it works perfekt to my Linux with OBS and srt-live-transmit -a -s 5000 srt://:4001?passphrase=secret1 udp://127.0.0.1:4501
Then I can add the mediasource as udp on port 4501 but this is just my workaround because something is broken with linux OBS/SRT.
- I am not sure about the SRT output /streaming from OBS but transmission from one linux OBS to antoher linux OBS using SRT does not work but maybe its only the RX part.
 
Top