Auto-Duck in Real Time

Non-Free Auto-Duck in Real Time 2.2.2

achmetha, i cant seem to get this to work, i have a Micomsoft XCAPTURE-1 card and and Soundblaster XFI card. In audio renders i have the following....

Default DirectSound Device
Deafult WaveOut Device
DirectSound: SPDIF OUT (SB X-Fi)
DirectSound: Speakers (SB X-Fi)
SPDIF Out (SB X-Fi)
Speakers (SB X-Fi)

When i try and join the Audio Capture to the audio input pin, i get the following error......



i have tried all the above and the only one that successfully joins is the 'Speakers (SB X-Fi)' but when i click on the green play button i hear no audio, does OBS have to be open and previewing the capture for me to hear audio??
 
Got it working now, i need to setup GraphEdit first and then launch OBS, now i can use auto-duck whilst grabing the audio directly from the capture device hence no more audio lag, great stuff!!!!

Wojciesh, is there a way you could implement this into your program at all?
 

achmetha

Member
Got it working now, i need to setup GraphEdit first and then launch OBS, now i can use auto-duck whilst grabing the audio directly from the capture device hence no more audio lag, great stuff!!!!

Wojciesh, is there a way you could implement this into your program at all?
It could also be that you still have OBS trying to open the Audio Stream in the Device Settings. Only 1 software program can access the streams individually at a time.
 
Last edited:

WasabiIceCream

New Member
I'm getting .NET Framework errors out the Wazoo.
Not sure what the issue is, because it used to work.
As soon as I run it, though, it's throwing exceptions, and not working at all.
 
Hmmmm, ive started to experience a problem and not sure whats causing it. For some reason now when i load up GraphEdit and load my preset is seems to kill the audio for the capture!, the audio graph displaying the volume level on OBS doesn't register anything at all. If i stop the capture close GraphEdit and then start the capture again then i get audio from the capture as i can see the audio bar in OBS moving. Any ideas what could be causing this issue?
 

Wojciesh

Member
homebro2000 - I have a lot of work right now and checking it can take little longer. I will try to give answer next week.
 
I have Roland Octa Capture, it is audio interface and I am running Mic and Game sound to it.
I would like to use Auto Duck to manage my sound, however when I add my audio, it does not sound anything at all.

When I add same sound source to OBS, it detects the sound,

Here are some example







Is there anyway that I can get this working?
 

achmetha

Member
Hmmmm, ive started to experience a problem and not sure whats causing it. For some reason now when i load up GraphEdit and load my preset is seems to kill the audio for the capture!, the audio graph displaying the volume level on OBS doesn't register anything at all. If i stop the capture close GraphEdit and then start the capture again then i get audio from the capture as i can see the audio bar in OBS moving. Any ideas what could be causing this issue?
Might be the same issue as before (multiple softwares trying to access audio stream simutaneously), or it could be the wrong Audio Renderer in GraphEdit. What Desktop Audio Device are you using in OBS vs what are you using in GraphEdit? Using Virtual Audio Cable by chance?
 
Might be the same issue as before (multiple softwares trying to access audio stream simutaneously), or it could be the wrong Audio Renderer in GraphEdit. What Desktop Audio Device are you using in OBS vs what are you using in GraphEdit? Using Virtual Audio Cable by chance?
Ive uploaded a video to show the issue im having......

https://youtu.be/uSH1RPupXK4

Well i have a sound blaster xf-i card and the desktop audio device im using of OBS is just set to 'Default' in the Audio settings
 

achmetha

Member
I have Roland Octa Capture, it is audio interface and I am running Mic and Game sound to it.
I would like to use Auto Duck to manage my sound, however when I add my audio, it does not sound anything at all.

When I add same sound source to OBS, it detects the sound,

Here are some example

Is there anyway that I can get this working?
you have your desktop audio muted in obs. that speaker needs to be red for it to be active. it works with your capture device in obs because it outputs to stream, thats why you see the audio bar moving. when you output the audio to desktop using graphedit, the speaker is muted in obs, so you see no activity.

tldr: click the speaker to make it active (red). should fix the problem :)
 
Nah all that red speaker does it output audio form the capture to the desktop, muting it doesn't mute the audio from the actual capture device it just stop the audio being sent the desktop speakers. If you were to unmute the red speaker icon then if you got an email or Skype message then this notification sound from these programs would be picked up in your capture that why i always have the red speaker muted!

The green bar underneath the red speaker icon is the audio from the actual capture card and as you can see even when the red speaker is muted the green bar still goes up and down. As soon as the capture audio and PC soundcard is 'linked' within GraphEdit it kills the audio of the capture card, as you can see there is no activity in green bar anymore
 

achmetha

Member
Nah all that red speaker does it output audio form the capture to the desktop, muting it doesn't mute the audio from the actual capture device it just stop the audio being sent the desktop speakers.
This is your exact problem. GraphEdit outputs the audio to Desktop, which you have muted.
That speaker being muted, mutes all desktop sound. If you go into OBS, and set your desktop audio to disabled. Check and see that the capture card audio will still show a green bar if not using GraphEdit.

The capture card audio can only be used by either:
A) OBS by itself
or
B) GraphEdit by itself (by streaming the audio to desktop).
Not both at the same time, that is just how these directshow devices work.

So as soon as you tell GraphEdit to "Open the Audio Stream" to your Xi-Fi Sound Card, OBS can no longer use the stream itself.
This is 100% what your issue is, so this workaround may not be for you from what it sounds like.

Your only other option would be to use something like Virtual Audio Cable, have GraphEdit output the capture card audio to Line 1, then Windows Sound, use the "Listen to Device" option to your Xi-Fi Sound on Line 1, then set OBS to use Line 1 as desktop audio. That is the only way this will work and not include skype message sounds, etc. Otherwise, GraphEdit will not be able to do what you want it to do.
 
Hey man thanks for the video.

But for the way your using OBS you do know you dont even need to use GraphEdit???. In the capture card device settings in OBS you can just disable the 'Output Audio To Stream Only' setting and enable the 'Output Audio To Desktop' that achieves the same thing GraphEdit is doing for you now!!. The only reason i wanted to use the 'Output Audio To Stream Only' setting was the 'Output Audio To Desktop' setting caused audio sync issue on the capture file, with the 'Output Audio To Stream Only' setting the audio was synced fine, but obviously you cant use Auto-Duck when you use the Output Audio To Stream Only' setting.

All GraphEdit is doing for you is using the same method as the 'Output Audio To Desktop' setting option in OBS but your just having to use an additional program (graphedit) to achieve that!

I was hoping that graphedit was going to piggyback on the audio from the actual capture card on a hardware level but it doesnt do this it kills the audio coming from the hardware and just sends it to the desktop via software and as i said you can achieve just this feature by using 'Output Audio To Desktop' option only and dont even need graphedit!

So just a heads up you dont even need Graphedit.

PS. What program did you used to capture your actual desktop?
 

achmetha

Member
So just a heads up you dont even need Graphedit.

PS. What program did you used to capture your actual desktop?
See my original post about GraphEdit as to why I am using this method.
https://obsproject.com/forum/threads/auto-duck-in-real-time.16224/page-2#post-167741

I previously used the method you have suggested (as it is WAY more simplified), but have since moved onto the OBS & GraphEdit combo for livestreaming console games.

I used OBS Studio (OBS MP) to capture desktop.
 
Top