Non-Free Auto-Duck in Real Time 2.1-BETA

Better AUDIO! Reduce game volume when SPEAKING or on HOTKEY! Audio ducking for Streamers and YouTube

  1. Wojciesh Member

    Wojciesh submitted a new resource:

    Auto-Duck in Real Time - Reduce volume of any game in real time. Live auto-ducking for streamers.

    Read more about this resource...
  2. dacoder Active Member

    Congrats, the first pay-to-use application on the OBS forums.
    Aside from that, looks good, will try tomorrow.
  3. etrnlwait Active Member

    Not sure where this can be effectively applied.

    The only thing that comes to mind is maybe raising the music volume when you're quiet on Stream and then lowering it a bit when you talk.

    Anyone?
  4. Wojciesh Member

    Yes, your are correct. Another example could be when you stream gameplay and want to reduce game volume when talking to microphone.
    Here are videos demonstrating such usage (this is Polish streamer - RockAlone):
    https://www.youtube.com/user/RMaciaszek/videos
  5. Jeff Darby Member

    Couldn't you just link us to a specific video?
  6. Wojciesh Member

    Well, he uses it in all his videos. But if you want specific video where auto-ducking is nicely visible you can watch some car racing gameplay, like this: https://www.youtube.com/watch?v=po_TWeov46c. There you can easily hear how car engine volume is smoothly reduced when he talks to microphone.
  7. Jack0r The Helping Squad

    Moderator

  8. Wojciesh Member

    Wojciesh updated Auto-Duck in Real Time with a new update entry:

    Auto-Duck in Real Time v1.3

    Read the rest of this update entry...

    Also, thank you Jack0r for this nice video tutorial!
    Last edited: Aug 4, 2014
  9. BlockAboots Active Member

    Is there any discount codes going atm please?
  10. BlockAboots Active Member

    Hmmm, im unable to get this to work. I have it setup correctly so when im listening to it live the game auido level drops when i speak, but when i listen to it back from the capture file the audio level doesnt drop. Im using AmaRec for my capture program and using a USB3 capture device (micomsoft X-Capture1) Any ideas?
  11. Wojciesh Member

    Hi BlockAboots, please tell me what have you selected as inputs and ducked channel. You could try to select AmaRec on Playback device as ducked channel.
    If you still have this problem please contact me and send me more details about your streaming setup and Auto-Duck configuration.

    Now about Promo Codes... if you think price is to high you can always contact us to get discount!
  12. BlockAboots Active Member

    Have sent you a message
  13. BlockAboots Active Member

    Hmmm it seems that the only way to setup AmaRec and OBS is to have is so your capture will record not only the game you want to capture but also all the PC system audio, say for example MSM messenger/Skype, anti virus, windows update tones all will get picked up in the capture as well.

    I have a Micomsoft XCapture-1 USB3 capture device and usually use AmaRecTv or OBS (in video Capture device mode) and in order for the audio ducking to be picked up in the actual raw output capture file is to, in OBS enable 'Output Audio To Desktop' so you get the audio from your capture also coming through your PC speakers.....

    [​IMG]

    and for AmaRec going into config and Graph 3(Live) enabling 'Mixer' and 'Loopback Video Capture Fix' setting, set PC Internal Sound Device to AmaRec Stereo Mixer and then selecting "What You Hear" (Creative SB X-Fi) for input......

    [​IMG]

    But as i said above in doing this then the capture will pick all you PC system sounds as well
    Wojciesh likes this.
  14. Wojciesh Member

    Please note, that when you use only OBS there is no need to do this - this is only workaround for AmaRec issue.

    EDIT: it seems that this is workaround not only for AmaRec but for general scenario when capturing game from console using capturing device.

    If you are hearing echo or some noise or other artifacts try to enable/disable "Use WaveOut audio renderer" option in Device Selection in OBS.
    Last edited: Oct 11, 2014
  15. wongJP Member

    I'm using OBS with an Elgato Game Capture HD (streaming console gameplay). I've had to change the setting (in OBS) for Output to Desktop sound. However, this records the sound at a delay (for instance, visually I'm in a racing game and I hit a wall, but the sound of the car hitting the wall comes a second later or such).

    Is there a way *not* to use "Output sound to Desktop" when using Auto Duck? I am probably missing a step or setting...

    Thank you in advance for any advice.
  16. Wojciesh Member

    Hi wongJP, please try to enable (or disable) "Use WaveOut audio renderer" option in OBS (below "Output audio to Desktop" option), according to some other posts on this forum this may help.

    Does this issue occurs only when using Auto-Duck or is it only "Output audio to Desktop" option problem?
    I'm not an OBS developer, so if you get this delay regardless of using Auto-Duck, you should contact OBS team.

    If this delay occurs only when using Auto-Duck and above solution didn't work for you please contact me and send me more details about your streaming setup and Auto-Duck configuration.
  17. wongJP Member

    Hi Wojciesh,

    I made some time to test Auto Duck again with OBS.

    I am able to "Output audio to Desktop" and I disabled "Use WaveOut audio renderer". It looks like I was mistaken, but let me explain my setup just in case others might have a similar issue:

    My Plantronics RIG headset is connected to both my PC (earphone jack from headset to computer) as well as my console (optical out from console to optical audio port of headset). There is naturally a recording delay for both video and sound when the audio/video is going through my Elgato Game Capture.

    The issue was that I had to disconnect the Optical cable from my console - so I'd be playing a game but then I would hear the *delayed* audio from the preview stream on my PC. My fault :-)

    That said, Auto Duck works great for what it's made for. Though, I was wondering - is it possible to "Output audio to stream only" instead of having to Output to Desktop (for consoles/game capture devices like the Elgato)?

    I'm aware that any games I play on PC (Steam, Origin, standalone installs) won't run into this issue. Thanks again for your response.

    EDIT: I suppose my best solution (where I am using a headset to listen to console audio), would be to not hook my headset to my PC. I wouldn't be able to hear any desktop sounds or sound coming from PC, but that isn't a problem since I would be listening to my game console audio during those sessions.
  18. Wojciesh Member

    Just some info for potential buyers... BLACK FRIDAY 2014 is here! All Auto-Duck licenses 50% OFF!
    Promotion is active until Monday 01.12.2014 midnight. Buy now!
    [​IMG]
    http://auto-duck.com/buy
  19. Wojciesh Member

    Wojciesh updated Auto-Duck in Real Time with a new update entry:

    Auto-Duck in Real Time v2.0

    Read the rest of this update entry...
  20. Wojciesh Member