Question / Help Apex Legends FPS drops

OneShotRich

New Member
Anyone having this issue with Streaming Apex Legends?

I believe the game may just not be well optimized or I may be doing something wrong, but I’ve never had this problem before.

When I’m playing the game it runs super smooth on any video setting I have. But my stream is struggling with occasional dropped frames ?! I stream with NVENC and have a 1060. I know it can’t be my cp since I stream BFV , Pubg, Black Ops 4 just fine and smooth 900p 60 FPS so I’m going someone could help ! I need to put out a quality content !
 

NachoFox

New Member
I'm having the exact same problem as you with Apex Legends specifically.

The below is a collection of fixes I've found for this "Rendering Lag" problem for Apex, although I am still waiting for a bigger fix as clearly many people are able to record and stream it with no issues. I've done all of the below and it's allowed me to stream and record under certain conditions, but it's certainly not at the level I want it to be.

1. Fully update windows 10 to the latest version (people have suggested going back to get rid of an update which caused this issue, but it's impractical and opens your PC up for viruses etc.)
2. Once updated, search for "Windows Game Bar" - Turn this off
3. Search for "Windows Game Mode" - Turn this off (This basically forces the PC to put all GPU power into a game, leaving none for OBS, so turning it off leaves a bit more free for OBS)
4. Whichever game you are trying to record and stream, add an in-game FPS limit to it, 120 works for some, but 60 is a safer bet.
5. OBS keeps scenes playing in the background to allow you to swap to them, you can right-click on webcam's, videos and audiotracks, and you can turn these to "disable when not in use", which will free up some power for OBS (although does make scene transitions look a bit less smooth unless you use studio mode to do it.
6. If you use a webcam, make it a lower resolution for you gaming scene, typically people only use a small image for their webcam whilst streaming, so having it at 1080 is pointless and using power that is unnecessary - you can keep it at 1080 for a full-screen scene, but make sure "disable when not in use" is ticked so that OBS is not processing this all the time.

These are all of the fixes that I am aware of currently, and they have all helped me slightly, however I am still digging for more information on how to get OBS working with Apex Legends so if anyone can add more to my list, please let me know.
 

OneShotRich

New Member
I'm having the exact same problem as you with Apex Legends specifically.

The below is a collection of fixes I've found for this "Rendering Lag" problem for Apex, although I am still waiting for a bigger fix as clearly many people are able to record and stream it with no issues. I've done all of the below and it's allowed me to stream and record under certain conditions, but it's certainly not at the level I want it to be.

1. Fully update windows 10 to the latest version (people have suggested going back to get rid of an update which caused this issue, but it's impractical and opens your PC up for viruses etc.)
2. Once updated, search for "Windows Game Bar" - Turn this off
3. Search for "Windows Game Mode" - Turn this off (This basically forces the PC to put all GPU power into a game, leaving none for OBS, so turning it off leaves a bit more free for OBS)
4. Whichever game you are trying to record and stream, add an in-game FPS limit to it, 120 works for some, but 60 is a safer bet.
5. OBS keeps scenes playing in the background to allow you to swap to them, you can right-click on webcam's, videos and audiotracks, and you can turn these to "disable when not in use", which will free up some power for OBS (although does make scene transitions look a bit less smooth unless you use studio mode to do it.
6. If you use a webcam, make it a lower resolution for you gaming scene, typically people only use a small image for their webcam whilst streaming, so having it at 1080 is pointless and using power that is unnecessary - you can keep it at 1080 for a full-screen scene, but make sure "disable when not in use" is ticked so that OBS is not processing this all the time.

These are all of the fixes that I am aware of currently, and they have all helped me slightly, however I am still digging for more information on how to get OBS working with Apex Legends so if anyone can add more to my list, please let me know.


This is random but have we tried reinstalling obs ?
 

DEDRICK

Member
It's mostly Game Mode doing it, I was playing Apex uncapped yesterday everything cranked @ 1440p, no rendering lag.

Game uses 97% GPU, OBS uses 3%, this is how it is supposed to work.

The older ways of disabling Game Mode though, like "Disable Fullscreen Optimizations", does not seem to work. Updating to 1809 and disabling it with the toggle does though, YMMV
 
Last edited:

OneShotRich

New Member
It's mostly Game Mode doing it, I was playing Apex uncapped yesterday everything cranked @ 1440p, no rendering lag.

Game uses 97% GPU, OBS uses 3%, this is how it is supposed to work.

The older ways of disabling Game Mode though, like "Disable Fullscreen Optimizations", does not seem to work. Updating to 1809 and disabling it with the toggle does though, YMMV


The toggle as bringing up the game bar then disabling it ? Did it automatically enable it cause I don’t recall having that enabled ?!
 

DEDRICK

Member
Game Mode, this toggle is only available on the newest version of Windows 10

1549492851410.png
 

DEDRICK

Member
Theres a few ways to disable it, one involves bringing up the Game Bar and turning off "Use Game Mode for this game"

Pain in the ass, easier to just update Windows, it's going to happen anyways
 

NachoFox

New Member
It's mostly Game Mode doing it, I was playing Apex uncapped yesterday everything cranked @ 1440p, no rendering lag.

Game uses 97% GPU, OBS uses 3%, this is how it is supposed to work.

The older ways of disabling Game Mode though, like "Disable Fullscreen Optimizations", does not seem to work. Updating to 1809 and disabling it with the toggle does though, YMMV
I made this change yesterday and was able to record / stream at 1920 with a camera, but it was still losing some frames here and there in the odd spike. What GPU and CPU are you rocking?
 

TheChampstation

New Member
Last edited:

Gearsecond

New Member
hi
Yesterday morning i streaming Apex Legends 60fps obs ingame 80fps i stoped a stream 3-4hour late after i moved from home.
Im back at night i started streaming without chaing anything and ingame i have 80fps still in obs 3-10fps WHY?
 

Crispapple

New Member
I thought I was losing my mind and that I accidentally changed an OBS setting. Glad to see more people with the same problems.

The first few days of recording Apex, I was getting really smooth recording playbacks, but ever since two days ago, I'm getting extreme Rendering lag and reduced recording fps. Hopefully it's something to do with the game itself.

GPU: gtx1060 6gb
CPU: AMD Ryzon 5 2600x
Ram: 16GB Ddr4

Blah blablah.. I feel like my rig could handle that game, cause it handles every game pretty well..
 

RYZE

New Member
Enable V-sync Option ingame and it will be fixed.

OK it seems to have fixed itself somehow now.... also could have been the vsync option. I have it on adaptive now. When it was streaming smoothly I def had that set to off. But oh well its working smoothly again now!
 

NachoFox

New Member
For anyone still struggling with this, it's not a fix for everyone, but if anyone has a G-Sync monitor, try turning G-Sync off for any effected games. Along with all of my above fixes, plus this, my stream and video is practically perfect on every game now, including Apex Legends which was the game which really wasn't liking my OBS. I did have a new audio issue which i noticed watching the stream back after, but this is likely for other reasons which I'll need to look into tonight.

My other fixes below, again, for reference:
1. Fully update windows 10 to the latest version (people have suggested going back to get rid of an update which caused this issue, but it's impractical and opens your PC up for viruses etc.)
2. Once updated, search for "Windows Game Bar" - Turn this off
3. Search for "Windows Game Mode" - Turn this off (This basically forces the PC to put all GPU power into a game, leaving none for OBS, so turning it off leaves a bit more free for OBS)
4. Fully update your graphics card
5. Whichever game you are trying to record and stream, add an in-game FPS limit to it, 120 works for some, but 60 is a safer bet.
6. OBS keeps scenes playing in the background to allow you to swap to them, you can right-click on webcam's, videos and audiotracks, and you can turn these to "disable when not in use", which will free up some power for OBS (although does make scene transitions look a bit less smooth unless you use studio mode to do it.
7. If you use a webcam, make it a lower resolution for you gaming scene, typically people only use a small image for their webcam whilst streaming, so having it at 1080 is pointless and using power that is unnecessary - you can keep it at 1080 for a full-screen scene, but make sure "disable when not in use" is ticked so that OBS is not processing this all the time.
8. If still struggling after all of these, or maybe even try it before any of these to avoid the hassle, if you use a G-Sync monitor, turn it off for any affected games whilst recording/streaming. (Go to Nvidia control pannel, search or navigate to G-Sync, turn off whilst recording/streaming)
 

Crispapple

New Member
Finally, the last thing I tried was to turn off the Windows Game Mode, and it finally worked! Thank you!
(I tried testing out a few things before turning off Windows Game Mode, Ill link them below)

As you can see, Windows Game mode is the culprit. TURN IT OFF
 

Attachments

  • default settings.jpg
    default settings.jpg
    357.8 KB · Views: 1,857
  • normal.jpg
    normal.jpg
    319 KB · Views: 1,834
  • Vsync on.jpg
    Vsync on.jpg
    358.1 KB · Views: 1,743
  • Windows Gamemode off.jpg
    Windows Gamemode off.jpg
    366.9 KB · Views: 1,761

Brian laspe

New Member
Hey yall for everyone who is still having issues there is one more fix for people like myself who didnt have the option to turn game mode on or off...in the game go to I believe it was gameplay, ea sports has a "data sharing" option which ate up my fps rate in slobs.. turning that off fixed my issue and also if you have nvidia graphics card go to the nvidia control panel (not geforce experience) and than go to add program, select apex legends, and make sure the settings are set to your graphics card not global settings.

Hope this helped yall for the people who dont have a game mode option to be turned on or off and happy gaming!
 
Top