Always getting an encoding error when recording even when constantly turning the settings down?

Emternal

New Member
Hello!

Last month I got a new PC and I installed OBS to record some gameplays, I use it to record my switch games and sometimes PC games except I cannot seem to stop getting "Encoding Overload" and I've tried turning down recording settings, changing to x264 and even lower the output. I'm wanting to record in 1080p60fps except atm I have it set to 720p30fps and yet I still get that error, I'm not sure what could be causing it? I've posted about an error code I got in the logs a while ago but yet never really got that resolved either.

My OBS version is OBS 26.1.1 64bit and my nvidia driver is 461.40
PC specs:

- Intel® Core™ i7-10700 Processor
- 16 GB RAM
- NVIDIA GeForce RTX 2060
- Windows 10 Home
- 64-bit operating system

Thanks!
 

Attachments

  • 2021-02-18 20-01-24.txt
    19.7 KB · Views: 16

Emternal

New Member
20:01:24.122: Norton Security Ultra: enabled (AV)
20:01:24.123: Norton Security Ultra: enabled (FW)
deinstall it defender make the same job
look at the tests

set it on
Game Mode: Off


20:01:24.710: base resolution: 1280x720 -> ste to 1080P
20:01:24.710: output resolution: 1280x720
20:01:24.710: downscale filter: Bicubic
20:01:24.710: fps: 30/1 -> 60
20:01:24.710: format: NV12
20:01:24.710: YUV mode: 601/Partial

Slide4.PNG



look here

Hello, thanks for the response, it works much better except I'm see a few frame drops still but they aren't as major compared to before, here's my new log and sorry for not responding sooner. I have changed everything to what you've said, I did decide to remove Norton, turn on game mode and change my recording settings.
 

Attachments

  • 2021-02-19 08-52-41.txt
    13.4 KB · Views: 10

FerretBomb

Active Member
You're using NVENC. That should never happen unless you're using the Max Quality preset, or have Lookahead or Psychovisual Tuning enabled.
08:55:38.141: b-frames: 4
08:55:38.141: lookahead: true
08:55:38.141: psycho_aq: true
Yep. Turn those two off. You're already using Quality (not Max Quality) so that's just fine.
Also, why do you have b-frames set to 4? Unless you're playing an EXTREMELY low-motion game (like Hearthstone) that will be actively harmful to image quality.
 

Emternal

New Member
You're using NVENC. That should never happen unless you're using the Max Quality preset, or have Lookahead or Psychovisual Tuning enabled.

Yep. Turn those two off. You're already using Quality (not Max Quality) so that's just fine.
Also, why do you have b-frames set to 4? Unless you're playing an EXTREMELY low-motion game (like Hearthstone) that will be actively harmful to image quality.

Thanks for responding again, I did another test recording with those settings and thought I'd change b-frames to 2 instead but I noticed one CPU overload whilst I was doing another test recording, I'm really unsure what's making it happen, do you happen to have anymore advice?
 

Attachments

  • 2021-02-19 10-52-03.txt
    12.1 KB · Views: 11
Top