Youtube Livestream disconnecting for absolutely no reasons (even with Restream!)

Facchini

New Member
Hello people, I hope everyone is having a great week!

I'm partnered with another platform that allows me to stream at high bitrates (50000kbps cap) and that's exactly what I use to stream daily and absolutely never had problems.

They will ask me to renew my contract next month but I don't want to do so for personal reasons, with that in mind I decided to migrate to another platform since the termination of my contract will shut down my account.

I have a Youtube channel with 9400 subs that I don't use, I decided to live stream here and I simply can't.

I've tried all kinds of bitrates, from 5000 to 51000 and all resolutions from 720p to 4k, forced Youtube to use VP9 instead of AVC upscaling a 1080p feet to 1440p, did everything possible but I get disconnected in weird ways.
Sometimes I get disconnected within 5 seconds, sometimes exactly 5 or 10 minutes. I mainly use the 'pure' OBS but tried slobs too and even ShadowPlay to compare results. Nothing changed at all.

Changed the test stream to Private, Unlisted, Public, Scheduled Event. Nothing fixed.

I use a business 1gbps fiber plan and tested a video upload directly to Youtube to see if it would stop sending data for some time. 135MB/s from start to finish.

After this test, I decided to create an account on Restream to rule out some bizarre ISP routes.
The stream at the Restream preview is flawless, but looking at the dashboard I can see the service 'reconnecting' to Youtube constantly. Watching the stream on youtube it never gets offline, but it buffers and resumes after the reconnecting and the recording just jumps a bit forward.
Created another channel from scratch and the same issues happened, using the backup server too.

Does anyone have a little light on how to fix this? This is driving me absolutely crazy.

I tried all possible combinations of keyframes and b-frames too.

The servers on my main account are ‘a.rmtp’ and the throwaway channel servers are ‘x.rmtp’.

Here is a recent (literally minutes old) log with only a scene, one background video, and 30000kbps.
I tried with 3000, 6000, 15000, 51000 before and got disconnected too, deleted the logs by mistake so I did again with 30000 since the servers accept anything up to 51000.

I even swapped GPUs to different nVenc revisions. Tried with 1060, 1660, 2060 and 2070.

x264 results are the same, I'm sure it's not a hardware issue.

I can't upload logs directly from OBS, it gives me an empty popup error. I Attached it and also sent it to Pastebin.


Thanks in advance!
 

Attachments

  • 2021-05-18 11-52-13.txt
    20 KB · Views: 8
Last edited:

Facchini

New Member
I can't edit my post because it's awaiting approval, but I did two things:

Reinstalled OBS again, but before installing I went to the previously installed directory and the plugins folder was full of .dll's even after uninstalling, I think they're leftover files from StreamFX. Wiped everything and tried to stream one more time. DC'd again.

Changed from RTMP to HLS, cranked all to max settings. 3840x2160 60fps 50000kbps. 45 minutes have passed and I wasn't disconnected yet.

Looking at the logs it's now feeding data to https://a.upload.youtube.com/http_upload_hls?cid={stream_key}&copy=0&file=out.m3u8

I will try different settings to check, but I think using HLS fixed it for me!
 
Top