Webcam Keeps Freezing & OBS Crashes

funwithfondue

New Member
I'm having this problem when I'm streaming on OBS my camera will either go black, in which case I just deactivate and activate it again and that fixes the issue, or more annoyingly my webcam will freeze and then the rest of the stream will be fine but if I try to change scene, end stream, go to deactivate/reactivate webcam etc. OBS will crash.

You can find my log attached to this post. I'm currently on OBS 27.1.3. Here are my PC specs:
- PC: Legion Y740-15IRHg laptop
- Processor: Intel i7-9750H
- GPU: NVIDIA GeForce RTX 2070
- OS: Win 10 version 21H1

All the USB ports on my laptop are in use and one of them is for the USB hub of my 2nd monitor and I have another USB hub connected to the USB-C port of the laptop. The problem started when I switched to a two monitor set up with my laptop. At first I had my webcam connected to the monitor's USB hub which I realized was not a good thing to do so I swapped it to a direct USB port on the laptop, but the problem still persists (though not as frequently).

Any idea what could be causing the freezing and crashing? Thank you for your help and time!
 

Attachments

  • 2022-02-16 18-18-09.txt
    88.4 KB · Views: 60

funwithfondue

New Member
Thanks for the reply! Here's the screenshot from that program.
 

Attachments

  • Screenshot 2022-02-17 002039.png
    Screenshot 2022-02-17 002039.png
    109.4 KB · Views: 248

funwithfondue

New Member
Thanks for the answer!

My HD60S is currently connected directly to one of my laptops USB ports. Do I understand you correctly that this is not enough and instead it should be connected to the USB hub all by itself?
 

cyclemat

Active Member
no on every chip USB SERIAL BUS

ITS AN BUS on every CHIP in your Notebook you have Hub devices every hub devices can handle a Bandwitch


Hi-SpeedUSB 2.040 MB/s

SuperSpeed USB 5Gbps[32]
(SuperSpeed)
USB 3.2 Gen 1[32]
(früher nur USB 3.0, dann umbenannt in USB 3.1 Gen 1)[33]
400 MB/s

SuperSpeed USB 10Gbps[32]
(SuperSpeed +)
USB 3.2 Gen 2[32] (früher nur USB 3.1, dann umbenannt in USB 3.1 Gen 2)[33]900 MB/s

SuperSpeed USB 20Gbps[32]USB 3.2 Gen 2x2[32]1.800 MB/s

So when you have an USB 3.2 5Gbps one Device can use 400 MB/s when you have 2 max 200 MB/s

now when the HD60s USES the full bandwitch the other devices didnt have bandwitch
1645133302883.png



ihave the same problem i connect all my cams to my stream PC but the bandwitch to not high enough !
so i use a Third PC as Camserver over NDI and buy a 10gibt switch and network cards
 

funwithfondue

New Member
Thanks a lot for the help!

I don't know which port this "[Port 18] Generic SuperSpeed USB 3.1 Hub" is because all the ports on my laptop are in use (except a mini display port) and nothing appears on that port.

I switched things around like this:

1645169906301.png


Going to try it on stream today. Hopefully it's enough so that I don't have USB overload.
 

funwithfondue

New Member
I don't have a docking station but with the new USB setup I didn't have any crashes or freezes on my stream! Thanks a lot for your help!
 
Top