Question / Help VST reverb Plugins not working

Narcogen

Active Member
Are you sure you added them? There's no mention of filters being added to sources in the log.

10:48:14.919: Loaded scenes:
10:48:14.919: - scene 'Scene':
10:48:14.919: - source: 'Video Capture Device' (av_capture_input)
10:48:14.919: ------------------------------------------------
10:48:44.549: coreaudio: device 'Steinberg UR22mkII ' initialized
10:48:44.993: coreaudio: device 'Steinberg UR22mkII ' initialized
10:48:44.994: Settings changed (audio)
 

KitKat

New Member
Thank you for your reply!
I thought I did because they are appearing and can be selected in the filters. They appeared in OBS after I downloaded them on my computer. Am I perhaps missing another step??
 

Narcogen

Active Member
You need to select the source you want to add a filter to, select "filters", choose "VST plugin" from the list of available filters, choose the VST plugin you want from the list of plugins, and then interact with the plugin's UI to alter its settings.

If this is done the logfile should show that you've added a filter.

If you have done all of this, the effect should be heard on the stream itself and also through the monitoring device (in Settings > Advanced) if your microphone is selected to "monitor and output" in Edit > Advanced Audio Properties.
 

KitKat

New Member
Thank you again:) I think this might be the problem. I am not adding the filter properly. I want to add it to my mic that is working through my audio interface Steinberg UR22 11. Can you kindly give me directions on how to do this please?
 

Narcogen

Active Member
If you've added your interface either in Audio > Settings or as a source in your source pane, it should appear in the Mixer pane, with moving VU meters to indicate volume.

Underneath the meter, from left to right, is a volume slider, a mute button, and a gear icon.

Click the gear icon and from the drop-down menu that opens, choose Filters.

A new window will open named "Filters for <device name>". The left pane will be a list of currently applied filters (empty if you haven't added any yet). At the bottom are buttons to add and subtract a filter, and arrows to move selected filters up and down in the order. (Filters are applied to the source according to their order in the list, top to bottom).

Click the "+" icon, and from the drop-down menu that opens, choose the item "VST 2.x Plug-in. You will be prompted to give this filter a friendly name so you can remember what it is doing, and then a window will open with a drop-down menu that lists all the installed VST 2.x plugins OBS could find on your system, a button that says "Open Plug-in Interface" so you can configure the plugin, and a checkbox to always keep the plugin UI open when active.

If you don't see the plugin you want on the list, make sure it is installed where OBS looks for it:

https://obsproject.com/wiki/Filters-Guide#vst-plugin

When you are done, close the Filters window. Filters in the filter pane also have a show/hide icon on the left like sources (eyeball icon) so that you can toggle their effects.
 

Attachments

  • Screen Shot 2019-02-13 at 8.12.28 AM.png
    Screen Shot 2019-02-13 at 8.12.28 AM.png
    7.2 KB · Views: 578
  • Screen Shot 2019-02-13 at 8.17.45 AM.png
    Screen Shot 2019-02-13 at 8.17.45 AM.png
    22.6 KB · Views: 660
  • Screen Shot 2019-02-13 at 8.17.58 AM.png
    Screen Shot 2019-02-13 at 8.17.58 AM.png
    93.4 KB · Views: 655

KitKat

New Member
Thank you so kindly for your time. I am doing all of these steps and have had no success. Now completely randomly (it seems) I am not getting a mic signal and can't figure out why...
 

RGOZ

New Member
Thank you so kindly for your time. I am doing all of these steps and have had no success. Now completely randomly (it seems) I am not getting a mic signal and can't figure out why...
im having this problem, did you work it out?
 
Me too - the user interface is up and seems to be working but no effects can be heard through my headphones or on a test video recording.
 

JHunterAckerman

New Member
If you've added your interface either in Audio > Settings or as a source in your source pane, it should appear in the Mixer pane, with moving VU meters to indicate volume.

Underneath the meter, from left to right, is a volume slider, a mute button, and a gear icon.

Click the gear icon and from the drop-down menu that opens, choose Filters.

A new window will open named "Filters for <device name>". The left pane will be a list of currently applied filters (empty if you haven't added any yet). At the bottom are buttons to add and subtract a filter, and arrows to move selected filters up and down in the order. (Filters are applied to the source according to their order in the list, top to bottom).

Click the "+" icon, and from the drop-down menu that opens, choose the item "VST 2.x Plug-in. You will be prompted to give this filter a friendly name so you can remember what it is doing, and then a window will open with a drop-down menu that lists all the installed VST 2.x plugins OBS could find on your system, a button that says "Open Plug-in Interface" so you can configure the plugin, and a checkbox to always keep the plugin UI open when active.

If you don't see the plugin you want on the list, make sure it is installed where OBS looks for it:

https://obsproject.com/wiki/Filters-Guide#vst-plugin

When you are done, close the Filters window. Filters in the filter pane also have a show/hide icon on the left like sources (eyeball icon) so that you can toggle their effects.


I'm having the problem that clicking "Open plug-in interface" does not open anything. I just need a little reverb.
Help!
 

billamusic

New Member
I am facing the same problem. If I add the inbuilt filters like compressor, gain, noise suppression it works. The minute I add VST plugins, the audio signal is lost. No sound is captured.
 

DavidJB

New Member
I'm having similar issues. Doing all that is described above but VST pugins, no joy.
Rode mic through Focusrite interface.
 

knuckles_8

New Member
key guys, I had the same issue but what worked for me is that instead of adding the filters to my MIC tab on the audio filters, I added it to AUDIO INPUT CAPTURE. Hope this helps!
 

stuffedsoul

New Member
I'm having the same problem with the reverb. It worked yesterday when I live streamed on Facebook. But I'm so new I don't know if it was because I had Ableton running or TAL 4 running, or both. I've tried everything and I'm about to give up. I've uninstalled, rebooted and re-installed. I've read just about everything I can read about it. Watched videos about it. It seems so easy to just plug in, choose filters, and reverb and open the interface and it should work, but I get nothing.
 

delaneygusmusic

New Member
Hey guys, I've had the same problem but I think I figured out why---if you go to Settings>Audio in the General section I'm on "Mono" sound--whereas the TAL 4 VST I installed says it only currently operates on Stereo. My configuration would get pretty jacked up if I made the switch to Stereo, so I'm going to look for a possible alternate solution. Hope this helps.
 

stuffedsoul

New Member
Would love to hear if you figure out a solution to the mono stereo ... as my focusrite interface operates on mono.

Hey guys, I've had the same problem but I think I figured out why---if you go to Settings>Audio in the General section I'm on "Mono" sound--whereas the TAL 4 VST I installed says it only currently operates on Stereo. My configuration would get pretty jacked up if I made the switch to Stereo, so I'm going to look for a possible alternate solution. Hope this helps.
 
Top