Virtual Camera Problems - macOS 14.1 & OBS 29.1.3

mswTim

New Member
I just updated OBS and the Virtual Camera is no longer working.

In Teams (1.6.00.27656) I see and option titles "Virtual Camera" but when I select it, it only shows a black screen.
In Zoom (5.16.2) there is not option for a virtual camera.

Before the OBS update, when I has the Virtual Camera off I would see the OBS logo with the crossed out camera icon. Now, that's not even there.

I've uninstalled and reinstalled OBS.
I've deleted the plugins from the Library folder.
I've tried different scenes.
I've changed output resolutions.
I've changed canvas resolutions.
I've tried all Virtual Camera output types and selections.
I've checked all the Mac System Settings Privacy and Security settings.

These other apps just are not seeing OBS

Any ideas what to do?
 

Attachments

  • Screenshot 2023-10-23 at 12.30.48 PM.png
    Screenshot 2023-10-23 at 12.30.48 PM.png
    93.6 KB · Views: 553

mswTim

New Member
I have a second Mac that I used for testing this morning. OBS Virtual Camera was working on outdated versions of Teams & OBS Studio.

I updated OBS Studio to the current (29.1.3) and OBS Virtual Camera still worked in Teams.

I then updated Teams to the "new" Teams 23272.2708.2452.9689and OBS Virtual Camera is still working.

It appears to be an issue with Mac #1 only. I have the same problem with both users on Mac #1.

On Mac #1 this morning I uninstalled Teams and OBS. I then deleted all OBS user library and system library files. I reinstalled "new" Teams, and OBS 29.1.3 just as I have on Mac #2, but "OBS Virtual Camera" still does not show up as an option in ANY app on Mac #1.

I tried running OBS from Terminal and I still get the same result.

ps both Macs are on the most current Mac OS, #1 is a M1 Mac mini, #2 is a M1 Max MacBook Pro.
 

knigma

New Member
I have the same symptoms (virtual camera not showing in Zoom after updating to MacOS 14.1). I tried manually removing the virtual camera and re-installing OBS (that triggered a fresh virtual camera install), and that hasn't solved the issue. I installed obs-studio-29.1.3-macos-arm64 and I'm using an M1. Everything seems nominal within OBS - it's accessing the physical camera and providing a preview as normal.
 

matzeihnsein

New Member

thanks @BeerHunter

Restore legacy video device support​

When you restore these legacy settings, the camera privacy indicator won't display in the menu bar while a camera with older software is in use.
  1. Restart your Mac into Recovery Mode:
  2. Click the Options button, then click Continue.
  3. From the Utilities menu, choose Terminal.
  4. Enter this command:
    system-override legacy-camera-plugins-without-sw-camera-indication=on
  5. Press Return. Depending on your system configuration, you might be prompted to complete additional steps.
  6. Quit Terminal.
  7. From the Apple menu, choose Restart.
Learn more about executing commands in Terminal
To change back to the default settings, follow the steps again and enter this command:
system-override legacy-camera-plugins-without-sw-camera-indication=off
 

RustyPeterson7

New Member
I have a Macbook Pro M1 Max that does not have the OBS Virtual camera show up in Zoom like everyone else.

The bizarre part is that I have an M2 Ultra on a 2023 Mac Studio at my office that is working just fine with the OBS virtual camera showing up in Zoom.

Go figure?
 

aumogan

New Member
I just updated OBS and the Virtual Camera is no longer working.

In Teams (1.6.00.27656) I see and option titles "Virtual Camera" but when I select it, it only shows a black screen.
In Zoom (5.16.2) there is not option for a virtual camera.

Before the OBS update, when I has the Virtual Camera off I would see the OBS logo with the crossed out camera icon. Now, that's not even there.

I've uninstalled and reinstalled OBS.
I've deleted the plugins from the Library folder.
I've tried different scenes.
I've changed output resolutions.
I've changed canvas resolutions.
I've tried all Virtual Camera output types and selections.
I've checked all the Mac System Settings Privacy and Security settings.

These other apps just are not seeing OBS

Any ideas what to do?
same problem. help pls
 
Top