Question / Help Video is recorded in poor quality

NiceWall07

New Member
I record video in a large bitrate and a resolution of 1920x1080, but after recording the video looks very bad. Tried to update drivers, put the old gtx1060 video card, updated Windows, does not help ! Here is log file: https://obsproject.com/logs/Vrm3dQE8Is-4riaI
 

Attachments

  • Screenshot_4.png
    Screenshot_4.png
    73.2 KB · Views: 31

Narcogen

Active Member
Your log needs to contain a complete (started and stopped) streaming or recording session to see all the performance data.

20:05:34.952: - scene 'Сцена':
20:05:34.952: - source: 'Захват экрана' (monitor_capture)
20:05:34.952: - source: 'Захват игры' (game_capture)


You shouldn't mix game and display captures in the same scene, it may negatively impact performance.

20:05:34.293: YUV mode: 709/Full

This should be 709 or 601 Partial; Full color will look washed out on most displays.
 

NiceWall07

New Member
Your log needs to contain a complete (started and stopped) streaming or recording session to see all the performance data.

20:05:34.952: - scene 'Сцена':
20:05:34.952: - source: 'Захват экрана' (monitor_capture)
20:05:34.952: - source: 'Захват игры' (game_capture)


You shouldn't mix game and display captures in the same scene, it may negatively impact performance.

20:05:34.293: YUV mode: 709/Full

This should be 709 or 601 Partial; Full color will look washed out on most displays.
 

Attachments

  • 2019-06-04 23-30-04.txt
    10.3 KB · Views: 21

Narcogen

Active Member
This log is also just a startup log. There is no recording or streaming session.

You need to verify in the log that there is a section that notes recording or streaming is starting, and then a line where it is stopped, and after that, OBS write statistics on rendering and encoding performance.

That said, I would suggest changing your color space to 709/Partial. Your video probably appears washed out because of this.
 

NiceWall07

New Member
This log is also just a startup log. There is no recording or streaming session.

You need to verify in the log that there is a section that notes recording or streaming is starting, and then a line where it is stopped, and after that, OBS write statistics on rendering and encoding performance.

That said, I would suggest changing your color space to 709/Partial. Your video probably appears washed out because of this.
https://obsproject.com/logs/T_URTrnuZ1jSdtX1
 

Narcogen

Active Member
19:15:23.788: ==== Recording Start ===============================================
19:15:23.788: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/Алан/Videos/2019-06-05 19-15-23.mp4'...
19:15:30.690: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Алан/Videos/2019-06-05 19-15-23.mp4' stopped
19:15:30.690: Output 'adv_file_output': stopping
19:15:30.690: Output 'adv_file_output': Total frames output: 399
19:15:30.690: Output 'adv_file_output': Total drawn frames: 414


Well, no rendering or encoding lag in that seven second clip.

The only setting I see amiss is that you should be using the 709/Partial color space.

https://obsproject.com/forum/resour...t-color-range-settings-guide-test-charts.442/
 

NiceWall07

New Member
19:15:23.788: ==== Recording Start ===============================================
19:15:23.788: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Users/Алан/Videos/2019-06-05 19-15-23.mp4'...
19:15:30.690: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Алан/Videos/2019-06-05 19-15-23.mp4' stopped
19:15:30.690: Output 'adv_file_output': stopping
19:15:30.690: Output 'adv_file_output': Total frames output: 399
19:15:30.690: Output 'adv_file_output': Total drawn frames: 414


Well, no rendering or encoding lag in that seven second clip.

The only setting I see amiss is that you should be using the 709/Partial color space.

https://obsproject.com/forum/resour...t-color-range-settings-guide-test-charts.442/
https://obsproject.com/logs/vpcqN0-Lb8r1QP1w
 

Narcogen

Active Member
21:37:20.067: [NVENC encoder: 'recording_h264'] settings:
21:37:20.067: rate_control: CBR
21:37:20.067: bitrate: 50000


You're better off using CQP rate control with NVENC when recording.

CBR is primarily intended for streaming; when recording this will make your files larger without making them better.

21:32:23.250: YUV mode: 709/Full

You're still on the wrong color space setting.

https://obsproject.com/forum/resour...t-color-range-settings-guide-test-charts.442/
 

NiceWall07

New Member
21:37:20.067: [NVENC encoder: 'recording_h264'] settings:
21:37:20.067: rate_control: CBR
21:37:20.067: bitrate: 50000


You're better off using CQP rate control with NVENC when recording.

CBR is primarily intended for streaming; when recording this will make your files larger without making them better.

21:32:23.250: YUV mode: 709/Full

You're still on the wrong color space setting.

https://obsproject.com/forum/resour...t-color-range-settings-guide-test-charts.442/
There is no clarity.
 

Attachments

  • Screenshot_1.png
    Screenshot_1.png
    110.9 KB · Views: 28

Narcogen

Active Member
The image on the right is scaled because the player is displaying its menu above the frame.

If you're unsure you have the right settings, you can set Simple mode in Settings > Output, and under Recording choose "Indistinguishable Quality, large file size"
 
Top