Teleport

Teleport 0.5.0

Tuna

Member
Tuna updated Teleport with a new update entry:

0.5.0

  • Audio and video are pushed interleaved according to their timestamps into OBS. This should compensate for the different run times of audio and video and allows OBS a more accurate audio and video sync.
  • When not visible, video will still be pushed into OBS. Decoding is just skipped and dummy images are being pushed.
  • Added a new filter for video only streams.
  • Internal queue size before dropping data is now 1 second instead of previously 20 frames.
  • Teleport streams list is...

Read the rest of this update entry...
 

DrGregVR

New Member
so im having an issue where the pc im trying to stream from is not able to find my gaming pc that i am trying to transmit. It only finds itself in the list even after i refresh it. am i missing something?
Have you figured this out? I'm having the same issue which is weird because it worked,.. at least I could connect my old laptop to the gaming PC, but it was so old it couldn't handle it. My newer gaming PC I'm trying to use to stream for whatever reason can't find the sending PC even after refresh, and the Sending PC can't see the streaming PC either.
 

DrGregVR

New Member
Impossible to tell without knowing your network. The machines must be in the same Multicast segment.
What does that mean exactly. I'm having the same issue. I have no idea what a multicast segment is. but I do know my old laptop was able to find the gaming PC,.. just didn't have a GPU so it didn't go well. but this newer gaming PC cannot find the sending PC and the sending PC can't find the streaming PC
 

YorVeX

Member
What does that mean exactly. I'm having the same issue. I have no idea what a multicast segment is. but I do know my old laptop was able to find the gaming PC,.. just didn't have a GPU so it didn't go well. but this newer gaming PC cannot find the sending PC and the sending PC can't find the streaming PC
If it's connected exactly the same way the old one was then the most likely reason would be that the new laptop has some software firewall that is blocking it. Maybe the new laptop came with one preinstalled that you're not even aware of? Sometimes it's also part of a bigger anti-virus/security solution where it isn't obvious that a firewall is part of it.
Might also be the Windows firewall (in case you're on Windows), I don't know whether that would block Teleport since I always have it disabled myself.
 
How is determined, which NIC is used for Teleport. E.g. can it be bound to use a specific Ethernet adapter if more than one exists or is ensured that a Wifi adapter is always omitted?
 

Tuna

Member
How is determined, which NIC is used for Teleport. E.g. can it be bound to use a specific Ethernet adapter if more than one exists or is ensured that a Wifi adapter is always omitted?
There should be a stream offer for each network interface. You then select the one with the ip address you are interested in.
 

LiquidBlitz

New Member
Loving the quality option, the ceiling takes the quality way higher than NDI. But I have one issue. Apologies if you don't like straight comparisons between them but I've noticed that regardless of Quality level chosen, there is noticeable stutter on the receiving end of Teleport (or rather missing frames or wildly inconsistent frametimes) compared to standard NDI - and I wondered if you might know of any technical reason why this might be the case? In my scenario all other factors are working flawlessly with no bottlenecks etc. But a simple back and forth repeatedly with 2 identical streams, one NDI, one Teleport - shows that NDI is perfectly smooth, with lower quality visuals, and Teleport is as high quality as your network bandwidth allows, but it's like all the frametimes are off, or dropped frames between the computers (tested with several values between 1-96, quality seemingly isn't the issue). Thanks for the work you've put into this.
 

tyo_streams

New Member
I've experienced the problem LiquidBlitz mentioned as well today. I stream at 936p120fps for the slow motion replays, and the result is significantly worse than expected. My OBS stats on each machine show insignificant numbers of dropped frames for any reason (0.1% or less for rendering/encoding/network), but my vod is a slideshow: https://www.twitch.tv/videos/1563210442

The connection between the computers is wired and travels through my comcast router. I think my next troubleshooting step would be to use wireshark to see if the bandwidth is spiky, which I'll do tomorrow if I can figure out how.
 

LiquidBlitz

New Member
I will clarify that my unsmooth transition between computers has nothing to do with recording/streaming. I can see it in the receiver's preview that it is stuttery, 0 "dropped frames" officially, on both ends. Looks equally stuttery in local recordings, so it isn't just the preview being odd. Less than 20% GPU/CPU on both ends. Best way I could describe it is the receiving stream looks closer to 20/30 fps than the 60 I'm running at, and the quality option has zero effect on this. I've gone so far as to try connecting both PC's directly with ethernet just to reduce points of failure, and the unsmoothness persists - which I find odd.
 
Last edited:

Warzy

New Member
Teleport has M1 support. However OBS M1 support itself is not even in beta. We have seen it break before. Feel free to investigate..
Hi, I'm coming back to you after trying to install Teleport with OBS Release Candidate 2 on a Mac M1, once installed I have no options available in OBS. Is an update of Teleport required?
 

miggy3399

New Member
Hello. May I ask how do I install Teleport on my mac?


It's an Intel mac with High Sierra and when I put the so file in obs studio, nothing is popping up in the tools tab. I'm a little r*tarded so I really need help with this hahahaha

Thank you
 

Sixara™

New Member
Dear Dev(s) - Thank you for this plugin! I was looking for a new way to broadcast between PCs as OBS 28 no longer works with NDI. Teleport works on my Windows 11 (Gaming PC) to Windows 10 (Source/broadcast PC) like a charm. In fact, I might just keep Teleport from now on.
 

Pence_PC

New Member
I recently transferred all my PCs over to Teleport from NDI. My main issue is when grabbing 2 Teleport sources for gameplay split on the stream PC, it transfers no audio. I can switch between one source at a time with perfect audio on the stream PC, but as soon as 2 sources are in the same scene, no audio. Absolutely nothing changes as far as audio goes. It shows audio in the mixer, but nothing is heard. Any ideas/solutions?
 

Chaniro

New Member
martha.jpg
Hi guys, i got this screen issue, do you know how can i fix it ?
thank you
 

Chaniro

New Member
I was able to resolve a green screen like this in OBS by going to Settings -> Advanced -> Video -> Color Range and changing this setting to Limited. For streaming, I have:

Color Format = NV12
Color Space = Rec. 709
Color Range = Limited
 
Top