Streaming with AverMedia EZMaker 7 on Streamlabs OBS issues?


New Member
Hi! I recently got the Avermedia EZMaker 7 so I can play Wii (No, not Wii U, and the reason why is cuz the games I want to play were not transported to Wii U) games. However I have run across some issues. First off, I was unable to get Streamlabs to recognize Avermedia until I downloaded the driver, I am adding this cuz my friend who recommended this swore up and down I didn't need it. Until I did it was only giving me the OBS Virtual Camera option. Well even though I can capture Avermedia, no video or audio becomes displayed at all! I've tried unplugging and plugging the USB back in. I've tried in 2.0 and 3.0 usb slots. I've tried restarting and unplugging together. Nothing at all! I've tried streamlabs *and* obs, both display neither. My friend directed me to use VLC to see if it's OBS or my capture card. VLC was able to display audio perfectly but an extremely blurred and miscolored video, it at least proved my capture card wasn't faulty. Wasn't able to fix the graphical errors on VLC otherwise. My friend is stumped and I've looked up troubleshooting problems to find unanswered replies or nothing at all. If there's anyone else that can help I'd be so grateful, even if it's to suggest a better retro capture card (return is still possible with full refund!).