Question / Help Sound Issues - Pitch Randomly Gets Lower/Slight Clipping


New Member

After streaming with Xsplit for months, I recently decided to switch over to OBS. We've done a couple of streams with no issues, but my last two streams have had an odd problem: some sort of error is happening to the sound where the pitch gets lowered/starts clipping. Suddenly, our voices are a lot deeper, and it seems like anything coming in at a higher register gets clipped lower.

The first time it happened it seemed to be for the entirety of the stream. I read that it could be due to the Audio Sample Rate set to 44.1khz, and switching it to 48khz should fix it. I switched it to 48khz (even though I've never messed with this setting, and I've streamed with OBS before without this issue), restarted OBS, and it seemed to work. But then I switched it back to 44.1khz, restarted OBS again, tried a test recording, and the audio was perfect with no issues. I kept changing settings here and there, but nothing seemed to make the issue happen again. After reading more on 48khz, it doesn't seem like it's the standard, so I want to say that simply restarting OBS was what fixed the issue, not changing the Sample Rate.

Second time it happened, I did a few test recordings to make sure there were no issues. Everything was perfect. We start our stream with great audio, but at around 53 minutes into the stream, the mic audio cuts out for two seconds, and when it comes back, there it is again, deep voice, highs getting cut out, and the weird clipping starts. I have no idea what's going on. When the mic audio cuts out, the game audio does not cut out, but I can't tell if it's also being affected by the pitch change since the game audio is low compared to our voices. I tried pulling the OBS log but there isn't a timestamp anywhere near where the issue happens. There's a timestamp when we start streaming+recording, and then the next one is when we finish the stream+recording. I will include the link to the log nonetheless. I also made a clip of the recording showing when the audio begins to have issues, which I will include below.

Link to video showing audio error (starts at 0:20, left audio before for comparison):

Other random information I can provide:
-Both the stream and the recording have the same issue.
-Streaming platform: twitch.
-Computer Specs+Equipment:
-CPU: AMD Ryzen 5 2600 Six Core
-Ram: 16GB (2x8GB) DDR4 DRAM 3000MHz
-GPU: NVIDIA GeForce GTX 1060 6GB
-Game Capture: ElGato HD60S
-Microphone: Blue Yeti Microphone (I'm using a USB Extender cable to plug the mic into my computer)
-OBS Settings seem to be provided in the log file, so I'll skip those.
-Thought maybe the mic was randomly disconnected/reconnected (USB issue, not manually unplugged) and when it reloaded on OBS, it wasn't encoding right. I did a mock recording and force-disconnected the mic and connected it back but the voice picked back up with no issues.
-Would having 6 audio tracks be an issue? I'm not sure why I have so many, but OBS came like that by default so I didn't touch those settings at all.
-Could USB overloading be the issue as well? I am using a lot of USB ports, including a hub that draws power from the computer, not an extra source.

Can anyone help me out? I really want to keep using OBS instead of Xsplit, but this audio issue is kind of annoying. Any pointers would help! I'll try to provide any missing information as well.


  • OBS Log File 2-10.txt
    28.8 KB · Views: 71


New Member
I have had the very same problem you have indicated here. I am wondering if you found any solution to it.

So, while I never got a definite answer on what was actually causing this issue, all I did was switch everything to 48kHz Audio Sample Rate and replace the USB cable connecting my microphone to the PC.

I switched this setting in OBS (File -> Settings -> Audio -> Sample Rate = 48kHz) and made sure all of my audio devices (both input and output) were at 48kHz at well. While checking for these settings, the only one that was not set to 48kHz was my Microphone input device, so that was the only one I changed.

To change that setting, open the classic Control Panel -> View by: Icons -> Sound. On the new Sound window, click on the device (in my case, I went over to the Recording tab and chose my Microphone), click Properties, click on the Advanced Tab on the new window and change the Default Format to 2 channel, 16 bit, 48000 Hz (DVD Quality).

Here is a screenshot just in case: [](

I'm not sure if this was what was causing the issue, but it has not happened since I've switched these settings. I also think the USB cord that was connecting my Microphone to my computer wasn't in the best condition, so that was replaced as well.

Hope this helps!


Switching everything to 48kHz sure helps, but there are always going to be some programs that use 44.1kHz. If you open one, then you get a high-pitched voice.

I noticed before that when I opened Discord, it would mess the audio drivers and make everything sound lower, because Discord defaults to 48kHz and I was on 44.1kHz at the time.

I wish there was a way to set absolutely every application on Windows to same sample rate.