Question / Help [ SOLVED ] Input lag on games when opening OBS

msqar

New Member
#1
I'm currently using the Streamlabs version, but this used to happen as well on normal OBS. Whenever i open OBS, i detect input lag on keyboard & mouse while playing, (Fortnite at the moment but happens with all games).

It's weird since i got a decent PC, specs are:

i7 7700K
1080 Ti OC
16GB DDR4 3000Mhz
Wired Logitech Mouse & Keyboard (so no battery problem)
Gsync 1440p monitor at 144hz using Unlimited FPS config on Fortnite.

FPS are way too good, around 180-200+ all the time. But this input lag is driving me crazy. If i close OBS, it stops.

Is this normal? I tried the Configuration Wizard, and nothing.
Tried setting up myself, nothing. Attempted so many things, read so many forums.

Can anyone help me? If OBS config data is needed, i can attach some screenshots too.
 
Last edited:

msqar

New Member
#2
any ideas? :( still happening, tested a lot of stuff that was mentioned in the forum but still... is this a normal thing? would i need to get used to this input lag if i want to stream?
 
#3
Is your Windows Desktop refresh rate also set to 144hz? Also, what happens if you minimize OBS? And do you have a second monitor at a lower refreshrate?

1531069434927.png


1531069487655.png
 

msqar

New Member
#4
OMG yes, i got 2 monitors.

1) is the DELL 1440p @ 144hz w/ Gsync
2) is BenQ 1080p @ 60hz.

I use the 144hz to play Fortnite ofc, 1st is for streaming purposes, it would make sense if it's a refresh rate issue lol :O due to input lag, frames are super okay while OBS is opened, 150-200+ fps all the time with Unlimited option, not locking it up in-game.

OMG! i just found that when i opened OBS, checked the refresh rate on my 144hz monitor, and it put it down to 60hz!!! that makes sense, but why is it doing this?
 

msqar

New Member
#5
Nice!!!!! you were right, ma' man!!! it works like a charm now, opened Nvidia settings, put it back to 144hz@1440p res and now i got everything opened and no suttering/input lag! Thanks man! Bless you!
 
Top