Recording on OBS between 30 fps and 60fps even with OBS saying its on 60fps?

TheLukas123

New Member
Hello, i'm with a really strange OBS problem, for some reason my OBS recordings are variating between 30fps and 60fps, on OBS says my recording are at 60 Fps but the preview are around 30fps, and most weird thing, is that this don't happens using nvidia shadowplay, for a reference look at this video: https://youtu.be/2yZ32ySTofQ, the shadowplay recording is at 60 fps without any issue and OBS is around 30 fps with frame drop

I Already uninstalled OBS, installed again, created another scene/profile and still having this problem, i'm starting to think that my problem is related with windows 10 multiple desktop/Voicemeeter banana or with my monitors (i use two monitor (one monitor is 1920x1080 through DVI and other is 1600x900 through VGA with HDMI adapter, both are 60fps)

Anyway, anyone have any ideia what is causing this? it's really annoying.

AND YES I'M ALREADY RUNNING AS ADMINISTRATOR

My specs:
Ryzen 5 2600, 16Gb ram 3000hz, RTX 2070, One ssd for windows/obs, one HDD for gaming and another HDD for recording (game and recording are on separeted hdd's).

Recording: NVENC (VBR at 40000~60000 and sometimes i use CQP at 16), Preset: Quality, Profile High, Look-Ahead not checked, Psycho visual checked, gpu 0, Max B-Frame 2

Video: Base (canvas) and output (scaled) both are 1920x1080, downscale filter bicubic (sharpened scaling, 16 sample), common FPS Values 60

Advanced tab:

  • General: Process Priority Normal
  • Video: Color format: NV12, Color space: 601, Color Range: Partial

A Random thing that i noticed: It doesn't seem to happen when I'm using the preset "Low-Latency Quality", anyone know why?

Here is the log from the session that i recorded these videos: https://obsproject.com/logs/8Zv-ByczHKt2Ds6h

Sorry for any error, english isn't my first language.
 

Attachments

BluePeer

Member
looks first if the log is from that the hdd is to slow in write speed
simple switch vom HDD to SSD and look if its similary
 

TheLukas123

New Member
looks first if the log is from that the hdd is to slow in write speed
simple switch vom HDD to SSD and look if its similary
What? How can be my HDD when this don't happen with shadowplay? both save the video to the same HDD, my HDD is a barracuda 2Tb 7200rpm 64Mb cache
 
Top