Random CPU spikes drop frames and de-sync audio

LukeRIpa

New Member
Hey everyone,

In recent months I've encountered an issue I hope you guys can help me solve.

As the title suggests, while I stream random CPU spikes (spike I determined by OBS's monitor - normally fluctuates between 5-7% but with these even reaches 20%) lasting 5-6 seconds will make my stream run at 4-5 FPS. Once the spike is finished is all good aside from the audio de-sync, which I quickly fix by changing the color space (which forces a refresh of the capture card). These happen between 2 and 3 times per stream - the length of the stream is generally between 2h/2.5h.

I tried to fix the problem without much priority as streaming is a hobby for me and it's quickly fixable in-stream, but now I want to find a solution to avoid these, as they take me out of the 'streaming zone'.

Right now I'm streaming to Facebook but these also occurred when I was streaming to Twitch and Restream. It also happened with all the consoles I streamed (PS5, PS4, Switch).

Here's my machine and what I use:

Model: Dell XPS 15 7590
CPU: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
RAM: 16GB
GPU: NVIDIA GeForce GTX 1650 4GB
Capture Card: Elgato HD60 S+
Monitoring device: Logitech G633 via USB

The video rec/stream is set at 1080p 30fps with NVENC encode.

I already tried the following (on top of 'playing' with settings) to no avail: change the recording storage to the internal NVME, change the monitoring device, change the encoder, steam without recording, and vice-versa. The issue still persists in these scenarios.

Attached you find my last stream's log (stream only, no recording) - I noticed it indicates the sample rate of the Elgato at 44100Hz while it should be 48000. I set everything at 48000Hz, and I just double-checked to confirm Windows sets it at 48000Hz, so I don't know why the software sees it as such - from what I gathered online and from Elgato's website, that might be causing the spikes, but I'm not sure.

Thank you so much in advance for the support!
 

Attachments

  • 2020-12-07 23-38-48.txt
    23.5 KB · Views: 13

LukeRIpa

New Member
23:38:48.777: McAfee VirusScan: enabled (AV)
deinstall it defender make the same job look here :

23:38:48.774: Running as administrator: false
Start OBS as admin

23:38:50.984: YUV mode: 709/Full
use Partial

why you have NDI installed ?

23:39:00.705: fps: 59.94 (interval: 166833)
set HD60s to 60 fps

show that webcam and Elgato not on the Same USBroot HUB Device try this program:


try to disable/enable the buffer for the HD60s

Thanks for the response!

I'll try to start OBS as admin for tonight's stream I can't find the YUV mode in OBS settings.

I installed the NDI because I tested the NDI recording (OBS recording the clean 4K Capture Utility capture), of course, the machine couldn't keep up. I tested that in the last 4 weeks or so, the issue started to present itself around May or June.

I can't change the Elgato HD60S+ to capture at 60fps. The only option I have is 59.94 or 'highest option available - I'll try that.

And, yes, the Elgato is directly connected to the PC while the Webcam (GoPro 6 attached to the cheap cam link making the rounds these days) is connected to a WD My Book Duo rear USB-A port. However, I added this to my set-up in August or so - once again, the issue is here since May/June.

I enabled/disabled buffer multiple times but even here no difference was made.

I'll update tomorrow with tonight's stream log. Maybe today if I have time to make a test recording.
 

LukeRIpa

New Member
Hey Cyclemat,

sorry for the late reply, had some stuff to work out IRL.

However, because I streamed late, I have not one but two logs.

The first my Days Gone stream from the Elgato HD60S+, the second is a live co-stream of The Game Awards (with webcam+window capture for capturing the YT's TGA stream).

Interestingly enough, the TGA stream lasted about 4 hours and the issue did not present itself, so I'd say by logic there's some issues with the capture card (much likely the encoding).

I'll attach the logs like the other time. 12/9 is the stream with the card while 12/10 is TGA.

Thanks so much for the help!
 

Attachments

  • 2020-12-09 23-41-29.txt
    19.4 KB · Views: 9
  • 2020-12-10 23-58-56.txt
    18.1 KB · Views: 10
Top