OBS won't work with specific game


New Member
I recently downloaded OBS and have been having some issues getting it working. I have been able to get it to work with most games (currently Hollow Knight and Super Meatboy), but I haven't been able to get it to work with Celeste when using game capture, it's always a black screen. I've tried all of the fixes I've found mentioned including having both run at high performance and running OBS as an administrator. I am on a laptop as well, so not sure if that could be causing another issue. Is there another fix that could work in this situation?

This is the log file

Hari Seldon

New Member
I came to this forum because of the exact same issue.
I thought it could be Steam running the games not like the others but no, all other Steam Game work perfectly with game capture.

Also I noticed that Celeste is the only game which bypass the 'night light filter of my screen'. I think the laptop identify it as a game and cut this filter to have a better experience, that could be link to why it can't be captured, idk.

Otherwise I found a way to overcome this issue even if it not the best at all.
- Instead of Game Capture, on OBS, select Window Capture.
- In Celeste, disable the fullscreen and set the size to x6
- Right Click on the source of the window capture -> Transform -> fit to screen
- Disable the task bar (right click on it and open its parameters
Like this the game is broadcast when you play it. But each time you check smth else, the game isn't displayed anymore

Edit : as I was writting this I get back to OBS to explain exactly my solution. And I finally worked well with Game Capture ...
I don't really know how but my settings were not on Highperformance, but rather on Low Power.
On OBS : Game Capture, Specific Window, [Celeste.exe]: Celeste, name on the window must fit, disable all the option, Normal speed capture. (and also transform -> fit to screen like before.)
((I was not on full screen when I figured out I wasn't on the window capture, but on the Game Capture so I tried to set fullscreen just to see, and it continue working))

I'm sorry I cannot explain more why it work this time and not before but I hope you could be able to do just like me.
See you later on the Speedrun leadeboard ^^ !