OBS Studio 29 Beta

RytoEX

Forum Admin
Forum Moderator
Developer
This happend on the OBS V 29 and OBS V 28.
If this also happens on OBS Studio 28, then this is not a new issue to the OBS Studio 29 Beta. This thread is for feedback that is specific to the OBS Studio 28 beta. If you have been experiencing an issue with previous or current stable releases of OBS, please seek assistance in the OBS Studio Support section of the forum or on our Discord server.
 

Verner

Member
Hello. I'm using the Recording tab in OBS for my second Twitch stream. In the list of video encoders, I could not find those that can use the Quick Sync H264 from the Intel Arc A380 video card. They are not there yet in OBS 29 Beta 2?
 

Attachments

  • Screenshot_1.jpg
    Screenshot_1.jpg
    138.4 KB · Views: 93

RytoEX

Forum Admin
Forum Moderator
Developer
Hello. I'm using the Recording tab in OBS for my second Twitch stream. In the list of video encoders, I could not find those that can use the Quick Sync H264 from the Intel Arc A380 video card. They are not there yet in OBS 29 Beta 2?
Custom Output (FFmpeg) lists codecs directly from FFmpeg. If they are not available in FFmpeg 5.1.2, then they are not listed. We added support for QSV AV1 directly in OBS in the standard recording modes.
 

Fenrir

Forum Admin
Hey, i got my RTX 4080 and i tried to use the NVENC AV1 Encoder.
But as soon as i hit Recording i got the prompt:

1670073096711.png


This happend on the OBS V 29 and OBS V 28.
I DDU bevor installing the new Card and tried the Game and Studio Driver Version of Geforce Expirience.
You are using an unsupported video format (BGRA) in Settings -> Video. You'll want to set that back to NV12, or P010 if you are trying to record HDR.
 

tphakala

New Member
I am running a live feed of my bird feeders and I switched to OBS 29 beta 2 recently. Last night youtube stream disconnected unexpectedly, OBS stats were showing that feed was live but no data was reported being sent, OBS was also so locked up that I had to kill it from Windows task manager.
Logs containing this event are at https://obsproject.com/logs/pAykSwpWpMxqVUkP
Hardware is 11th Gen Intel NUC
 

Fenrir

Forum Admin
We're deep back in normal support territory, as none of that should be different between 28 and 29, so please create a new thread in the appropriate support section, or use our Discord for more assistance. This doesn't sound related to Beta.
 

Texas wolverines

New Member
Hey all today I was trying to import my videos in Davinci resolve 18 and could only get the audio to show up. The video files play find in windows media player just fine but video doesn't show up in the video editor just the audio, so I did some digging. I opened the video properties on one of the videos I recorded in AV1 file type MKV I looked at the details tab and saw that there was missing video Info
and audio information note in the pic I have attach

Xbox live  2022-12-14_20-10-42.jpg

Now i change the file type to MP4 but kept the av1 encoding and looked at the same information and mp4 file had everything filled in on the video and audio info note pic number two .
Xbox live  2022-12-14_20-13-33.jpg

and also, the mp4 video showed up just fine in the video editor so with that being said is this a bug or not or am i missing something here???
 

Fenrir

Forum Admin
Please check with a media player if the file plays back. Windows can't read AV1 metadata by default, and might require an additional codec installation, but the video files play just fine in something like VLC or MPV. You'd have to ask Blackmagic if Resolve supports AV1 though. It's also very likely that it doesn't.
 

tphakala

New Member
New quicksync encoder on 29 beta 2 seems ignore "Output > Encoder Settings > Rate Control" setting, it defaults to CBR no matter you have selected in gui.

08:56:47.735: >>> new qsv encoder
08:56:47.735: [qsv encoder: 'advanced_video_stream'] settings:
08:56:47.735: rate_control: CBR
08:56:47.735: target_bitrate: 4000
08:56:47.735: fps_num: 25
08:56:47.735: fps_den: 1
08:56:47.735: width: 1920
08:56:47.735: height: 1080
08:56:47.735: [qsv encoder: 'advanced_video_stream'] debug info:
08:56:47.762: impl: D3D11
08:56:47.762: surf: D3D11
08:56:47.820: m_nSurfNum: 11
08:56:47.821: m_nTaskPool: 4
08:56:47.821: major: 1
08:56:47.821: minor: 35
08:56:47.821: ---------------------------------
 

RytoEX

Forum Admin
Forum Moderator
Developer
New quicksync encoder on 29 beta 2 seems ignore "Output > Encoder Settings > Rate Control" setting, it defaults to CBR no matter you have selected in gui.

08:56:47.735: >>> new qsv encoder
08:56:47.735: [qsv encoder: 'advanced_video_stream'] settings:
08:56:47.735: rate_control: CBR
08:56:47.735: target_bitrate: 4000
08:56:47.735: fps_num: 25
08:56:47.735: fps_den: 1
08:56:47.735: width: 1920
08:56:47.735: height: 1080
08:56:47.735: [qsv encoder: 'advanced_video_stream'] debug info:
08:56:47.762: impl: D3D11
08:56:47.762: surf: D3D11
08:56:47.820: m_nSurfNum: 11
08:56:47.821: m_nTaskPool: 4
08:56:47.821: major: 1
08:56:47.821: minor: 35
08:56:47.821: ---------------------------------
This does not happen on my machine. Please provide a full log file, and also please retest in OBS Studio 29 Beta 3.
 
Top