OBS Replay stops Randomly with "Unknown Error"

The OBS Replay Function Works fine most of the time, however every 1 or 2 hours the recording crashes and cant be restarted until OBS is completely closed and reopened.
This does not happen when sitting idly on the desktop. Apparently some kind of significant 3d accellerated workload is needed to replicate this.
I have attached the Log file of one of such crashes.

Things i have tried so far:
- running OBS in Administrator Mode
- reinstalling OBS
- removing all custom scripts
- removing all plugins
- removing all scenes except for one and reducing that scene to only include a single desktop capture
- DDU the driver and perform a clean install from the nvidia website (tried both Game Ready and Studio Driver)
- reducing in-game settings of various games, even running at only 20% load on the gpu.
- raising the RAM limit to 15gb for the replay buffer (even though usage never goes above 5gb even in very action heavy scenes)
- switching between the NVIDIA HVEC and NVIDIA h.264 encoders
- closing all video players (Websites with videos playing, Discord, VLC, etc...).
- running OBS in regular mode instead of portable mode

Encoder Settings and Hardware Configuration are in the Logfile. However i can gladly provide more Information if needed.

Does anyone have an Idea what is happening or how i can fix this?
Thanks in advance to everyone that takes their time to look at this!

Side note: The Log file seems to have some memory garbage in it. Is this something the nvenc api returned?
 

Attachments

  • 2023-08-14 05-28-02.txt
    15.1 KB · Views: 18
Update: apparently it was an early symptom of my VRAM dying. A few weeks later more issues started popping up and i got visible artifacting & frequent crashes in games.
After Replacing the faulty GPU two weeks ago, the issue has not appeared again.
I hope this can help someone else^^
 
Top