OBS not playing desktop audio from Digital Audio Workstation

jonesgotmusic

New Member
I have been able to stream with audio from my DAW[(Digital Audio Workstation) Presonus Studio One, Ableton] before and now it doesn't show any audio is coming through. I am able to hear the audio on my speakers, but OBS meters for desktop audio shows no values. All other apps, Mozilla, Windows Media Player, Windows sounds, Groove Music, all show audio values coming through OBS on desktop audio. I have tried uninstalling and reinstalling OBS, changing sample rate from 44.1kHz to 48 kHz to match my DAW and OBS, changing the properties for desktop audio to my audio interface, to default, made sure audio monitoring is off, tried using all the different tracks available all to no avail. I have a mic connected to my audio interface and I am able to hear myself and OBS shows values on the meters. It will however show values when I am not using my audio interface. I have been scouring the net to find a solution but can't figure this one out. Once again I have audio from all other apps, I can play a video from youtube with audio values showing up on desktop audio in OBS. Same with files from my computer whether they are audio or video. Please help. I've been going at this for almost a week.



LOG FILE:



OBS issue.png
OBS issue2.png
OBS issue3.png
 

nathangoheen

New Member
Hey there. I don't think I can help you, but I'm trying to stream and use audio from my DAW as well, and it sounds like at one time, you were able to do this. May I ask how? Thank you in advance, Nathan
 

jonesgotmusic

New Member
Hey there. I don't think I can help you, but I'm trying to stream and use audio from my DAW as well, and it sounds like at one time, you were able to do this. May I ask how? Thank you in advance, Nathan

I ran the auto configuration to set everything up. At the top select tools. It'll bring up a drop down menu and select auto-configuration wizard. It should already be selected "optimize for streaming, recording is secondary(I only stream and don't save my videos for editing so I left this option selected), select next. Next it'll ask for video settings. I left this alone and didn't change them since I didn't care about the difference. Select next. Next it'll ask you for stream info. Select your service you want to stream on i.e. facebook live, youtube, twitch. You will have to log into your account on whichever service you have an account with to get a stream key. They're not hard to find and should be listed whenever your setting up your live stream for your service. Copy the stream key and paste it inside the box. I left the 2 boxes checked since that was a default setting and select next. It will bring up a box letting you know it's about to run a test. Select yes. Once complete it will give you estimated setting ideal for you. Select apply settings and you should be good to go.

I figured out my problem, not sure if you'll run into it but in my DAW I had the asio driver selected for my interface, and was not getting any sound for desktop audio. Switched it to mme/direct x and solved my issue of not being able to hear audio in the stream from my DAW.

Screenshot 2020-09-27 172449.png
Screenshot 2020-09-27 172550.png
Screenshot 2020-09-27 172607.png
Screenshot 2020-09-27 172624.png
Screenshot 2020-09-27 172640.png
Screenshot 2020-09-27 172659.png
Screenshot 2020-09-27 172717.png
 
jonesgotmusic

I may be able to help you fix the audio. Watch my lasted how to setup the best stream platform. With that setup you will have ZERO problems if you follow the steps. If you need any help. Let me know.

There are a order in how to install things on any computer. fail to do that, you will encounter several problems ahead. Once you have you system working 100%, make a restore point. Also, pay attention in how to back OBS and other software.

best,

Ney
InteractiveDNA
 

DJBANDELERO

New Member
I'm having the same issue from the OP. My head hurts trying to figure this out. I'm trying to run audio from TASCAM to OBS but no sound is bridging over.
 
Top