Question / Help OBS iPhone latency

Dave Hall

New Member
We've been running a 24.x version of OBS on an iMac running 10.14.6 Mojave for the past three months, connected via USB to an iPhone 10 with 13.3.1 software, as a video source for Facebook Live streaming. To date, it has run seamlessly. Then, starting today, we noticed a HUGE video lag between the camera and the OBS view window. After 1 minute of streaming, the OBS view might be 10-15 seconds behind the iPhone screen, and eventually, as it fell even further behind, the video became unstable on Facebook, and we had repeated Facebook drops. I updated to OBS 25.0.8, and the problem persists. I tried upping the bit rate on the OBS iPhone client to no effect. I have log files from our repeated tries today. Any ideas?
 

Attachments

  • 2020-05-07 13-48-37.txt
    17.3 KB · Views: 179
  • 2020-05-07 14-18-48.txt
    14.3 KB · Views: 32
  • 2020-05-07 19-49-31.txt
    9.2 KB · Views: 20
  • 2020-05-07 19-51-18.txt
    9.8 KB · Views: 16
  • 2020-05-07 20-05-42.txt
    12.3 KB · Views: 21
  • 2020-05-07 20-53-46.txt
    4.6 KB · Views: 25

markwalley

New Member
Same, I've noticed it's got worse since the new iOS Camera app launched. It's fine initially then after a minute or so we have massive lag. Very frustrating. I've message the developer of the OBS camera app, as they've just released 3.0 imagine it's something to do with that. Hopefully quick bug fix.
 

MartinA69

New Member
Just tried a Facebook live stream with two iPhone using the updated OBS camera app. This is the first live stream since the app update and found the sound to be very glitchy. Just like the mic was being switched on and off. Had to go old school straight from the iphone.
 

jessies

New Member
Same here ... started having issues yesterday when I went live. Has to be updated OBS camera app issue. Im having video lag like above, Facebook live sorry error after a while, and now OBS connects USB connected but shows black screen on OBS. FRUSTRATED. I wonder when they will fix problem
 

wpierluissi

New Member
Same issue, I tried using my new iPhone 11 and it is worse than using my old iPad Air2. So I ended downloading a very inexpensive app named Shoot, it only let you get a clean image from your device back camera. So I use the Video Capture Device option in OBS and then select my iPad Air2 using a usb connection. The video is good but no audio, so I am using an usb audio mixer with a condenser mic to get the audio.
 

jessies

New Member
Same issue, I tried using my new iPhone 11 and it is worse than using my old iPad Air2. So I ended downloading a very inexpensive app named Shoot, it only let you get a clean image from your device back camera. So I use the Video Capture Device option in OBS and then select my iPad Air2 using a usb connection. The video is good but no audio, so I am using an usb audio mixer with a condenser mic to get the audio.
I bought the shoot app cause I only need Video but when I go to OBS and add video capture I do not see phone... am I missing something?
 

wpierluissi

New Member
Yeah! my issue is resolved! I downloaded and install the new version for Mac OBS ver.25.0.8 (64bit), the new iOS Camera Plug-in ver. 2.6.0 and updated the iOS app to ver 3.0.0-58, and it works. The new plug-in has additional settings, with my MBPro 13in Retina late 2013 8GB of ram the best setting was Latency=Low and Enable Hardware Decoder selected. I hope this helps! It is working fine for me now.
I had to keep the bit rate low 1500 kbps, Encoder = software (x264), audio bitrate = 160, sample rate 44.1 kHz, canvas and output 1280x720 and 29.97 fps. I know it is not the best quality but at least it works for me and keeps the video and audio synched.
I bought the shoot app cause I only need Video but when I go to OBS and add video capture I do not see phone... am I missing something?

wi
 

wpierluissi

New Member
Yeah! my issue is resolved! I downloaded and install the new version for Mac OBS ver.25.0.8 (64bit), the new iOS Camera Plug-in ver. 2.6.0 and updated the iOS app to ver 3.0.0-58, and it works. The new plug-in has additional settings, with my MBPro 13in Retina late 2013 8GB of ram the best setting was Latency=Low and Enable Hardware Decoder selected. I hope this helps! It is working fine for me now.
I had to keep the bit rate low 1500 kbps, Encoder = software (x264), audio bitrate = 160, sample rate 44.1 kHz, canvas and output 1280x720 and 29.97 fps. I know it is not the best quality but at least it works for me and keeps the video and audio synched.


if using the Shoot app your source needs to be a Video Capture Device instead of iOS Camera. Then once you have the Video Capture Device added, your iOS device will show on the device drop down list. That will present an image of your device like mirroring your device to your OBS source. So you can record or stream your iOS screen, which will allow you to use the Shoot application to see what your camera is showing on the iOS screen. It will mirror any application, the reason why the Shoot application is good for this, is because it does not have any on screen buttons or settings on the screen while showing what the camera is capturing. It just shows a clean video output.

Hope this helps!
 

wpierluissi

New Member
Yeah! my issue is resolved! I downloaded and install the new version for Mac OBS ver.25.0.8 (64bit), the new iOS Camera Plug-in ver. 2.6.0 and updated the iOS app to ver 3.0.0-58, and it works. The new plug-in has additional settings, with my MBPro 13in Retina late 2013 8GB of ram the best setting was Latency=Low and Enable Hardware Decoder selected. I hope this helps! It is working fine for me now.
I had to keep the bit rate low 1500 kbps, Encoder = software (x264), audio bitrate = 160, sample rate 44.1 kHz, canvas and output 1280x720 and 29.97 fps. I know it is not the best quality but at least it works for me and keeps the video and audio synched.


wi
if using the Shoot app your source needs to be a Video Capture Device instead of iOS Camera. Then once you have the Video Capture Device added, your iOS device will show on the device drop down list. That will present an image of your device like mirroring your device to your OBS source. So you can record or stream your iOS screen, which will allow you to use the Shoot application to see what your camera is showing on the iOS screen. It will mirror any application, the reason why the Shoot application is good for this, is because it does not have any on screen buttons or settings on the screen while showing what the camera is capturing. It just shows a clean video output.

Make sure your iPhone cable is Apple brand or an Apple approved cable. If the cable is good you should also be able to record your iOS screen using QuickTime.

Hope this helps!
 

wpierluissi

New Member
Just tried a Facebook live stream with two iPhone using the updated OBS camera app. This is the first live stream since the app update and found the sound to be very glitchy. Just like the mic was being switched on and off. Had to go old school straight from the iphone.
Make sure you are running the latest version of OBS, iOS Camera for OBS and the latest iOS Camera plug-in. That solved my issue with glitchy sound and audio & video out of synch issues using my iPhone 11 connected to my MBookPro 13 Retina late 2012.
 

wpierluissi

New Member
We've been running a 24.x version of OBS on an iMac running 10.14.6 Mojave for the past three months, connected via USB to an iPhone 10 with 13.3.1 software, as a video source for Facebook Live streaming. To date, it has run seamlessly. Then, starting today, we noticed a HUGE video lag between the camera and the OBS view window. After 1 minute of streaming, the OBS view might be 10-15 seconds behind the iPhone screen, and eventually, as it fell even further behind, the video became unstable on Facebook, and we had repeated Facebook drops. I updated to OBS 25.0.8, and the problem persists. I tried upping the bit rate on the OBS iPhone client to no effect. I have log files from our repeated tries today. Any ideas?
What version of iOS Camera Plug-in for OBS you are running. I had a similar issue and it stopped after installing version 2.6.0. I selected Letancy=Low and Hardware decoder checked under the new iOS Camera device settings.
 

jessies

New Member
Yeah! my issue is resolved! I downloaded and install the new version for Mac OBS ver.25.0.8 (64bit), the new iOS Camera Plug-in ver. 2.6.0 and updated the iOS app to ver 3.0.0-58, and it works. The new plug-in has additional settings, with my MBPro 13in Retina late 2013 8GB of ram the best setting was Latency=Low and Enable Hardware Decoder selected. I hope this helps! It is working fine for me now.
I had to keep the bit rate low 1500 kbps, Encoder = software (x264), audio bitrate = 160, sample rate 44.1 kHz, canvas and output 1280x720 and 29.97 fps. I know it is not the best quality but at least it works for me and keeps the video and audio synched.


wi
ok I tried to download the iOS camera plug-in ver. 2.6.0
Yeah! my issue is resolved! I downloaded and install the new version for Mac OBS ver.25.0.8 (64bit), the new iOS Camera Plug-in ver. 2.6.0 and updated the iOS app to ver 3.0.0-58, and it works. The new plug-in has additional settings, with my MBPro 13in Retina late 2013 8GB of ram the best setting was Latency=Low and Enable Hardware Decoder selected. I hope this helps! It is working fine for me now.
I had to keep the bit rate low 1500 kbps, Encoder = software (x264), audio bitrate = 160, sample rate 44.1 kHz, canvas and output 1280x720 and 29.97 fps. I know it is not the best quality but at least it works for me and keeps the video and audio synched.


wi
ok can you tell me how to install the iOS camera plugin 2.6.0 ... I download it but then nothing... I have a Mac
 
Last edited:

Dave Hall

New Member
We've been running a 24.x version of OBS on an iMac running 10.14.6 Mojave for the past three months, connected via USB to an iPhone 10 with 13.3.1 software, as a video source for Facebook Live streaming. To date, it has run seamlessly. Then, starting today, we noticed a HUGE video lag between the camera and the OBS view window. After 1 minute of streaming, the OBS view might be 10-15 seconds behind the iPhone screen, and eventually, as it fell even further behind, the video became unstable on Facebook, and we had repeated Facebook drops. I updated to OBS 25.0.8, and the problem persists. I tried upping the bit rate on the OBS iPhone client to no effect. I have log files from our repeated tries today. Any ideas?
I have since updated the plugin, and during a two minute test, things seem to be working ok today, so I assume that was the issue.
 

Dave Hall

New Member
ok I tried to download the iOS camera plug-in ver. 2.6.0

ok can you tell me how to install the iOS camera plugin 2.6.0 ... I download it but then nothing... I have a Mac
Usually you just double click the downloaded file, and the installer should start.
 

wpierluissi

New Member
ok I tried to download the iOS camera plug-in ver. 2.6.0

ok can you tell me how to install the iOS camera plugin 2.6.0 ... I download it but then nothing... I have a Mac
Double click the pkg file to start the installation and follow instructions. You might need to accept letting the software to have access to your Mac.
Then open OBS and add an iOS device.
If you see on the New iOS Device Window the Latency field, you should have ver 2.6.0 or later already.
 

jessies

New Member
Double click the pkg file to start the installation and follow instructions. You might need to accept letting the software to have access to your Mac.
Then open OBS and add an iOS device.
If you see on the New iOS Device Window the Latency field, you should have ver 2.6.0 or later already.

ok thanks .. I have new plugin ver 2.6.0 cause has latency and encode option but still giving black screen even though it should be working... any idea why this is happening?
 

jessies

New Member
I want to use shoot app as backup since I can't figure out the OBS camera app yet that's not working for me.... I added video capture device but my phone does not show up on drop down list to select
 

jessies

New Member
ok so I figured out how Iphone OBS camera app went from black screen to working but not sure why and if I can fix it.... I apparently have to have my webcam connected to MacBook Pro Catalina for my iPhone OBS camera app connected with USB to work... Does anyone know why this is happening?
 
Top