OBS Freezing

kvittaz

New Member
Hello!

I'm having an issue where my OBS starts freezing. This issue started after the latest update, It wasn't that bad to start out with, only freezing now and then when I was working on adding new sources after the streams and so on. Then it started freezing almost exactly 2 hours into my streams for 3 streams in a row. Today it froze 5 times in a matter of 30 minutes.
When these "freezes" occur only the stream preview freezes. Chat and the audio mixer keep going. And about 2 seconds after that my stream disconnects from twitch. When it happens the only way to close OBS when it freezes is to close it through the task manager. Trying to close it by just clicking close will make the OBS turn white and unresponsive.

I've tried to verify the files, removed a plugin that I was not using, and updated all my drivers, but it just seems to get worse.

Hope somebody here can help me! Thanks!
-Kvittaz

My hardware:

i7-12700kf
Gainward 3080 Phantom
1 TB m.2 sdd
Windows 11
 

Sweepy00

New Member
I'm having the same exact problem. The thing is, I'm just using virtual camera. And it seems to freeze randomly! Drivers updated, reinstalled several times. It seems to only do it when I either I exit out of a game or a game starts up, or a process randomly stops.

I hope there's a fix for this because it's getting frustrating

I have
Ryzen 5900
RTX 3080
32GB of RAM
 

Gladicek

New Member
Same issue. Updated drivers, reinstalled OBS... might be related to Windows 11 22H2 update. Looking forward for some fix as this is really annoying issue.
 

rcarsey1

New Member
Ughh.. I've had a very similar issue beginning in early November 2022 and the timing coincides with the Windows 11 upgrade from 22H1 to 22H2. I stream to YouTube HLS and the stream disconnects after approx 3-5 hours. The preview freezes. The only way to make it work again is to close OBS and restart it.

Things I've tried: Re-install nvidia drivers (latest) without the GeForce Experience, upgraded NIC drivers, completely removed OBS and re-installed/upgraded

Current environment:
Ryzen 5 3600 / 16GB RAM / Win 11 Pro (upgraded to 22H2 on 11/5/22) build 22621.819 / Windows Feature Experience Pack 1000.22636.1000.0
NVIDIA GeForce GTX 1650 (v526.98 download; driver v31.0.15.2698 from 11/13/2022)
OBS 28.1.2 64-bit
NVENC encoding (tried both HEVC and H264)
YouTube HLS stream (also tried RTMP)
Using hardware decoding (I'm showing video from a security camera that is H265)
4k/30fps stream
Only plugin is gstreamer (which, for now, I've changed some video settings to use OBS native "Media Source" -- as I thought perhaps gstreamer had an issue.. doesnt seem to make a difference)

Log file attached. I have a clock displayed on the video.. and it froze around 23:50.
 

Attachments

  • 2022-11-20 23-49-49.zip
    87 KB · Views: 10

rcarsey1

New Member
Ughh.. I've had a very similar issue beginning in early November 2022 and the timing coincides with the Windows 11 upgrade from 22H1 to 22H2. I stream to YouTube HLS and the stream disconnects after approx 3-5 hours. The preview freezes. The only way to make it work again is to close OBS and restart it.

Things I've tried: Re-install nvidia drivers (latest) without the GeForce Experience, upgraded NIC drivers, completely removed OBS and re-installed/upgraded

Current environment:
Ryzen 5 3600 / 16GB RAM / Win 11 Pro (upgraded to 22H2 on 11/5/22) build 22621.819 / Windows Feature Experience Pack 1000.22636.1000.0
NVIDIA GeForce GTX 1650 (v526.98 download; driver v31.0.15.2698 from 11/13/2022)
OBS 28.1.2 64-bit
NVENC encoding (tried both HEVC and H264)
YouTube HLS stream (also tried RTMP)
Using hardware decoding (I'm showing video from a security camera that is H265)
4k/30fps stream
Only plugin is gstreamer (which, for now, I've changed some video settings to use OBS native "Media Source" -- as I thought perhaps gstreamer had an issue.. doesnt seem to make a difference)

Log file attached. I have a clock displayed on the video.. and it froze around 23:50.
As an update to this problem.... It seems that if I turn off the Preview, I do not encounter this problem. My YouTube stream had been going for a full 24 hours now. ‍♂️
 

JohnBBeta

Member
I have the same issue, it seems to only reliably happen on one of my scenesets, but others not yet... on a win 11 PC, I had held off updating to 22H2 and it happened before, I ran the 22H2 update and it still happens. Most recent v of OBS, advanced scene switcher only extra plug in used and is most recent version. V high end PC. 5950x / 3090.

is anyone on win10 encountering this? I am seriously considering clean installing 10. (This doesnt happen on my win 10 machine)

PS Big up the escape from tarkov masssive
 
Top