Question / Help OBS Frame Stutter (Single PC)

Heyez_94

New Member
Yo Guys,

At first, i want to say that this is more complicated than most of you guys are thinking (i hope i am wrong), i am trying to solve this nearly for as long as is know.

Ive got a multi monitor Setup,

1x Samsung TV (1080p,60hz) - connected via HDMI
1x Terra 24" Monitor (1080p, 60hz) - connected via HDMI
1x Acer Predator 28" Monitor (2160p, 60hz, Gsync) - connected via DP


My Specs are:

CPU: i7-8700k (OC to 4,8 GHZ)
RAM: 4x G-Skill DIMM 8 GB (3,2 MHZ) = 32GB
GPU: Asus Rog Strix RTX 2080, Driver Version: 440.97 (tested the last 3)
Windows 10 Home 64 Bit: Version 1903


My 3 Displays are all connected to my 2080. They are all set to 60hz in Windows and NVCP.
Lets talk about the Issue.


Like ive written before, my Monitor which i am mostly using for gaming is the Acer Predator. I mostly play World of Warcraft in 4k on Max resolution, capped normally at 59,9 fps (Gsync & Vsync enabled in Nvidia Control Panel) to get the most out of its performance and i am very proud of the quality.
My 24" Monitor do i use for OBS, Chat, etc. My TV is for Youtube, Movies etc.


Since the RTX cards are very nice when it comes to stream quality, especially if you downscale 4k to 1080p, I want to stream my content sometimes for friends and other ppl out there. Like mentioned in the title i use OBS, sometimes Streamlabs OBS (tried Nvidia Shadowplay as well) for streaming, recording and so on.

So normal scenario:

I start my PC complete fresh after a 10 hour break and open nothing except OBS64 bit version (running as admin) and World of Warcraft. I did a fresh setup on OBS, so there are no other scenes and no other sources than my Game Capture of WoW. So there is no way to interfere with a stupid other source or whatever. I opened Windows Task Manager to look on my CPU / GPU / RAM stats.. there is nothing rly bad happening. My CPU is aroung 20-25% usage, RAM around 25% and GPU around 10-20%. For Understanding, i use everything on Ultra, 4k. AA disabled since you dont need it on this resolution, there is nearly no difference. Vsync and Tripple Buffering (in game) disabled. FPS CAP disabled. Gsync works perfectly. When i Use the preview from OBS my CPU stays at 20-25% usage, my GPU jumps up to 30-50% usage. When i fly around and doing stuff and Things, hitting Dummys to test frametime and stream quality there are really bad stutters in the Image. My GPU never hit any point above 80% or something like that.

Here is a link to see what i mean: https://www.twitch.tv/videos/498408014 - i mean this is a common issue. Lets figure it out guys.

OBS Settings: Nvenc NEW, CBR 6k Bitrate - https://www.speedtest.net/result/8697668805 , Keyframeintervall set to 2. Preset: Max Quality, Profile: high, Look- Ahead and Psycho-Visual Tuning enabled (i guess LA AND PVT both improved it a little bit but this could be deceptive), GPU: 0, Max. B-Frames: 2.
For Output i use : Base canvas resolution: 3840x2160p, Downscale it with Lanczos (tried also with billinear and bicubic, seems not to change anything) to 1920x1080p. FPS: 60 (tried 30, 50 and 59,94 fps - didnt change anything). Process Priority set to High (tried to use normal and higher as normal as well, nothing changed) Also use the browser-hardware acceleration, but I guess this is also not changing anything if i would disable this one. I also changed the downscale to resolution to 1440p and 720p to make sure its not a downscale issue.


On the video i posted before, twitch says 2 skipped frames every 20-30 sec i guess. Obs is using around 0,2% - 1% of the CPU Usage, 0,1 - 0,2 Ms to render frames. and no skipped frames as well or lagged frames or whatever.. it stays at 0 all the time. But it stutters a lot.

To repeat - here is a link of smooth gameplay: https://www.twitch.tv/videos/494932714?filter=archives&sort=time this on i streamed with Display Capture (Gsync is automatically disabled when using Display Capture in OBS - i tested this with NVCP Gsync control) But, this configuration is not an option for me, because i yeah, i paid the Gsync option, and without i have very bad frame drops especially in Raids (also with Graphic Settings set to 1 and everything disabled) Especially on Boss Fights where pretty bad stuff is going on like Queen Azshara - https://www.twitch.tv/videos/495443831?filter=archives&sort=time - at 14:20 you can see for example the FPS (left corner) is dropping down to 30. This is like Pain in my A... and when i disable Vsync i would get pretty bad screen tearing.

So what ive figured out about this is, without Gsync and constant refresh rates (thx to Vsync - also tried Fast sync) the Stream is running perfectly but the game suffers from it. So it cant be an option for me. Back to the actual Problem.

Like i said i am working on this for months, have read every single thread to solve it. I tried things like Capping the Game FPS using RTSS (Riva Tuner Statistics Server) but when i try to use RTSS, OBS is like losing the Game Capture and shows only a black screen. Display Capture is no option because of it disables Gsync in time when i set it up in OBS immediately. There is no way i know to use it (but i would prefer Display Capture for Content creation - so if anybody has an idea - would be nice).

With RTSS i tried to cap my FPS to like what the Blurbusters said. 3 FPS below your actual refresh rate so that it never hits above your monitor refresh rate and vsync doesnt kicks in and gsync is always enabled. In my Case 57 FPS.
Because of Came Capture isnt working with RTSS i tried to use the ingame FPS Limiter for capping to 57 FPS in Front and Background.
This also did not stopped the Stuttering from occuring. So I disabled the FPS limiters. That did not help me.


I tried also to restart my PC with only my Main Monitor active and made sure that only 1 monitor is connected with my GPU. Also no Improvements.

To make sure what i am talking about, i got stutters in the obs preview (enabled or not) - no detected frame lags or something, with nearly no GPU Usage. This is also the Problem with x264 or Nvenc old and Nvenc new.. Streaming, recording or whatever.. it just stutters from the Gsync refresh rate i guess.
Here is a picture from the Task Manager while streaming https://prnt.sc/pn211r .


Also Here is the last stream and OBS log for it:
Video: https://www.twitch.tv/videos/498419482
Taskmanager: https://imgur.com/a/KOkqFp4
OBS-LOG: in the appendix


I am using the newest OBS Version 24.0.3 64 Bit. And also the newest Version of Streamlabs OBS (dont know which one is it now).

I tried nearly everything to find a fix for this, have read every single thread to solve it but yeah.. havent found any but i won't give up.
So i am ready for you guys.. hit me up with ideas.. lets talk about.. and if we solve that problem.. there are many ppl out there which will profit from it.


I hope i dont hear stuff like "did you update to the newest driver?" ^^ I guess i am pretty maxed out when it comes to ideas. But whatever, i am thankful for any advice.

Thanks for now..

Heyez_94
 

Attachments

  • 2019-10-23 14-29-17.txt
    12.3 KB · Views: 13
Top